Remotec ZXT-600 AC Master

Hello folks. I’ve been using the Remotec ZXT-120 for about a year without any issues. I wanted to get a second one for my bedroom but Remotec seem to have updated these with the ZXT-600, so I ended up buying those instead.

I was able to add the ZXT-600 to my Smartthings (V2) hub, but the default ‘Z-Wave Thermostat’ handler doesn’t work for it, and I can’t find a custom Device Handler for this device at all. I have also tried setting this up as a ZXT-120 but that doesn’t work either. Manufacturer’s website doesn’t seem to provide any support. Any help on this would be much appreciated.

@mandilpradhan
I downloaded this custom DTH from their website before they hid it. Try it.

2 Likes

Thanks a ton for this. I wonder why they’d hide this along with the online manual but still continue selling the product.

Glad I could help.
I don’t think they hid it on purpose. It’s more like they have problems with their newly designed web site. There are no working links on it.

1 Like

Has anyone been able to get the zxt-600 working with a scheduler to control a mitsubishi mr slim mini-split? I have tried many apps; virtual thermostat, 5-2 thermostat scheduler, and now troubleshooting scheduletstatzones and haven’t had any success.

Thanks for any insight.

Hey - do we have any experts on this product?? I’m normally quite adept and sorting this things out but this one has me beat at this point.

The best thing I have manged is to ONCE get my Airwell ACs to turn off - that’s it!

I have managed to get the ac-code list & the (badly written) smartthings guide from - https://www.remotec.com.hk/zxt600

There is a v5 of the custom DTH but it hosted on baidu and I just can’t download it, so i’m using the v3 from this tread. I’ve followed the instructions, coded each ‘storage location’ etc etc. Tried all the Airwell AC codes, tried code 000 as suggested by the manual for when you ‘learn’ all the IR codes etc. - nothing work. The unit will blink, so IR is being sent (in theory) but nothing.

Any help appreciated.

Are you saying you have tried the DH linked above? NomadTech provided a link to the Google Drive where this DH can be downloaded… Not perfect, but works with Hub2, App v3.

Yeah - i used the one provided here.

I guess what’s confusing me are the instructions are from remotec (the ones i linked to) where it says to first use of of the AC codes (still not sure one matches my model tbh), program the 32 IR codes (i did that), and then code the unit to code 000. I did all of that and nothing. I tried ignoring the last step just in case and again nothing. Clearly i’m missing something!

I gave up on it and returned the ZXT600 to amazon. I got it to barely work (turn AC on and off). Not worth it.

I gave up as well and returned the ZXT 600 to Amazon. I’m moving to Sensibo that seems to be much more advanced with a similar price.
In case this can help, Remotec customer service sent me the V6 of their DH. It’s clearly better than V3.

This is a link. Hope this is helpful

Hi @mandilpradhan did u managed to add remotec zxt 600 into smartthings? I took the device handler from this link ZXT-600 created it and can even add a virtual device to make it appear on my smartthings. but just cant seems to find the actual device to get it to work.

@Hyunvic: I ended up returning the ZXT 600 and ordered the ZXT 120 that I knew would work since I already had one.

FWIW, I was able to get the ZXT-600 working with Smartthings using the DHT from Remotecs website and a bit of work. The DHT basically worked as is once I found the right code (1853 for a Mitsubishi msz-gl).

The one real issue with the DHT code was it wasn’t delaying the messages sufficiently when setting the mode. Changing the delay to 2300 on L1110 fixed that and now it seems to work. (It might have to do with running on battery vs microusb power?) Here is the DHT that works for me (YMMV).

Did anyone get this working properly? I ordered the ZXT-600 to have a play around with and can add it to ST no issue using the DH in this thread, V. 5 I think. But, when I try to issue a command, I get “A network error or server error occurred, try again later”. So I don’t think I am even up to the point where the remote code is required, but rather it’s not communicating properly.

I do have it working, but just barely.

In particular, the “new” Smartthings app doesn’t support the UI from the DTH anymore (and my understanding is that there is no easy workaround for this). I did just manage to reset are re-add one of the ZXT-600s (which I have to do when the battery runs out). I procedure I used was:

  • Add the DTH in the IDE.
  • To add the device: go to new device and select from the “by brand” menu any random zwave device (doesn’t matter which, but the “scan nearby” button did not work). Then triple click the prog button, and if you are lucky a ZXT-600 will be found.
  • Open the new device in the app, and open the settings menu. Set the remote code and 0 temp offset.
  • Go back to the IDE, run the simulator, connect it to the new device, and press the “configure” button (this should send the device code, and you see stuff, not errors, in the logs). (Watch the ZXT-600 – you should see the green light hold steady for a few seconds).
  • Now things should work (provided you had the right code for your AC, which you probably won’t since all they give you is a list of random codes per manufacturer).

This is all a complete hack, and maybe there is some power user here who understands a much better way to do this (or how to update the DTH UI for the new app).

1 Like

Manage to get it working. “New smartthings app” doesn’t support UI define in DHT, thus a lot more command & field not being displayed.

Mention above by SmartthingsUser, going to simulator at DHT manage to learn IR code. Using v5 DHT on Remotec meant for “Old smartthings app”

  1. In simulator, open the setting menu, scroll to the bottom of page, there’s a slider for configure learning position for “Parameter value”
  2. Close setting and scroll down there’s a command box to “issueLearningCommand”
  3. After done learning, set remote code to 0 and press configure.

Now remote will use the learn code. After setting up, I change to “Z-wave battery thermostat” as daily DHT as it have better UI.