SmartThings Community

HVAC IR Extender (Remotec ZXT 120) (2014)

dth_hvac

(Boris M) #1

Does any one use Remotec Z-Wave ZXT-120 IR Extender for Air Conditioners Model: ZXT-120?


Easier way for smartthings to control ir devices?
Looking for IR Extender Z-Wave products
Air Conditioner controller working with ST?
Anybody have equipment capable of learning/exporting an IR code, help please?
Suggest a Device
Multi Sensor Temperature
208/230v Wireless Outlet
(Brian Dahlem) #2

I am. I just created a device-type and posted it on GitHub. I also started a project to keep track of the file.


(Boris M) #3

How does one gets AC codes programed into this thing?


(Brian Dahlem) #4

For the manufacturer code, go to preferences in the thing’s settings and enter the code, click “done” and then click configure.

If your manufacturer isn’t directly supported, I haven’t implemented the learn function yet. I lucked out and found that my mini-split uses the same codes as another brand. I’m trying to think of the best way to go about learning codes using the SmartThings UI.


(Boris M) #5

Thank you. I’ll try it thursday and report back :slight_smile:


(Boris M) #6

I am not sure what exactly you mean by “go to preferences in the thing’s settings?” All I see is configure, I do not see preferences or settings.


(Brian Dahlem) #7

If you installed the ZXT-120 Device type, preferences should show up below the configure tile, next to the activity tile.

Could you go into the graph.api.smartthings.com site, and make sure your device in the My Devices tab shows up as a “ZXT-120 Thermostat” rather than a ZWave Thermostat?

Brian


(Boris M) #8

Brian, my bad. I was looking for preferences in my phone app. I do have preferences and was able to input a code, but device is not responding at all. The log shows that activity ended as soon as I changed device type from ZWave Thermostat to ZXT-120 Device type. I guess I need to reset ZXT-120 and see what happens.


(Brian Dahlem) #9

I updated the code to improve polling, please let me know if things are working for you.


(Ultrathew) #10

Brian - Thanks a ton for taking this on. I just purchased and set up a ZXT-120 using your device type code, and it’s working beautifully with my Mitsubishi Mr. Slim unit. One question I have: I only use my Mr. Slim for cooling, nothing else. Can I modify the code to just remove the other modes (heating, drying, etc) so I’d be able to easily just toggle between “Off” and “Cooling”?


(Brian Dahlem) #11

@Ultrathew, there are two things you can try. First, there may be a code for Mitsubishi that works for your Mr. Slim unit that only offers cooling. The second option is in the code, on line 179 is a list of modes… if you change it to:
["off", "cool"]
it should work like you want.


(Rohan) #12

@bdahlem Thanks a bunch for adding this device type in smartthings. Its working great with my mitsubishi mr slim unit. The only problem I see is that the temperature sensor does not show any reading on my android devices, it works fine on iOS.

Any idea what might be the problem?


(Darren Bellouny) #13

Brian,

Just got my ZXT-120 going with your code. I cannot thank you enough. The only issue is the code I tracked down the set point reported on the app does not match the unit. It may be incorrect manufacturer code I am doing more investigating. I finally have control over my mini split thanks to you. Now if I can track down the perfect code I’ll be set.

Darren Bellouny


(jening) #14

Hello, can somebody show me how to configure the ZXT-120 on SmartThings. I have added the device, but cannot enter the configure menu. Thanks


(Ron) #15

Can you be more specific, what is your issue ?
The “configure” button sends the zwave configuration.
The “Preferences” button opens the preferences dialog to change your preferences.

NOT: Preferences are broken right now. You can follow this thread to see when it might be fixed


(Richard) #16

Can you tell me what code you used for your Mr. Slim unit?


(Ron) #17

I did on other thread but in case someone else reads later I am using 176


(Richard) #19

I can’t get the code changed. Won’t stick.


(Ron) #20

You using my code ?

If so then a few things.

  1. unit should be in always listening mode. You need to configure this “BEFORE” you include it. So if not sure exclude it using ide (don’t just delete), then read manual to configure “Always Listening” mode and not FLIRS mode. In FLIRS mode the config gets missed if it isn’t listening and I had issue making it work.
  2. after setting parameters you have to hit “configure” to send the new values.

I also have a new version I am working on. It’s a little nicer interface, had fixed buttons for fan speed modes along with a report back display tiles.
I need a little more work on the fan buttons because they current turn on the unit. I want them to just set the mode and send the signal to the unit when cool, heat, etc is selected. So watch for new versions in near future. Here is the current modified version

It looks like this now.


First row is temp tile, battery tile, temp tile with name (I might move these lower)
Second row is Last Issued Mode, Last Fan Setting, Last Swing Setting
Third Row is Discreet Cool Button, Discreet Dry Button, Discreet Heat Button
Forth Row is Last Issued Cool Temp, Off button, Last Issued Heat Temp
Fifth Row is Discreet Fan Modes LOW,Med,High
Sixth Row is Auto Fan mode, swing on, swing off
Seventh heat temp, slider (slider bug doesn’t initialize told by ST this is fixed)
Eighth row is cool temp, slider (same bug)
Ninth row is last poll time, current config reported, offset reported
tenth refresh, configure, smartapps
eleventh preference,activity


(Richard) #21

Thanks Ron. That’s super helpful. I am using your latest code, but the unit was in the FLIRs mode. I’ve changed it. But I still can’t get the code to change.