SmartThings Community

Remotec ZXT-120


(Dan) #5

For what it’s worth, I have not (yet) been successful in getting it to communicate with any of the 3 air conditioners (all different brands listed in the documentation). I’ve also used Brian’s code base to try and expand it to use the 000 “learn” mode, but haven’t gotten that to work. I’m not an expert with the IDE so it is very possible this is due to my personal learning curve.

I also want to add in a tempoerature off-set.

I do appreciate Brian’s work on this!


(Viking) #6

hello! I was trying to get ZXT-120 to work, but I am not able to. I was got Brian’s code and added the device, then, I was able to add the device. But the device seems unresponsive after that. It does not read the temperature nor it accepts any command. I did add one of my AC codes to the app and hit configure, but nothing happens. Any ideas on how to make it work? I do use my hub in Celsius.


(Mike O'connor) #7

Hi all - I was able to get this working with my pioneer split ductless ac/heater. Pioneer was not one one of the supported brands from remotec so I had to do the following:

  • change the device type code to send the remotec a remote code of 25. This is line 223 of the current version of the device type.
  • this puts the remotec into learning mode and you can program it using your existing remote following the instructions provided by remotec
  • after your done teaching the remotec go back and change the remote code in the device type back to 27
    You should then be all set.
    This would be a nice feature to add in the st interface for this device type :smile:

(Ron) #8

I am trying the device code from @bdahlem for my Version 1.6H ZXT-120 but it’s not working.

It doesn’t display temp reported by the zxt-120, several modes don’t work. Off doesn’t work which is one of the main modes I want (auto off in the morning), only cool and heat work in that they turn on the unit but I can’t really tell if it is in the correct mode since unfortunately Mitsubishi Slim’s have no method of feedback for the current mode/setting engaged.

I am also confused because the thread says the code doesn’t work with learning but the code setting has a label which states set to 000 for learned. I plan to edit the device and add try to add a learn button which issues the code 25 and the various values to let the device learn. Not sure how I am going to do that but I have a few idea. Mainly just add another Preference for Learning code.

I know the AC code I am using (176) is correct at least for Cool/Heat/Off because I used to have this device attached to my veralite. It only allowed Off/Heat/Cool so I am trying to move it to my ST Hub for dry mode as well.

Does anyone have this code working ?
Has anyone modified it and can share a updated version ?

If not I will start playing with the code to see if I can fix the issues I am having. I plan to change it from a mode which toggles to independent buttons for each mode. That is what the veralite has so I know it is possible. I at least want a discreet on/off button. The remote for the slim has on/off and mode separate however I think the remote just maintains the last mode and sends that signal when turned on.


(Ron) #9

Hmm…When I try to set a new task to shut off the Heat in the morning it only offers set cold temp and set hot temp. This isn’t really a thermostat as much as it is a control device. It sends IR signals for ON/OFF/HEAT/AC/DRY/ETC, Set Temp is really for the AC unit then the AC unit’s thermostat does the job of maintaining.

I just want rules such as
At 7AM set mode "OFF"
If Temp reading > 80 Set Mode Cool and set temp 75 (which will also turn the unit on)
If Temo reading < 60 Set Mode Heat and set temp 75
ETC

That is how I used it in the VeraLite, but this device code only lets me act on temp setting. It doesn’t let me change modes.

I think I need it to behave more like a switch with many settings. Or perhaps I just need to add smart apps for this device ? Not sure since I am new to this stuff…


#10

Hi Ron,

I had the same issue with the ZXT-120. I wanted to use is as a switch but couldn’t get it to work.
To solve it I wrote a Device Type (a virtual switch) and a smartApp. The smartApp is subscribed to the events of the virtual switch and calls the commands of the ZXT-120 in a handler. The trick is to control 2 devices from your smartApp. In order to do this the smartApp must be capable of handling multiple devices. You can only add one capability to the smartApp preferences, so I added the capability: thermostat (which ZXT-120 also has) to the virtual switch. Now I can just turn my AC on and off using the button of the virtual switch and I can use the switch for actions.

Hope this helps you!


(Ron) #11

Thanks, I already did the same. I have posted my updated version here in different threads. But thanks for replying.


(Mike Foley) #12

Mike, did you ever figure out how to program the Pioneer? I can get it to turn off but not turn on or change temps. Any help is much appreciated.

mike


(Mike O'connor) #13

Hi mike- I have had limited success with the pioneer - I get it to change temp- sometimes- then other times I get no response from it. How did you get it to turn on/ off? Does it work consistently?


(Brian Dahlem) #14

@mikefoley, @drummerboymike I don’t know if it will help now, but my mini-split was a pioneer as well. I used remote code 40 for it, and it controlled it without learning.


(Mike Foley) #15

Hi Brian,

I tried code 40 but it didn’t work for me.

I wish there was something better than this.

thanks,
mike


(Mike Foley) #16

Ok, so I just sat down and started banging away at codes… And found one that worked!!!

Try code 70. It’s under the brand name Yutu.

I’m so pumped now!

mike


(Mike O'connor) #17

Thanks Brian, that code seems to work perfectly!


(Aaron Fisher) #19

Has anyone been able to integrate this with IFTTT or build better triggers to turn on/off with lights and such?


(Ron) #20

You don’t really need IFTTT you can just write a smart app. Something like Big Switch which watches on switch and drives others. Instead watch one switch and call Thermostat cool, off accordingly. Actually in my version of the device code I have on mapped to cool so you can literally use big switch and just treat the ac like a switch. I have my AC integrated with my Harmony Remote and my Amazon Echo using on/off in this manner.


(Ervest) #21

Hello

i already pair the remotec zxt-120 with samsung smartthing hub, but when i tried to configure a new code nothing happen when i press the configure button.

any help with this?

My AC unit is a panasonic. There is any procedure to enter the code manually to the IDE?

thanks in advance.


#22

I downloaded @bdahlem code from Github (device-type.zxt-120.groovy) and added it to my SmartThings. I followed the included instructions. I then went to the configuration and entered the Remote Codes corresponding to my AC. I find it hard to believe that none of them worked. I am not sure if I’m doing something wrong. I have a Sharp window air conditioner. I entered each of the codes, then pressed the “configure” button and tested sending commands to my AC, but none responded. My ZXT-120 was already associated with my SmartThings before I downloaded Brian’s code from Github. I simply went and changed the device type to what is indicated in the instructions.


#23

Try the following thread instead, it has some improvements on the original:


(Vineet) #24

What is the max length of Cat5 cable I can use with the IR extender port on the Remotec ZXT-120 ?


(Mark) #25

It’s a pretty low power device. You might want to check with remotec and see what they say.