Remotec zts-110 with new smartthings app

The zts-110 s that worked just fine with the old smartthings app, don’t work well in the new app. If I try and change the temp in the app I get an error. “Couldn’t connect to thermostat, try again later.” Anyone have this device working with the new app?

I am trying to connect this exact thermostat to my V3 SmartThings Hub and am getting the same error message. I selected the Stelpro Ki (Z-Wave) during setup. Following this…

Are you saying this worked better?

No. I was just giving some detail about how I set mine up. I am experiencing the same error as you and looking for a solution.

I added the device automatically. I used the IDE to change the driver from a z-wave thermostat to Stelpro Ki (Z-Wave). And that seems to have fixed my issue. No more timeout.

That’s great news. I may need some additional direction as to how you did all this as I was not given the opportunity to add the device automatically and I’m not sure how you went about changing the driver. Are you using only the SmartThings app or do you have some other type of program to do this?

The IDE is a website from smartthings that allows you to make changes to your smartthings that the app does not allow.

Chris, I was able to make the changes per your instructions. It took awhile before things started responding properly, but I did notice that I no longer have a fan control setting. There is only a heat and and Eco setting, no A/C mode. Also, Alexa keeps saying the thermostat is not responding even though I see the setting change. Any thoughts? Maybe the Stelpro Ki is not the right setting.

I have a ticket in with smarthings. What this demonstrats is that the generic zwave thermostat is faulty. I only use the stat for heat and it’s a boiler so no fans. If they give me another fix to the zwave thermostat, I will respond here.

Are there any better options with this? I am trying to change the temperature using the new app and it just tells me there is a network error. I am using the generic handler currently.


Its not a supported device. I have two myself. I have tried several device drivers, and found none that make it work with smartthings. It worked with the old app but samsung left it behind.

I thought I was using a generic handler but in fact i am using this which worked fine with the classic app.

I am getting the information from the thermostat but I cannot change the temperature.

I changed the device type to “Z-Wave Thermostat” and now it is working. Yay.

I use the rboy device handler and it works no better.