Newbie: how do I change device driver from default Z-Wave Thermostat?

I paired a RadioThermostat CT32 (with Z-Wave module). The default assigned driver is “Z-Wave Thermostat”. It works ok locally, but when using ST app on my iPad or iPhone from a remote location, I cannot change the temperature setting. If I tap on temp control’s up or down buttons, it displays the new temp setting - then progress gear spins for about 10 secs, then reports “a network or server error occurred. Please try again” - then the display reverts back to previous temp setting…

Could it be the driver? I’ve read some folks have had luck by changing the driver to CT100. So I tried by going to the “Advanced Users“ page and drilling down to this tstat device. The Driver drop down box only lists 9 drivers, none of which look to be for a tstat. So how do I find the CT100 driver?

Mulling this over more, since it works locally, I doubt this is a driver issue. More likely a communications issue…

Are you using the c wire to power it or are you using batteries? If your using the batteries then yes, it is probably a range issue. I have a few Ct100’s that I have no way to run a c wire to and I’m using batteries on. The Zwave module goes to sleep and you need a reliable Zwave beaming repeater within 5 feet or so to wake it up so it gets the command. I use some GE Zwave Plus pocket sockets and it works for me. I use the Z-Wave Thermostat driver and it works fine.

To change drivers, you would need to search the forums for your thermostat model and see if someone else posted that they have found a driver that works for you thermostat and then see what driver they used. If it is a custom driver then you have to find the developers channel invite link and then you would follow the link and enroll your hub in that developers’ channel and then install the driver you want. If you need more help with installing a custom edge driver then let me know and I will try and explain in more detail.

I am using a 24 volt transformer to provide power to this tstat.

The odd thing is that it is reading values from tstat, but probably only when tstat decides it’s time to check in (as opposed to ST hub requesting data in realtime).

I just tried to change fan mode to ON, but same network or server error. So it’s not just the temperature buttons that have this problem - looks like nothing can be written to tstat over Internet (I’m away from home).

The fact that it works fine locally tells me the driver is not the problem. Nor is it a Z-Wave signal strength issue. So, my thought is that it’s a communication issue with ST’s server(s) when working remotely over Internet. I’d bet the default Z-Wave Thermostat driver I’m using is capable of working totally locally (when I’m home), but when away, something is broken/incompatible in the remote communication layers with ST servers…

I wonder if there is any way to turn on logging for this device driver? Currently nothing shows in the LOG page after I try to change temperatures or other tstat settings (when working remotely). All I see is periodic temperature data that the tstat reports to my ST hub…

If you can control the thermostat locally then it doesn’t matter if you are down the block or in India. As long as you have an internet connection and can connect to the SmartThings cloud then you should be able to control it. When you’re at home and using your home internet connection or 8000 miles away it uses the same connection method. It has nothing to do with the driver or Zwave etc. You need to do some testing when your home or at the location where the thermostat is installed. Make several tests while you are connected to your home wifi and then make several tests when you have your wifi shut off and using cellular data. It just doesn’t make sense!

1 Like

There’s always been so many oddities and nuances with ST - that’s why this 40+ year IT guy hasn’t messed with ST in last several years.
It’s much more of a Plug-n-PRAY product as opposed to a Plug-n-Play one… :slight_smile:

I’ve no clue how ordinary folks can possibly use ST with much success. Guess it’s really targeted mostly for gurus…

1 Like

Good idea to test at home using iPhone, once with wifi and once with cellular :+1:

I recently ran into a scenario where my iPad would timeout after 45 secs at the initial ST app’s startup screen whenever I tapped on [Sign In]. Turned out I had to enable my default browser (Firefox) to be able to run in the background. That presented somewhat like my tstat problem, where the spinning progress gear just kept spinning…

Years ago when I contacted ST support about the Sign In problem, they told me to clear cache. That had no effect. It was only the other day when I thought of checking whether browser was enabled to run in background that this several year old problem got fixed…

You’d think ST developers would perform a check for background operation being enabled - and if not, present a dialog to user telling them where/how to enable it…

LOTS of nuances :slight_smile:

1 Like

It’s really the other way around. Remember that over 90% of smartthings customers don’t have a standalone hub. (They have a Samsung smart appliance or television or Monitor). and even most customers who have a standalone hub have 15 or fewer devices, and use no custom code, as smartthings employees have mentioned multiple times.

So most smartthings customers are only doing plug and play. If it works for them, or it doesn’t.

Of course, the majority of people in this forum are power users. They may not be programmers, but they are doing a lot more than the typical smartthings customer does. And those are the situations where you can run into a lot of strange results. :wink:

1 Like

It probably won’t matter whether you’re using Wi-Fi or cellular, because the smartthings app always requires an Internet trip to the smartthings cloud, even if it’s on the same Wi-Fi as the hub.

They didn’t have to design it that way, but they did. There is no local communication between the app and your devices. :thinking:

1 Like

I’m puzzled/disappointed that my ST hub doesn’t work totally locally when trying to interact with relatively simple devices like my tstat. When I use app (at home) to raise tstat temp a degree, it would be smarter for app to talk to hub directly(wifi), then hub talk directly to tstat (z-wave). I see no advantage in involving cloud in this case. There are downsides to involving cloud, such as during an Internet outage or ST server outage…

1 Like

I think this to myself all the time. How is the average consumer going to make this work when there are so many different issues! If they don’t find this forum or have any idea where to start troubleshooting a problem then if they purchased a hub they will return it or if it was an appliance, TV etc then Samsung just lost a customer for life. I was a field tech for Samsung from the mid to late 90’s and the whole corporate strategy was let’s impress the customer and we will keep them for life. Brand loyalty was their number one goal. Things changed around 2009 or 2010 and they went the opposite way and decided that they would rather make a quick buck instead. Now their trying to integrate ST in all the new appliance’s and home entertainment systems. This will alienate more customers then they will keep if they don’t start hiring better developers and stop changing stuff that is not broke. I was really impressed with how things were going earlier this year and how things got much better. This all stopped in mid-September as everything started to break again. Now there seems to be an endless problem with Zigbee, battery drain, SLGA as well as a bunch of other things. A lot of people don’t understand why the devices they purchased with Matter certification won’t work when that’s what the promise was. Its getting to be a mess again. If it was not for these forums and JDRoberts, jkp, h0ckeysk8er and many others I would have chucked my ST hub and moved on to something else. I try to stay loyal to Samsung but my patience is wearing thin.

1 Like

I’m thinking it doesn’t. I have seen a definite uptick in posts on here coming from people who went out and purchased their shiny new appliance with promise of home automation to find out it doesn’t work!

1 Like

Many of us feel the same way. As I mentioned, they didn’t have to design it this way (where the app always has to go through the cloud first), but they did. :man_shrugging:t2:

Apple Home is a good example of a nice user-friendly home automation app which doesn’t require an Internet connection once everything’s been set up as long as you’re on the same local Wi-Fi. So it can definitely be done, and be done by big global companies, but obviously Samsung is aware of that, and has continued with their cloudbased Model for over 10 years.

Maybe Samsung will change it someday, maybe they won’t, but that’s up to them. For now, it is what it is.

You’re certainly welcome to question it (and doing so on their public facing official channels like Facebook or Twitter/X will at least get some attention from marketing), but meanwhile, we just have to work with what we’ve got.


Yeah, that’s a whole separate issue. People not even being able to set up a new appliance is obviously a brand disaster, i’m not sure why we’ve been seeing so many more of those since August, but there definitely have been more.


Most of us on these forums are using advanced Smart home integration and switches and sensors and really have no idea what to tell them when they can’t trigger their new ice maker to make 3 cubes when the light comes on. LOL

1 Like