Remotec Z-Thermostat (configuration with Z-Wave Commands)

Thank for your response. Does anyone else use this thermostat on battery?

The manual states that even in FLiRS mode, the setup and operations are the same. Maybe I’ll try and reset it and see if it still does not update regularly.

Hi Mclovin50,

I had the same issue you are having with my thermostat not reporting. See my posts above regarding association groups. I don’t really understand them thoroughly, but apparently the thermostat reports only on association group 3 but the smartthings hub only associates with group 1. So I had to send a configure command to the thermostat to get it to report on association group 1 instead. Here is the command that I used in the device profile to change the setting. Once I sent that it started reporting as it should.

“zwave.associationV2.associationSet(groupingIdentifier:3, nodeId:[zwaveHubNodeId]).format()”

For some reason Dennis didn’t need to do this and his just worked but I had the same issue you are having and this solved it for me. Hope this helps.

Tim

1 Like

Thank you thank you. That did the trick. Im now getting more updates.

Tim, Is your thermostat running on battery? If so That might explain why I never had to do the association set.

No, mine is running on AC, don’t even have batteries in it.

I’ve also got two of them and had to associate both.

Do either of you guys get battery updates every 30 minutes?

Don’t know. Mine aren’t running on batteries. I do get temperature updates every 30 minutes though as long as the temperature changed by at least half a degree.

1 Like

Need little assistance. How can I call the association report to find what the thermostat is currently set to? Does below look right?

zwave.associationV2.associationGet(groupingIdentifier:2, nodeId:[zwaveHubNodeId]).format()

def zwaveEvent(physicalgraph.zwave.commands.associationv2.AssociationReport cmd) {

log.debug $cmd

}

Sorry, can’t help you with that one. I have not used association.

Earlier in 2017, SmartThings made sweeping updates to the zwave stack and Z-Wave Thermostat Device Handler. In doing so, my ZTS-110 stopped working well.

I finally had time over the past couple of days to do some debugging and research. My ZTS-110 has some poor z-wave reporting behavior, especially when it comes to reporting it’s supported thermostat modes. I’ve fixed this in my custom device handler.

I found this thread and decided to pull @dspanogle’s battery & configuration parameter code into my device handler. I added support for the Swing and Differential parameters, which I had to customize, as the device defaults are not to my liking.

Finally, I confirmed that deleting the hub from association group 1 and adding the hub to association group 3 ensured changes done via buttons on the thermostat (mode, fan mode, set points, etc) were immediately reflected in the app. Associations are corrected in the device handler.

If you are using a ZTS-110, feel free to pick up this device handler here: https://github.com/cjisndenial/SmartThingsPublic/tree/master/devicetypes/cjisndeial/remotec-zts-110-thermostat.src

Hey. I have two of these same thermostats and found your post after trying to figure out how to get them into ST. Unfortunately, the github link Doesn’t resolve. Do you still have the device handler and if so, please could you make it available again? I’m a noob with this stuff. Thank you!

I have attached the device handler I currently use. It is not perfect but works for what I need

This is excellent thank you. I sort of had it working but now my thermostat has gone into degrees F vs degrees C confusion :slight_smile: I am in the UK . I tried to set the scale from F to C but the thermostat is responding in F and i am trying to set it in C , hence it never switches on as the temperatures are too low. Is there a hex value to set the scale i.e. to C not F ? thanks

It was too long ago when I did my driver mods so my memory is not so good.

Just as a guess (Not sure) may have to add to the configuration part of the driver.

set parameter 5 (0x05)

Scale of temperature:

value 0x00 = degrees C Set it to 0x00 in the configuration section of the driver

value 0x01 = degrees F (default) Since this is the default you have to program it for degrees C

Hey thanks a lot Dennis , I’ll have a play around with that. Much appreciated :slight_smile: and post back if I can get it to work in Centigrade . :grin:

Hi Dennis

I got it working in Degrees C thank you :slight_smile:
I changed all the “F” to “C” in the code, and changed all the scale 1 (F) to scale 0 ( C) or could use Scale 2 to use the setting from the device (which i had to degrees C)
Also instead of using either of the above, i also tried unit: getTemperatureScale() which also works.

Then the device started to respond with 2 temperatures, e.g. 20C and 41C which had me confused for a while, as 41F is 5C so I thought it was also returning the min temp setting. But then i realised it was reporting Humidity in C as the code didn’t have the capability to deal with humidity so reported it as C instead. So added capability “Relative Humidity Measurement” and sure enough the device reported 41 with a unit of “%” .

I extracted some code from here thanks to Minollo :slight_smile: and used the code from there to add a tile for humidity :

  •    valueTile("humidity", "device.humidity", width: 2, height: 2) {
     	state("humidity", label:'${currentValue}°', unit:"%"
    

and

    def zwaveEvent(physicalgraph.zwave.commands.sensormultilevelv3.SensorMultilevelReport cmd)
   {
     log.debug "SensorMultilevelReport ${cmd}"
   	def map = [:]
   	switch (cmd.sensorType) {
   		case 1:
   			// temperature
   			map.value = cmd.scaledSensorValue.toString()
   			map.unit = cmd.scale == 1 ? "F" : "C"
   			map.name = "temperature"
   			break;
   		case 5:
   			// humidity
   			map.value = cmd.scaledSensorValue.toInteger().toString()
   			map.unit = "%"
   			map.name = "humidity"
   			break;
   	}
       map
   }

Thanks a lot for the pointer to get me started , finally got it all working in C also with humidity :slight_smile:
Nige.

1 Like

Just for reference we were contacted by the manufacturer last year and added official support for the ZTS-110 and ZTS-500 in this custom device handler. If you have access to rboy apps you can try it out, it also has support for other features unique to the ZTS series like deadband synchronization, filter replacement status/rest (UI for the classic app) etc. More details can be found on that topic. Here is some feedback from ZTS-500 users.

1 Like

Great Work. What model thermostat do you have that reports humidity?

Hi Dennis, its not a Remotec Thermostat , I started out searching for code to modify when i found this post.
I have the electric underfloor heating version of this cheap device : https://www.amazon.co.uk/gp/product/B01IJAAY7Q/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1
It seems quite unbranded, it came with very limited instructions and no software, but now works perfectly and with Smartthings thank you :slight_smile:


and in ActionTiles:

There is no fan, I stripped all that out of the DH but cant seem to find out to remove that FanCirculate , but I very happy now its all working.