Default Z-wave thermostat DTH - change temp by 0.5C and UI modification not working


I’m trying to modify the default Z-wave Thermostat DHT in ST to:

  1. Allow temperature to be changed by 0.5C (doesn’t seem to work)
  2. Remove the “Fan mode” UI element as my thermostat does not have a fan

To accomplish this I tried:

  1. Setting the “delta” variable to always be 0.5
  2. Removing all references to “fan”
  3. To flush cache: Changing between DHTs and updating the DHT name, etc.

Yet the thermostat still changes by 1C and the fan UI element is still there

Here is the full code:

Thank you!

  1. are your sure your device provides the information?
  2. Groovy is End of life and due to be retired so any work you do here will need to be re-done as an edge driver (in beta) within the next few months.
  3. what model is your device? someone may have already done the work.

Thanks for your swift reply!

  1. I’m able to change the thermostat heatpoint with 0.5 on the device itself
  2. I’m cool with that
  3. It’s a Heatit Z-TRM3 Thermostat, the paid DHT @RBoy offers has the same problem with GUI as stated here

Have you contacted @RBoy to ask for it to be modified? If you have the DHT that means you paid the support and they’re incredibly responsive? That’s what you’re paying for?

Yes, if you hear me very wary about to modifying a DHT at this point - you’re right. I’d instead be asking for someone to write a proper EDGE driver with the feature you want instead in THIS thread:
Post Requests for Edge Drivers Here (community-created) - Devices & Integrations / Community Created Device Types - SmartThings Community

Or potentially trying out the default ZWave Thermo EDGE driver and seeing if it has the same issue.

LITERALLY anything besides modifying old end of life code when there’s plenty of supportable ways forward.

1 Like

It’s how the SmartThings mobile app thermostat control works. You can’t adjust it on 0.5 increments using the controls. The only way to do it is to tap the number and manually enter the 0.5 increment.


I’d be very wary of trying that one out right now. Anyone that does should really test the temperature setpoints while physically present to be sure that they work as expected. If I’m remembering correctly, the issue is that the temperature scale (C/F) isn’t currently available in Edge, or perhaps the scale that is available isn’t reliable. I’m running my own thermostat driver with no issues, but I’ve hard-coded the fact that my thermostat and I both measure temperature like good Americans. The beta ST driver has this comment in the code that sums up the current makeshift logic used - it could be that this works just fine for a thermostat running in the normal livable range, but definitely test.

-- under 40, assume celsius

The post below deals with this very topic. I’ve only skimmed it, but it’s the right approach. It requires using the CLI and editing JSON files so it looks scary, but it’s not too terrible a process.

This is also controlled in the device presentation, so while following the steps in the linked topic you would delete the sections pertaining to the fan.


Thanks everyone! I’m impressed with the community here! :slight_smile: seems like Edge is where I should focus these efforts.

Seems to me like some of this functionality should be built into the new default thermo EDGE driver, however the non-battery version seems to only be in TEST or am I missing something? (see this link)

I tried installing the EDGE driver, but my device seems to use the custom DHT anyway, even after removing device and and onboarding again via scan. Any thoughts?

1 Like

To have the device join with the edge driver,:

  • the device’s fingerprint needs to be included in the driver (There’s a generic fingerprint included, which may work for your device if it doesn’t match a specific fingerprint. Though I haven’t seen whether the generic fingerprints will pull a device into Edge)
  • the device’s fingerprint cannot be included on any custom DTH in your account (you can either delete the DTH or comment the fingerprint out of the DTH by typing // at the beginning of that line)
  • the device needs to be excluded and then included back into the network

The test folder has routines to test the driver by emulating the behavior of the real device. It isn’t indicative of whether or not a particular device is supported.


Hi @fredrile,

Thank you so much for this DTH! Are you the author? I was just about to purchase a license from Rboy, but then I found this DTH instead. I might wait until the Edge driver comes out for the purchasing, if needed.

Regarding your DTH, I had a huge headaches integrating my 4 Z-TMR3’s. First 2 went fine, it was recognized as Z-Wave Thermostat, I changed to this DTH and it seemed ok. I had troubles with 3rd and 4th, it would only recognize them as Z-wave Multichannel device and if tried to change to your DTH it was completely broken.

I tried several times with removing/adding device again, each time with slightly different steps, didn’t work. So I removed all 4 from the ST (including 2 that were fine-ish) and started again, this time the first 2 that were previously ok had the same Z-Wave multichannel switch issue. I tried all I could think of, and what finally worked is removing your DTH completely, and adding/publishing it again. This time all 4 of my Thermostats were recognized/added az Z-TMR3 Thermmostats right away! But they didn’t really communicate, no data was visible. What actually did the trick was to switch all 4 to Z-Wave Thermostats, and then switching back to Z-TMR3 … and boom! Seems like it’s working! I tested some rutines as well and looks promising.

However, there is one issue that remains! Although when I go inside of the device it looks fine, it seems to be stuck in “checking” status on the room/favourites overview. Did you have similar experiences?