[RELEASE] Zooz ZEN77 700 S2 Dimmer

Zen77 same issues here. Zen72 handler works, but Zen77 handler fails on commands.

Any fix? Currently I have to use default generic zwave dimmer handler.

Did you find a resolution? I’m considering exchanging for a diff brand.

When the problem with the 1.02 firmware was reported I released a new version that fixes it, but you need to change the “Ramp Rate” setting to “Instant On/Off”.

If your firmware isn’t 1.02 then let me know what it is.

FYI, if you don’t want the ramp rate set to instant and/or you want local execution then you can always change it back to the generic handler after using this handler to configure it.

1 Like


Currently it shows as 1.03, but I’m not sure if it’s showing that in ST IDE due to swapping from 72 & 77 handlers… here is the link where I got the 77 handler from: https://www.support.getzooz.com/kb/article/560-how-to-access-advanced-settings-for-zen77-s2-dimmer-700-on-smartthings/

Where is your updated 77 code located? In this thread?

The link in that article is the same link as the one in the first post of this topic so it will always be the latest version.

Your first post says that it’s working with the ZEN27 handler, but your last post said that you’re swapping between the ZEN72 and ZEN77 handlers which should be the same so is it working with the ZEN72 handler?

You originally said it worked with the ZEN27 handler and then your last post mentioned the ZEN72 handler, but using a device with a handler written for a different device can mess up the configuration parameters so you need to remove the device, factory reset it, and join it again.

Firmware 1.03 should be fully functional with the ZEN77 so if you’re still having issues after factory resetting the device it let me know.

1 Like

Sorry I meant to say 72 & 77…(I’ve never used the 27 handlers, only the 700 series ones.

So it works when using the 72 handler… but it fails to connect when I update it to the proper 77 handler.

I’ll follow your steps of removing, resetting, re-adding. I’ve done it a few times, but I’ll do it again just for good measure & post back here.


Removed, reset, readded, tested works with generic dimmer DHT, then updated to Zen77 (instant on/off)& immediately fails via Zwave. Only works at the paddle. This is my 5th power cycle.

The device should get assigned the ZEN77 handler during inclusion.

Post the device’s raw description shown in the ide.

1 Like

I’d love to see a video of that process. With the new ST app, you add it by “scan for device” or “scan QR code”, either one automatically assigns the default Zwave generic. You then have to go into IDE & “edit device” and manually assign custom handler.

In the 3 years I’ve been using ST, that is how all Zwave devices seem to work when adding a new device & adding a custom handler.

Am I missing something?

I’ve joined devices thousandsof times while writing/testing well over 50 z-wave handlers and I’ve never had a device that I couldn’t get to join with the correct custom handler automatically during inclusion. (V2 & V3 Hubs Only)

That being said, when Edge Drivers went live they messed up the onboarding process and now it sometimes takes more than one attempt to get S2 Authenticated devices to join with the custom handler.

I’ve found the Scan QR Code inclusion process to be the most reliable, but devices still get assigned the correct custom handler when joining using Scan Nearby or selecting an item from the brand list.

I had you post the raw description because if the mfr, prod, and model were blank then you’d need to reboot your hub, but they’re not.

If you’re manually changing the handler then the initialization code isn’t getting executed so while at the top of the device’s details screen swipe down. You should see a refresh icon for a moment or the screen flash.

After doing that open the settings and change one of them.

This is how the in app device screen looks like. It doesn’t show FW or Status… my previous switch the Zen72 worked perfectly, but I ended up going with the 77 to see if it would avoid flickering with fixture, which it does! :slight_smile: sadly the device handler for it is what is driving me bit nutty. I tried refreshing, changing a setting… same result, it will randomly show offline; etc… but it will never turn light on using it, unless at the physical switch or if I use the generic or zen72 handler.

Fixed! I deleted the DH, reset device, added handler back… then re-added device, changed from the auto installed generic to the Zen77…. Boom! It showed up properly this time… works finally! Ugh that was weird.

1 Like

That was weird, but after you mentioned deleting the handler and re-creating it I remembered that I have seen that happen before with a different handler.

I still find it odd that custom handlers don’t get assigned automatically during inclusion for you so do you have a regular SmartThings hub that’s either V2 or V3?

1 Like

Yes ST hub 2018 v2

Just FYI all of my Zen7x series switches added with the generic DTH and had to be manually changed to your custom dth. They all work well so no complaints. Using V3 hub

That’s so weird because that rarely ever happens to me. Are you located in the US region and what method of inclusion did you use?

Yes, in the US on the V3 hub and Android phone. I use the scan QR code to include. They all work great so thank you so much for your hard work!

Does the v10.10 & 10.20 version work with this driver?

Is there an edge driver for the Zen77 yet?


No, but there might be one available next month…

1 Like

There’s a driver available for the Zooz ZEN77 S2 Dimmer on Zooz’s Edge Driver Channel.

1 Like