[RELEASE] Zooz MultiRelay (ZEN16)

The handler explicitly sets the child handler when it creates it so that’s not possible, at least not with the classic app…

The settings screen in the new mobile app is really buggy so if that’s where you enabled it then it’s possible something weird happened when it was created…

Disable the child device setting and save so that it deletes the child and then enable that setting and save again so that it re-creates it…

Or just enable that setting for one of the other relays and see if that one works as expected. It should reflect the correct state of the other relays even if they’re not wired…

I’ll be hooking mine back up to my test box to make a change to a different handler so once I’ve done that I’ll be able to test it myself in the new mobile app.

New Mobile App Issue with Child Devices

There’s a bug in the built-in “Child Switch” DTH that causes time out errors in the new mobile app so after turning a child device on through that app you’ll have to re-open the mobile app to see the change.

I just posted a “Child Switch” DTH to my SmartThings GitHub repository so that users can install that handler and manual change the child devices type field to it and everything should work as expected in the new mobile app

When I have some free time I’ll make the MultiRelay DTH create the child devices with the custom “Child Switch” handler if it’s installed and the built-in handler if it isn’t.

1 Like

@krlaframboise So I had a weird thing just happen with my child device and I use the Classic app exclusively. I have my main device named Zooz MultiRelay and my child device named Fireplace. The master device is just fine however when I opened up the app today I noticed that my child device was missing. After scrolling through the list I found it further down with the title “Tile Missing”

When I click on that device I get a blank page, but the title of the page says Fireplace as it should and not Tile Missing.

I can still control the device through the Master device and turn on just the 1 relay and I can also still control it through Google Assistant, but can’t through the child device directly.

The only thing I have done recently is move the Fireplace device into a Room on the Classic app. Not sure if this is a bug or just something funky with SmartThings.

Nevermind, I figured it out and seems like it’s a similar issue to @Automated_House. I went into IDE and found that my child device had switched the DTH to “placeholder.” I changed it back to the default Child Switch and all is back to normal.

I’m not sure why it would have suddenly changed. My only guess is that it happened when I moved the device to a room.

here’s an article I put together for using the MuliRelay with a gas fireplace


How much hassle would it be to add seconds to the auto-off feature and just make it a input variable? I am currently unable to achieve momentary capability with the Child devices, and 1 minute auto-off is just to long for my application. I am using Webcore currently to simulate momentary switch condition with the child devices.

I am using the Zen16 for multiple garage door applications.

The auto-off feature is a hardware setting and it doesn’t support seconds, but I’ve seen a couple of complaints. It wouldn’t surprise me if they changed that in future firmware, but that will cause problems in the handler so I really hope they don’t.

Making the handler simulate the auto-off feature in seconds wouldn’t be much faster or reliable than doing it in a SmartApp and you’re already using WebCoRE so why don’t you just make the piston turn it off x seconds after turning it on…

Thanks for the reply. I am currently turning the switch state to off it is on for more than 5 seconds. However, WebCore does have a significant delay at time. I wish I could do it locally.

That would require a hardware change.

You might be able to get the device to execute locally using the built-in Dual Switch handler and that might make it execute faster, but that would only work if you used Smart Lighting to control it and that app probably can’t do what you’re trying to do.

Handler v1.10 is out! Relay inching is now possible via auto-off in seconds!!! I have tried this with the updated firmware and hardware, seems to work as intended. Tossing my Sonoff in the recycled parts drawer!


I’ve added my ZEN16 relay and the device handler but it doesn’t show up under any room in my smartthings app. It shows during the adding but doesn’t show after that. Under the IDE I can see the device and the child switches as well as their group settings but they don’t appear in the app. Any ideas?

Are any other devices showing up?

Have you created more than one location?

Which mobile app are you using? new or classic and iOS or Android?

All my other devices show (dimmer switches, range extender, tv, range, dishwasher). I only have one location in the new app on Android.

Edit: I did install the classic app and I see them under that and am able to control them.

I think there’s an unassigned room section somewhere on the main device screen in the new mobile app.

Are you using the new iOS or Android app?

Using the new Android app it doesn’t show up. When I added the device it required me to pick a room. Immediately after the device if I went into that room it would force close the app and require me to reopen it. I also tried assigning it to a room through the IDE but that didn’t help either. It does show and work in the classic app just not the new app.

It should generate 4 devices so do you see all 4 in the classic and none in the new?

I see all 4 devices in classic and the IDE but not the new. See attached screenshots


Have you checked the entire list of the device’s screen in the new mobile app in case they appear in a different room or unassigned section?

If you can find those devices on that screen in the new mobile app then try assigning them to the garage room again. I’ve found that the room assignments between the new mobile app and classic mobile app don’t always work as expected.

I’ve also had weird caching issues in the new mobile app where the new mobile app’s main device screen showed them in the correct room, but they weren’t in the room when I opened it.

For Android, I ended up fixing that by going into the application section of the phone settings and cleared the data for the new mobile app. I’m not sure if that’s an option for iOS, but re-installing the new mobile app would do the same thing.

PM me if you’re using the Zooz MutlRelay to control a garage door and interesting in testing a new SmartApp I wrote it for it…

For anyone that comes back with a similar issue it appeared that my account had a region issue where it was in the wrong region. I got it reassigned to the correct region but it still had some weirdness with smartthings. After deleting all of my smartthings data under account->personal data then factory resetting the hub and adding the device handler everything worked as expected.