[RELEASE] Zooz MultiRelay (ZEN16)

I am trying to use this switch to run multiple garage doors

Zooz has a Garage Door Opener app that was written specifically for this device so I’ll PM you the links to the code and instructions.

that would be fantastic thanks

You can find detailed instructions for setting up the Zooz Garage Door Opener SmartApp in Zooz’s How to Use the ZEN16 MultiRelay as a Garage Door Opener on SmartThings documentation.

I wrote the app so if you’re already linked to my GitHub repository then you can add the SmartApp and Device Handler that way instead of having to copy and paste the code from the links in the documentation.

Here’s some additional information that’s not in their documentation:

  • The SmartApp automatically creates a child garage door device for each garage door you setup in the SmartApp and you can use it to see the state of the door and open/close it.

  • When you use the child device’s open/close commands it will put the device into the corresponding opening/closing state, turn on the switch, turn off the switch after the delay (if applicable), and once the door stops moving it sets the door state to the contact sensor’s state.

  • If the contact sensor changes and the child device didn’t initiate the change then it sets the door state to the corresponding opening/closing state and once the door stops moving it sets the door state to the contact sensor’s state.

  • If the switch turns on and the child device didn’t initiate the change then it sets the door state to the corresponding opening/closing state, turns off the switch after the delay (if applicable), and once the door stops moving it sets the door state to the contact sensor’s state.

  • The child door device also supports the switch capability and it reports switch on when the door starts moving and switch off when it stops. If you execute the “on” command it will perform either the open or close actions depending on the current state of the door. Executing the “off” command doesn’t do anything.

  • If you want to use a siren/chime to play a sound while the door is moving you can use the opening/closing events of the child device for the start/stop triggers with the new mobile app, but the classic mobile app doesn’t support those events so you’ll have to use the switch on/off events instead.


The direction say to use a Zwave contact or tilt switch, i have a few zigbee contact swithes can a zibee device be used instead of zwave?

Yes, any open/close sensor added to SmartThings could be used here.

ok so I got it all added, but have a issue. the switch only came up in the app settings as one relay. so it controls both doors at once not individually

My Zooz MultiRelay handle creates a device for each Relay and it also creates a “Zooz MultiRelay” device that has all the settings and controls the 3 relays together.

When setting up the garage door in the app you need to make sure you select the switch for a specific relay and not the parent switch.

If it didn’t create a device for each relay and you had my handler installed/published before you joined the device then it will create them if you go into the settings screen and save.

If you joined the device before installing my handler then you should remove the device and join it again.

using device handler Zooz Garage Door v1.0, im only getting one device and its called Zwave Device Multichannel, should i be using device handler Zooz MultiRelay v1.2. I really appreciate all the help!!!

Yes, you need to be on the latest version of the handler, but the changes in the latest version are related to the way the child devices are created so I recommend removing the device, replacing the 1.0 code with the 1.2, and then joining the device again.

the latest version of which handler? the two ive been using are, * Zooz Garage Door v1.0 and

  • Zooz MultiRelay v1.2. With the Garage door v1.0 i would only see one relay controlling the whole switch. with the MultiRELAY 1.2 i get 4 devices but doesnt work with the Zooz Garage Door Opener v1.0.1. maybe im doing something wrong but ive followed the directions word for word.

If you installed the Zooz MultiRelay v1.2 handler before joining the device then it should have created 4 devices during inclusion. 3 of those device names end with " - Relay #" and you need to choose one of those when setting up the door in the SmartApp.

The Zooz Garage Door v1.0 handler needs to be installed, but you shouldn’t be doing anything with it.

The Zooz Garage Door Opener v1.0.1 SmartApp needs to be installed and the “Select Relay Switch” field should list all 4 of the devices created by the MultiRelay so you should select one of the child relay devices and not the parent.

It just dawned on me that if you tried renaming the child relay devices through the new mobile app then it might have changed the “Type” field to placeholder so you’ll need to open the device in the IDE and change the type field back to “Child Switch”.

That really shouldn’t have happened if you joined the MultiRelay with the 1.2 handler installed, but let me know if that was the problem.

Have you made any progress? If not, PM me so that we’re not cluttering up this topic.

Yes I got it! the issue was I wasnt using both handlers. I was only using one or the other at a time. once i reset everything and installed both handlers it works as expected. thank you for the help and the code to do this. sorry i dont think i can PM because im a new member.

Were you able to get the garage door SmartApp working? If so, have you run into any issues or noticed any features that are missing?

Yeah, seems to work fine, I like the little animations of garage doors opening and closing. I adjusted the time to 13 seconds.


Hello, I’m also trying to wire up my garage doors. I’m being told by the zooz people that my ZEN16 should be toggled “OFF” in the smartthings app in order for the garage door “SmartApp” to do it’s job. When I try to open/close the garage via the smartApp, however, the main relay and R1 both toggle “on” and not only does nothing happen with my door, the manual wall opener stops working as well. Toggling back off the relay reactivate the manual opener… Any suggestions? I’ve gone through the install 3 different times. Even tried excluding all devices, deleting all handlers and apps and starting fresh. Same issues :frowning:

I also looked at the comments above. I did rename my relays during pairing, but all show correctly as “Child Switch” in the IDE so I don’t think that’s my issue. Any help would be GREATLY appreciated!

How do you have the opener wired in? I ran two wires from the two connectors on the opener itself to the two screws on the relay. And your opener is a plain Jane opener? I did all my set up and testing without having the garage door wired in. I’d use an ohm meter to test the relays while operating. I’d try disconnect the opener and testing it that way see how the relays behave. And go from there.

I just thought of one issue I had when I first started. The first time I copy pasted the handler somehow it had an error on line 231 or something like that and it referred to the child switches. Maybe that’s your problem too. In the handler if you hit the simulator button that’s where it showed me the error. I can send you the handler if need be.

Post the device settings and SmartApp settings.