[RELEASE] TCP Connected bulbs work with SmartThings Again!

Hi. I have downgrade some gateways with the instructions , after downgrade, remember to block internet access to avoid the hub upgrade again.

Try, try, try and nothing, in the dns this:
CNAME-record for update.greenwavereality.eu = d3k0oqko7onde3.cloudfront.net
and all work fine but not load the firmaware.

I block de d3k0oqko7onde3.cloudfront.net,
it seems to work , but the tcp app in the phone does not connect with the bridge.

I have the firmware 3.0.80

Where can I find the original TCP app? Google Play shows lots of apps when I search for “TCP Lighting” or “TCP Lighting App,” none of which appear to be affiliated with TCP.

The app is kinda dead now, too. Even if you get the APK, I still had it die and no longer work with my hub. Thankfully, this: https://github.com/bren1818/TCPLightingWebInterface/wiki

Hi. I have ios and it´s working fine, no problem to setup new gateway, sorry I have not android.

Am I right when I guess that this needs a Smart App and only works with the Smartthings Classic app?

I swear, I thought it used to work but now when I try to control the lights, I get an error from the new app saying it can’t connect to the device. The classic app works just fine.

I find that everything works great until I want to add a new TCP bulb, then I basically blow everything up and have to start from scratch.

The logs aren’t much help… “physicalgraph.exception.ConflictException: Device still in use. Remove from any SmartApps or Dashboards, then try again @line -1 (doCall)”


OK, so I figured this out. Edit the Smart App and look for line 152:


comment that line out by putting // in front of it, and save & publish. You can now add new bulbs.

I’m sure I am screwing something up but it is working so I am not digging any deeper.

1 Like


My app has never stopped working controlling my lights in house via WiFi. But does this change allow you to have the internet ability back?

Thank you.

This worked great when I got a gateway with the correct firmware. I was able to add my lights and turn off/on. The only thing that isn’t working is trying to set a dim level in smartthings… Nothing happens. Any thoughts/solutions? Thanks

1 Like

Yep, here we go again. I’ve been googling the heck out of this and it seems like Smartthings might have changed something that affected HUE lights in the same way when using HomeAssistant, but then they updated their plugin and they are working again. I’ve been trying to dig up what changed to see if we can apply it here.

It’s a shame the dev has abandoned this project with minimal documentation.

OK, so I found it. I have learned that it is apparently trying to log a Smartthings System Event and it is failing. I am GUESSING that Smartthings changed the way devs have to refrence system events and force them to use actual attribute names of the device cabibility. In this case, I assume we are looking for


def setLevel(value) {
log.debug “in setLevel with value: ${value}”
def level = value as Integer
sendEvent( name: “level”, value: level )
sendEvent( name: “switch.setLevel”, value: level ) // this one bombs because of switch.SetLevel
parent.setLevel( this, level )

NEW Code:

def setLevel(value) {
log.debug “in setLevel with value: ${value}”
def level = value as Integer
sendEvent( name: “level”, value: level )
sendEvent( name: “Switch Level”, value: level ) // this one bombs now until you replace switch.SetLevel with Switch Level.
parent.setLevel( this, level )

Thank you so much for working on this. To clarify - we’re changing the code in the Device Handler, correct? Sorry I’m very novice.

I tried what you have here and received this error message:
org.codehaus.groovy.control.MultipleCompilationErrorsException: startup failed:
script_dth_metadata_895adefe_1478_447d_b5df_3ff5c451b5ba: 123: expecting ‘}’, found ‘:’ @ line 123, column 34.
log.debug “in setLevel with value: {value}" def level = value as Integer log.debug "in setLevel with level: {level}”

I would appreciate any additional help…thank you again

I’m sorry, it looks like the first time I pasted the code in, I did not do it properly. I just edited the post to fix the paste.

I manually changed the one line and it worked! Thank you so much!

Are the TCP lights working at all?
I reverted back to firmware 2.0.47. I do run into an issue in the iOS app where the lights don’t appear in the app unless the light switch ON. Do I need to reset my lights or hub in someway and add them again?
I have been able to add the handler and connector in the IDE successfully. I see the app in the Smartthings iOS app, but after entering the IP address, I don’t see any lights recognized. It times out.
I just picked this hub for the purpose of getting these lights to work with Alexa, but it seems like Hassio so far has given me better results. I would love for this thing to work, so any help will be greatly appreciated.

HI He_Be , I have not tested the project some time ago, ST have updated some functions, but a common problem is to load images in the app , because ST limit the size of loaded data. I will try to test the code and update if is necessary.

Thanks. I have no images other than the standard icons. The TCP hub is pretty much back to factory defaults. I appreciate your help Ule.

Hopefully, this is an easy question. I had given up on these several years ago but today I stumbled on my 8 bulbs and hub. The app had long been lost from phone replacements and time. The app I found called Light Ops seems pretty much read only and I could see all the old bulb names, old names that are quite specific and really no longer applicable. I followed the guides and with a bit of trial and error, I have all 8 bulbs discovered and manageable, sweetness. I thank all that contributed, very much. So here is my question… Of course I can rename devices in ST, no problem, however I was curious if anyone knows how to rename the devices on the tcp bulb side? I did find an older apk of the TCP Lighting app, however I think it is not compatible with the downgraded firmware. Not a big deal, just a housekeeping thing.

As we are on the Smartthings community, why use a separate TCP App? I am able to use my Smartthings app to control my lights through this interface…

2 months later…

if you read any of it then it makes sense. housekeeping. regardless, i figured it out on my own.