[RELEASE] Neo Coolcam / MCO Z-Wave Light Switch

Guys, i installed 24 switches of this in my new house, they are look awesome but this small press delay is SHIT!
Every guest who is coming to the house and trying the switch has a small problem with it.
EVERYONE is pressing it just for a moment, and because the switch has this 1 sec delay , they pressing it immediately again (because they think the first press was wrong) so the switch is turning ON and immediately OFF or doing nothing.

I cannot believe that NEO sold thousand of switches and there is no change in the software…

Are you guys OK with this delay?

Brian, I´m pretty much in the same boat as you where a while ago, house renovation and need 20-30 switches for the EU market and these Neo Coolcams seem to be the only real option at the moment except for Fibaro switches which i dont really like the design of and the price is over the top.

Have you abandoned the Neo´s or made any improvements to them in any way?

1 Like

§any luck or anyone find solution for this 3ch issue

I would like to ask if you can check “neo-coolcam-light-switch.groovy” & " neo-coolcam-light-switch-child.groovy" because the second switch the child (2 channel switch) stop working. I’m not able to switch it on/off via webcore nor via SmartThings Classic app. It also doesn’t work from the new SmartThings app.
I’m using the EU version of 2 channel Neo Coolcam light switch on SmartThings hub v3 with latest firmware 30.3.
Thanks in Advance

@Ervin_Narancsik - It appears to be firmware issue.

@hongtat - Thanks for the reply.
Meantime I tried another DTH released by @krlaframboise [RELEASE] Neo Coolcam Light Switch 2CH and I can confirm it is working fine with the current firmware (30.3) issue related to multichannel switches.
Lets wait for fix from SmartThings support.

Hi, i’m facing the same problem as you with delays.
They are using https://www.holtek.com/documents/10179/116711/BS81xA-xv150.pdf chip for sensors and in three gang switch it can be increased. Not 100 percent sure about 1 and 2 gang as i have they with 2017 revision and there is too tiny chips soldered

A recent breaking change by SmartThings may cause the child device not responding to on/off action or show correct status in the New SmartThings App.

It may also not discoverable in the new Google/Alexa integration.

If you have NEO Coolcam or MCO Zwave light switch (with 2 or more channel/gang) - please

  1. Update the code from here.
  2. Login in to IDE.
  3. Under “My Devices” tab, find and click on the child device.
  4. Check the “In Use by” column, if this child device is in use by other apps (e.g. Automations, SmartLightings, ActionTiles, WebCore, etc,) - remove them. This column must be empty before you proceed to the next step.
  5. Click the “Delete” button to delete the child device.
  6. Find the parent device of this child.
  7. In the parent device, click the “Edit” button, and click “Update” button.
  8. A new child device will be created and it would appears in the new App and Google/Alexa correctly.

The Child has Type “placeholder”

It switched one time to On and is now offline acc the app.

Do I need to change Type of the Child?

Grtn Ben

Can you try replacing the “Z-Wave Light Switch Multichannel” with the Neo Coolcam - Parent & Child and delete & add the device again?


YES! Works immediately.

The parent & de child.

Tnx for the fast solution.

Grtn Ben

I have 4 channel MCO, I removed it from the hub and now when I added it by default it chose Z-Wave Device Multichannel. I edited it and selected “Zwave Light Switch MultiChannel” and update. no childs has been created. I updated the handlers for both the parent and the child.

Can anyone help?

Thank you very much for this post and the Device Handlers, @hongtat , appreciate it.

I am new to SmartThings. I installed my first few devices on my SmartThings hub (V3) yesterday. Indeed, I am so new that yours are the first device handlers I have installed on my hub. Adding the Device Handlers is easier than I thought.

I have plenty of MCO Home MH-S312, but even more MH-S314 switches around my house (on a different controller, not SmartThings) which I now would like to migrate to SmartThings. They’re not the ultimate switches I’d like, but they will - temporarily - have to do so I don’t spend a lot at one go.

I have not as yet tried moving even one switch to Smartthings, but I will most certainly try - your post above seems pretty recent (well, some 5 months old) so I am hoping the Device Handler will work with the new Samsung app just the same. (Please let me know if you don’t think this is the case).

I see that the code was only tested with MH-S312 (as per your text on GitHub), but not MH-S314 (which I have the most of)… Is this still the case please? And would you reasonably expect it to work nonetheless?

So there goes my first attempt… I managed to exclude one of my MCO Home switches from my Zipato controller, but I now cannot join it to my SmartThings network… I scanned from the app and held one of the buttons on the device for 8 seconds (and longer actually) - and nothing. I followed the manufacturer’s instructions to do this but it seems that I must be doing something wrong. It’s pretty much how I set up the other devices I have so far on SmartThings (which is not many), but no luck.

Anyone knows how to at least join this device to my SmartThings network, please?

Update - I managed to joing the MCO Home MH-S314 switch to my SmartThings neywork after my 11-yr old son showed me a video on how to exclude a device and re-include it :smiley:

And then I proceeded as per above instructions from @hongtat - and guess what, I now see four separate switches for my Dining room - so well done to @hongtat , the solution does indeed work!! I just hope I don’t get the lights going on/off on their own as some users seem to have suffered.

The only thing is that I see them on the home screen like 4 different devices, unlike for example my Aotec Wallmote Quad device, where the switches appear to be bundled as buttons belonging to the same device. That said, I am extremely happy to have my MCO fully operational, because I can detach them from my Zipato, finally, and have them acting as repeaters for me all over the home.

In any case - thanks a million :slight_smile:


As always, after the initial euphoria, reality smacks you in the face…

The MCO Home MH-S314 worked pretty well with the device handlers up here, but then I realised something that basically means I would not be able to use these switches. That’s the lag…

So basically, switching them on from the app is fine - there’s a lag of maybe half a second, it’s acceptable in my view… Switching from Alexa is almost the same, perhaps just a little longer… But switching the device (any of the four keys) on or off physically doesn’t register on the app for a whopping 20 to 30 seconds. That, then, is not really acceptable, of course. Any automations attached to the devices, e.g. if you have them set up as a two-way switch at the ends of a corridor - that won’t work well, because you’ll have to wait a minimum of 20 seconds for the light to go on.

This has happened to me on 2-gang switches, actually, and so there are MH-S312, as well as on MH-S314… All suffer from the same problem, and only when pressed physically. Has anyone else been through such a problem? Do I have anything set up wrong?

Make a new “room” named “MCO dining room” and move the 4 devices there, as a workaround.

Grtn Ben

1 Like

Thanks @benerkens , appreciate that. I am already at the room limit (it’s not a small house and I needed the room granularity)… Actually I am over the limit as I set them up on the old app and they were all migrated to the new one, but cannot set up any new rooms. It doesn’t matter much, really - I see four different devices, I’ll get used to it.

Using the switches from the app works great - the device handler is indeed great at showing the 2-gang devices as a parent and a child, and the 4-gang devices as a parent and 3 children, and that’s great.

My biggest problem is the response when I use the physical switch. I realised that it is taking an average of 30 seconds to show up the response on the app, and it’s something that has to do with the dth (I suppose) because if I use the device with the default device handler allocated to it by SmartThings, it works fine - you press a button and half a second later it goes on, or off, on the app. Once you change the dth from the IDE and allow it to create the children - than from that point on you have this 30-second (could be 1 second, could also be 60 seconds) delay for the app to register the new status of the switch. Seems like there’s some 1 minute checking intervals somewhere I can’t get rid of.

I guess only @hongtat can answer that one if he is still on the community, I’ll wait for now before adding more devices.

Here I have the Neo CoolCam 2-button wall switches (Z-Wave) with the @hongtat DTH (1 parent and 1 Child)

Response is within 2 seconds by the app. The control is via the cloud. Sometimes, bad internet, the response is slow.

How is the routing between the switch and the hub? Many hops?

Route This Device (42) Home Hub

And the error?

Received Messages From Device: 2735
Received Messages From Device (Duplicates): 22
Messages Transmitted to Device: 2699
Messages Transmitted to Device (Failures): 0
Updated Time: 2021-02-21 6:38 PM CET

Thanks again @benerkens. I trust you understand that mine are MCO Home, not Neo CoolCam. I use 2-gang (MH-S312) and 4-gang (MH-S314) types, and have loads of these all over the house.

If it were 2 seconds - I wouldn’t be very unhappy… Yes, you expect a light to go one sooner, but things get better over time (I suppose). But 30 seconds is not Internet latency or slowness or “busy periods”, it’s something wrong, and as I said, any other device, the moment I touch it (let’s say up to a second later) - it shows up on the SmartThings app. I tried this with Dimmers, Aeotec Wallmote, TV, everything shows up on the app instantly when physically activated, except these MCO Home with this dth - but using them without the dth is not an option, as at least the dth allows me to see ALL the child switches and makes them available to Alexa.

Anyhow, I digress…

Route is very simple: Route This Device (0A) Main Hub

I don’t understand what you mean by error, but here are the Metrics:


  • Received Messages From Device: 586
  • Received Messages From Device (Duplicates): 25
  • Messages Transmitted to Device: 540
  • Messages Transmitted to Device (Failures): 0
  • Updated Time: 2021-02-22 8:24 PM CET

That seems like a lot of messages considering I only created it maybe 20 hours or so ago… But that’s what it says :slight_smile:

Could you try going to your parent device (the 1st switch gang) settings, make a change, and see whether it improves the response time?

It should be ~1 sec to reflect in the app when you use the physical switch.