[RELEASE] Heatit Z-TRM2fx / Z-TRM3 Electronic Thermostat Device Handler (Official)

Hi there. Please refer to the first post for the latest list of features available in this official device handler:

Key Features of the DTH

  • Supports
    • Z-TRM2fx - Eco, Heat and Cool modes
    • Z-TRM3 - Heat mode
  • Reports current thermostat temperature (separately) and:
    • Z-TRM2fx - Floor Sensor, Room/External sensor
    • Z-TRM3 - Internal Sensor, Floor Sensor, Room/External sensor
  • Configure different sensor modes
    • Z-TRM2fx (F, A2 and A2F)
    • Z-TRM3 (F, A, AF, A2 and A2F)
  • Reports load details
    • Power (W)
    • Voltage (V)
    • Consumption (KWh)
  • Setpoints for Eco, Heat and Cool mode
  • Toggle display mode on thermostat (Setpoint or Temperature)
  • Configure display and button brightness
  • Configure temperature sensor offset
  • Configure mix/max operating temperature
  • Support for C and F temperature scales

Bought and installed the Device Handler for my Z-TRM 3 and updated the Type to Heatit Electronic Thermostat. It seems to be working except in the Smart Things app it just shows ‘Checking’ instead of the temperature. If clicking on the sensor, the temperature is shown. What is strange is when I used the Type = ‘Z-Wave Thermostat’ it worked as supposed.

in the past weeks, my Z-TRM2fx has been going offline a lot. (like every 2-5 days). I do see in the trace, that every now and then it reports this:
12:21:04: warn IGNORING SPURIOUS BASIC_REPORT from endpoint null: BasicReport(value: 255)

Not sure if this is relevant. Mine are about 1 year old, and if this is an confirmed error, I would say that according to norwegian law, this is a “reklamasjon”. Hence, they need to fix it or give me a new one. Or?

I had the same problem but after factory reset of the Trm3 and upgrade to the new DH from RBoy, the thermostats have been online for 2 weeks.

I have today added 4 Z-TRM3 thermostats with success. I am often away from home and have created an automation which turn all devices off and turn all temperature-controlling devices to a lower set-point. When trying to add the Heatit thermostats to the automation under “then”, they wont appear in the list of control units. Is this a common problem?

Working fine here

Sometimes the platform is slow and times out and it won’t show all devices. Reloading a few times usually fixes the issue. Historically weekends the platform is slow and times out more often.

1 Like

My trm2fx has started doing the same thing - it’ll stay online for about 24 hrs and then seems to disconnect requiring a power cycle. I’ve tried moving my hub closer and z-wave repairs but it makes no difference - did you resolve your issue in the end?

No, sorry. I just need to reset them. It is quite annoying, as Heatit has discontinued this one (and are now selling the trm3 instead), so they do not care…

Hi. I have added the DH to control my TRM3, but I have some issues. For instance, when I try to add any automation it says “Network error”, couldn’t add automation. This does not happen for HeatIt Temp2, which works fine. Also, I’m a bit confused why automation only shows 2 options, which both are named as “Temperature”.

And why is it showing battery status, when this is not controlled by batteries? There are also 2 set temperatures in the main window as well as something called “main” and “dimmer” which seems to now have any connection.

It’s an issue with the SmartThings mobile app. It’s working fine here on one phone but behaving differently on another phone. For the TRM3 it should show you 4 temperature sensor options (one for the main and 3 for the external / internal sensors). Try a different mobile phone (android) and if you’re set I’ll having an issue you’ll have to report it to SmartThings support to fix the mobile app.

Yes, same issue.

@RBoy @KristofferF :

Same issues; Android / TRM3/02.01.05 :

  1. impossible to include parameters in an automation or scene. Neither is it possible set new temp values onto the device using the app, but the other way around works

  2. Several instances of temperatures and fans, and infact a dimmer (!) shows up on the main" tile

As described in the post right above yours it’s a bug with the lastest SmartThings mobile app which is affecting many custom devices. They are aware of it but aren’t providing an ETA for the fix. You can downgrade to an older version of the SmartThings mobile app (it’s working fine on v1.75.65.43 Android and iOS v1.6.67-520) and report it to SmartThings support so they can expedite the fix.

Hi, does anyone know how to reset the energy consuption reported by these thermostats?

HeatIt Z-TRM2fx / Z-TRM3 Electronic Thermostat Device Handler - version 02.02.01

  • (Feature) Added energy reset button for future firmware updates

NOTES

  • Firmware versions TRM2fx (3.06 and 3.04 ) and TRM3 (4.00) do not support resetting energy consumption over z-wave. This feature has been added for future firmware updates which may support energy resets over z-wave.
  • The UI may not reflect the new changes due to platform caching. One way to force the cache to clear is to change the device handler to Z-Wave Device and then back to this device handler from the IDE, then sign out of the ST mobile app and sign back in. If nothing else works, you may need to exclude your device, delete the device handler and reinstall it.

Thank you.

some strange observations; I have 4 HeatIt Thermostats. The UI changed with one of them, but not for the 3 others. When I push the reset on the one, I get the error messge “A netowork or server error occured. Try again later”.

Hi, got the app to send the Reset command. But it does not work. The Heatit still reports the same energy consuption.
The eventlog shows 2 events:
2021-12-22 9:20:34.000 AM CET
44 minutter siden DEVICE resetEnergy ready HeatIt Z-TRM2fx reset energy is ready
2021-12-22 9:20:29.000 AM CET
44 minutter siden DEVICE resetEnergy resetting Resetting energy meter

The current firmware for TRM2fx (3.06) and TRM3 (4.00) do not support resetting the energy over z-wave. This feature has been added for future firmware updates if they provide that feature. For these firmware’s the only way to reset the energy consumption is to exclude and re-pair or factory reset the thermostats.

1 Like

Hello. which hub are you using? I use Aeotec but I do not get all the features. På forhånd takk

Hi,

I have finally been able to install my 4pcs Heatit Z-TRM2fx Thermostat that i have bought a while ago. It was easy to purchase and activate the DH from rboy, but when trying to pair the devices with my smartthings app, i face some challenges.

Going to Con on the device, and seaching for nearby devices in the app.
The app finds the device, and i choose secure connection and scan the QR code.
The device confirms include, but the device pops up as “Z-wave device multichannel” with no useful parameteres to be changed (f.ex dimmer).

What have i done wrong?