[RELEASE] Heatit Z-TRM2fx / Z-TRM3 Electronic Thermostat Device Handler (Official)

Thanks for the quick reply, updating to 02.01.01 solved the problem :slight_smile: I hadn’t notice a new version was out, installed it only a few weeks ago :slight_smile:

Hi, I have installed RBoy device handle 02.01.00 on my smartthings v3. Initially managed to communicate with all my eight TRM2fx , however after a while I have noted that status of some thermostats went offline. I have already tried factory reset, reconnect to the hub, etc. Every time that I re-start the hub a different set of thermostats present this issue so I dot believe its related to the distance between them and the hub. From the hub utilities I have already run Zwave repair and got some errors like:

  • Network repair for device [07]: Could not delete old routes
  • Network repair for device [06]: Could not assign new route
  • Network repair for Z-TRM2fx [11]: Could not update neighbors
  • Network repair for Z-TRM2fx [10]: Could not update neighbors
  • Network repair for device [0E]: Could not update neighbors
  • Network repair for Z-TRM2fx [0D]: Could not update neighbors
  • Network repair for device [0B]: Could not update neighbors

Zwave errors are mesh or device errors, unrelated to the DTH. It means that your device isn’t responding. The TRM2fx has a known firmware defect in some versions which causes the device to hang under heavy mesh traffic after a while as explained here.

That’s nice, I have updated FW with cable from HEATIT. Two of the thermostats that went offline have direct contact with the hub. The thermostats also fail whery ofthen.

More people with same problem?

1 Like

I have the same issue here. I have just updated firmware in eight units (used OTA instead of cable), however the problem is still the same, some thermostats go offline after a while. I have noted that they come back online after you reset them or switch the power off/on. I have raised the question to heatit and am waiting for a reply.

Ok keep me updated on the response from Heatit.

I also see this (online after reset). And I have the issue on both the TRM2fx and TRM3.

Feedback received from Heatit “I don’t know what is going on there but you could try asking RBOYapps, they are the ones that make our intergrations for smartthings.”

Hi there. This is a known issue with the Z-TRM2fx model and isn’t related to SmartThings. HeatIt engineers have been able to replicate the issue and we have also been able to replicate the issue outside SmartThings. When there is a lot of traffic on the z-wave mesh, the device z-wave module sometimes hangs and needs to be power cycled to resume operation. The 3.6 firmware improves the stability however a permanent fix will require an updated firmware from HeatIt. Once the device z-wave module hangs it will also impact any other devices that are routing through it until it’s restarted. It also helps to reduce traffic on the network from other devices.

Reply received from Heatit today:

“There aren’t any updates planned as this product is EOL (End of Life) and is succeeded by the Z-TRM3.”

I find strange Heatit be allowed to use the label “z-wave” on its products…

Heatit have to take the responsibility and find a way to fix this or they have to take the “Work with SmartThings” away from the home page.

RBoy how can you sell a device handler to a product you know have a failure?

There have to be possible for Heatit to make a new FW, I got a cable from Heatit and updated the FW but I still have the same problem.

Hi just sendt this e Mail to Heatit
Heatit is a Norwegian company so the text is in Norwegian.

Hei sendte dere originalt denne mailen:

Hei

Er elektriker og har kjøpt 10 stk TRM-3 FW 4.00 som jeg bruker i mitt eget hus opp mot SmartThings. Bruker RBoy sin DH opplever at termostaten ikke varmer om jeg setter setpunkt fra SmartThings. Opplever også at jeg etter en stund mister kontakt med termostatene fra hub’en. Ser på div forum at det er en feil i FW jeg har i termostatene. Hvordan får jeg oppdatert termostatene til nyeste FW versjon og vil dette hjelpe slik at de to feilene jeg opplever forsvinner.

P.s. Dette er en nyinstallasjon alt i huset er Z-wave kun termostatene som slutter å kommunisere med hun etter en stund. Det at det ikke fungerer å sette setpunkt forstår jeg skal være ordnet om jeg får oppdatert termostat.

Har fått hjelp, kabel og FW brukt mye tid på dette nå. Settpunktet kan nå styres fra ST men feil 2. Offline thermostat skjer fremdeles fra tide til annen.

Dette er nå et kjent problem på kryss av alle huber, RBoy kan bekrefte at dere kjenner til feilen hva skal jeg gjøre for å få produktet deres til å fungere som tiltenkt.
Dere bør ta bort « works with SmartThings «på hjemmesiden frem til dere har en løsning på problemet. Dette er jo feilinformasjon, termostatenen deres fungere Max 30 % så lenge dere selger de mot div huber.

My 2 Heatit TRM-3 is not possible to change set point from the smarthings app. They appeare online, and no errors. I used the newest DH . Why did I pay for a DH thats not working?

It’s a SmartThings mobile app bug. They updated the heating setpoint controls UI plugin last weekend and due to a bug the UI controls disappeared for all heating thermostats. SmartThings engineers are aware of it and the setpoint controls should return automatically once they fix it. It’s doesn’t have any impact on SmartApps or Automations used to set the temperature.

Please keep us posted in case of any feedback from Heatit. Tks!

Hi I have noted that in the DH code there are a couple of lines checking if the FW version is 3.04, however the latest FW file from Heatit seems to be 3.06. Is that anything RBoy should look at ?