[RELEASE] ActionTiles, the homepage for your SmartThings home!

  1. Please direct Support requests to http://support.ActionTiles.com ; there you can search for open issues as well as open a helpdesk ticket.

  2. Try to reproduce the problem on a desktop browser. Press F12 to view the “Console” tab of the browser debugger and watch for any errors. Does the “toast notification” (black box near top of screen) appear to confirm a command was executed?

  3. Ensure that the Temperature can be set from the SmartThings App and that the updated value is reflected in ActionTiles (You did this, thanks! :wink:)

  4. Try to observe SmartThings IDE Live Logging while attempting the temperature change: https://account.SmartThings.com ; Compare it to executing a simple Switch. We don’t need the full output; but relevant portions or errors will be helpful in your contact to Support.

  5. Be sure to mention and link to exactly which Ecobee DTH you are using. Is it custom? Is it official SmartThings “Works With SmartThings”? We have extra limits on support for non-WWST devices.

Thank-you!

LOL. This is usually what I ask the users when they request support!

I used Chrome on Nexus 6p and FF for desktop. The shortcut took me to the ST login page, as expected.

2 Likes

@arnb

I created a shortcut as well and added it to one of my panels. It immediately opened another window and took me to the ST Login page

I’m using Chrome Browser on Android 7.1.1

It’s good practice for you from the other side :grin:

1 Like

Thanks and sorry - I forgot about that. But, it looks like your response helped me fix it already. In checking I did not have a DTH so I installed one and now it works fine.

Thanks!

1 Like

I’m giving @625alex a pass on this minor faux pas. I “work” (I’m retired) both sides of the “fence” with a subscription website and free smartapp, SHM Delay, and as a user of ActionTiles, some Smartapps, and many other Windows and Android products. I understand when one person works as both the developer and tech support department, and tech support interrupts the focus on some intricate code, tech support sometimes takes a back seat.

I also discovered part of yesterday’s issue: I coded the URL without a preceeding http(s):// making AT choke. I rarely if ever type that portion of the URL into a browser. Also after much reading on the murky subject of setting a browser link to an Android App, I found it’s not going to happen unless the App is coded to allow it. Additionally, there is an issue with the Fully Browser Application Launcher not showing Apps on a Kindle Fire. It may be fixed on the next Fully release.

1 Like

Wow, this really opened my eyes to automation. This tool rocks!

1 Like

As someone who is also a developer in another arena, I am sales / marketing / support / requirements and analysis / architect / developer / tester / and trainer in my company so I get it. :grinning:

1 Like

In this case, a much prettier user interface than the standard offering :grinning:

1 Like

Well, the Shortcut dialog says “enter absolute URL”. There are numerous protocols and intents that we can’t account for.

I’m glad you have figured it out!

1 Like

That would require reading :rofl:

We gave you too much credit @arnb and made the assumption that you put the full url in since it was posted in it’s entirety in the thread :grin:

1 Like

True enough, when entering a new shortcut it says “Absolute URL”, but I was totally confused when the ActionTiles page showed up in the window.

I would find it helpul if there was an edit on the data entered that gave a warning or error when the protocol:// (or perhaps also “intent:”) was not coded at the beginning of the URL. No need to verify the protocol, except perhaps for embedded spaces or special characters. Another option would be to go with http:// when no protocol or intent is coded. I realize it is a pain coding, editing, and documenting for the “Lowest Common Denominator” but in my opinion it reduces requests for assistance.

1 Like

I probably tried 20 or more URLs and intents yesterday. It is my general habit to try something until I give up and read the manual. Sort of missed that absolute warning.

1 Like

The OP of that thread, Alex Bergman, added some information, and I’m now able to directly open Ring from AT in the Fully Browser.

The change: “For Fully Browser, swipe to open the side panel, select Settings>Web Content Settings and enable both “Enable Popups (Plus)” and “Open URL Schemes in Other Apps”

2 Likes

Were you able to figure out how to assign a shortcut that opens the SmartThings app directly?

If you’re using the fully browser try setting up the application launch page unfortunately you may not be able to set up apps on a Kindle Fire

1 Like

There appears to be an icon missing for the default on a valve …

Chrome browser on a Mac.

Thanks for reporting! This will be fixed in the upcoming release in the next couple of days.

2 Likes

@tgauchat Terry, I’m missing some info from Contact Sensors also. I followed instructions from the “some things are missing from smartthings” thread, and added <capability “Actuator”> and <capability “Switch”>. All other capabilities were already in the DTC code. I’m getting a RED tile in Actiontiles (which is a ‘warning’ on Sballoz HV) and no battery reading shows.
Device: Quirky/WInk Tripper.
DTH: Quirky/Wink Tripper ; mitchpond.
Any other ideas?
Thanks so much

Please use the SmartThings IDE to look at the “Current States” (i.e., Attribute Values) section of the Device instance Details.

This is explained in a bit more detail here: http://support.actiontiles.com/forums/8-actiontiles-knowledge-base/topics/1038-question-mark-shown-on-virtual-switch-or-other-connected-thing-tile/

In other words… ActionTiles can only process valid values that are sent from SmartThings. Looking in the IDE, per above, is a starting point to diagnose what Attribute Values are set, and then we can move on and discuss if those values are valid - or not.

1 Like