Relay not opening/closing garage door

devicetype
hubv2
communitydevices

#1

Posted in multiple topics covering this, but got no responses so figured I’d make a new post.

I’m using the evolve relay. Everything paired fine. I have it hooked up in the garage now. I have the basic doorbell button to open/close the garage on a chamberlain hd220 opener. I wired the relay directly into the opener where the button wires go. The button still works fine, but the up/down buttons on the opener do not. When i toggle the relay via the app, I hear a click and nothing happens. I’ve read that means it could be wired wrong, but there’s nowhere else to wire it. The blue wires are connected directly to the button wires via wire nut and another wire connects them both to the opener. and like i said, the button still works so i don’t see how it could be wired wrong.

Anyone have any ideas?


(Ash (www.smart-dots.com) / Ashutosh Jaiswal) #2

First connect those button wires manually and make sure the garage still works. If it does, connect the two wires to the relay terminals and turn the relay on and then off and see if the garage works. If it does thenyou will have to change the relay device type to a momentary z wave switch in the IDE.–> Login to ide.smartthings.com and then gonto “My Devices”, select the device - Edit Device and then from the drop down choose zwave momentary switch. Then just a tap on the switch should trigger the garage.

If the manual on/off of switch does not trigger garage in the beginning, you need to make sure you have the right wires.


#3

I’ve already changed the device type. And the button does work. When I attach the relay the garage still works. But the relay doesn’t trigger the garage at all. I do hear it click @ashutosh1982


(Ash (www.smart-dots.com) / Ashutosh Jaiswal) #4

May be if you can share some pics it will help? Pics of the set up and your garage opener?


#5

I messed with the wiring again this morning. This may have been happening before, but I can’t be sure. When I hit the relay and it clicks, I get an error code on the arrows. The button still works.

Up Arrow Flash: 1
Down Arrow Flash: 3
Symptom: The door control will not function.
Solution: The wires for the door control are shorted or the door control is faulty. Inspect safety sensor wire at all staple points and connection points and replace wire or correct as needed.

Button


Green/Black going into same holes as button wires.

Green/Black wired to relay

Opener model


(Ash (www.smart-dots.com) / Ashutosh Jaiswal) #6

Your wiring seems OK.

Please check if your garage opener is a MyQ compatible opener. if so, then the contact based triggering will be disabled. This is also the case in some of the newer models of the garage opener.

I assume you already checked this,

  1. Try removing the Green and Black wire from the relay and contact them manually to ensure that the garage is operating - Dont remove the green and black wire from the garage opener - This is just to ensure that you have proper contact and to ensure that manual tampered contact will work with this garage opener.
  2. While the relay wire is not connected to the green and black wires, operate the relay and if possible check with multi-meter if the two blue wires are making a contact.
  3. If all is good, make the connections again and this time operate the relay manually using the little switch on top - Turn the switch ON/OFF multiple times to see if that triggers the garage shutter.
  4. If all fails… Get a remote that can open your garage and connect the two contacts of the remote to the relay and try that (This will confirm that tampered connection is not supported by the opener)

If none of these work, then you may have to contact Chamberlain and ask them what will be the best solution to automate your garage model and I am sure there will be a way to integrate that with ST.

Good Luck!


(Eric) #7

just guessing but,

1a. are there 2,3, or 4 wires going to the wall-button from the original terminal block? The button is illuminated so it seems likely to be 3 or more. But your picture of the terminal block suggests the red&green-wires-in-white-jacket is going to the wall-button with no additional wires
1b. does the wall-button-light go out when you press it?

  1. maybe you configured relay for a maintained connection. Most old-style garage openers expect a momentary connection on the wall-button which signals the opener to perform one door cycle, so then the door opens or closes depending on the existing position of the door.

In the case of #2 you want to configure your new relay for momentary connection.


#8

I set it up as a z wave virtual momentary contact. I’ll take the button apart when I get home and check for extra wires. This was installed last year. The old one was only 2 wires before. And the same 2 wires that were ran from the original button were reused. I’ll check to see if something was added though


#9

@ero4444 I took the button off and it is only the two wires connected to it.

@ashutosh1982

It is not myq compatible.

  1. I did this and it still will not open and I’m receving the same 1 up 3 down error as with the relay
  2. no meter at this time, but being that the first step didn’t work I don’t think that’s the issue

UPDATE: Just chatted with a chamberlain rep and here’s where I am now (pissed off and seemingly out of options)
Brandon: Hi, my name is Brandon. How may I help you?
Matt Smith: hello. I’m trying to trouble shoot a wiring issue. I am using an evolve relay switch to tie into the opener so I can control it via z wave. The relay is fine. The issue is it’s plugged into the same contacts that the wires from the button on the wall plug into, but I get an error code 1 up 3 down when I try to activate it. To make sure it was not the relay, I took two short wires and connecxted them into the same holes (where the button wires go) and manually touched them. That should close the circuit, but I get the same error code. I have model HD220
Brandon: You will not able to use that controller with this unit. The wall controls are serially encrypted to the opener and no devices can be added to them.
Brandon: Manually touching wires do not work. The motor unit will not activate without receiving the serialized code from an approved wall control.
Matt Smith: I see. Would connecting the relay to the button work? Or do I need to solder directly to the remote?
Brandon: No, sir - it is not compatible.
Matt Smith: I see. and this model isnt compatible with the myq device right?
Brandon: That is correct.
Matt Smith: So is there ANY option to automate the opener at all?
Brandon: Unfortunately, not this model of opener.
Matt Smith: well thats disappointing. thanks for the info


(Troy) #10

I am no expert on this stuff, but it seems to me that if the simple 2 wire button works than a simple relay should operate the same. I would not think that the 2 wire button does anything other than close the circuit and allow the juice to flow and trigger the action (open or close). Just for the heck of it, have you tried to switch the wires at the opener and see if it mattered?

I recently used the monoprice curtain relay on my older genie openers (both of which use the simple button like yours) and it works fine. I wired like you did, direct from relay to the same 2 screws that the buttons go to.
Thanks to the help from others on this forum I was able to get the app to work the way I wanted it and all is well.
On a side note, I just use my cameras to see what position the doors are in and the app works just like the button, opens if closed or closes if open. This way I am not wondering all day if I remembered to close the doors.


#11

I did try that. From what the chamberlain rep said there’s encryption that allows only authorized buttons or remotes to send the signal. I’m beyond aggravated at this point


(Ash (www.smart-dots.com) / Ashutosh Jaiswal) #12

OK this is where you try the last option.

I am sure they have provided you with a wireless remote to keep in your car etc. If need be you can order an additional one. Open up that Remote and connect two wires to the contacts that complete the button on the remote. Once you do that, you can now connect these two wires to the relay…and now it should work. Its a dirty work around, but will work.


#13

That worked. I don’t have the confidence to try soldering it. Will ask a few people I know. Ty

EDIT: thanks for all the replied. soldering directly to the remote works like a charm


#14

Was having the same problem with my HD220. I’m using the Linear gd00z-4. Wiring it directly didn’t work but this solution worked perfectly - thanks! I imagine wiring directly to the wall button’s PCB would also do the trick.


(Gus) #15

I am beginning to wonder if something changed on the ST platform for these relays. Mine has been working great since Nov 2014 but a few months ago, with no changes to any ST devices or my garage door opener, the garage door now opens but does not close all the way. I have to keep opening and closing the garage door with the wall button or ST app until the garage door closes. And it is set as a Virtual Momentary. I tried deleting it from my hub and now I can’t find the relay in the Add Thing menu to reconnect. Any ideas?