Quirky GE Outlink POTLK-WH01 POTLK-WH02 Outlet Device Type

While I don’t actually have a device type to share I thought I’d start a post about this device as I’m currently “testing” it with various other device types of similar function.

I stopped by Home Depot the other day because they had these down to $30 and they claim on/off function as well as energy reporting. So far the only thing I can’t seem to figure out is how they do their energy reporting because none of the existing ZigBee Device Types with energy reporting actually make the device report energy.


For those who have one and want to be able to use it with the on/off just select the GE Zigbee Switch Device Type. I’ll continue to try to figure out the energy reporting part.

1 Like

Does anyone know if the Outlink is also a Zigbee repeater? I am assuming the answer is YES, but want to confirm.

I don’t know of a way to actually confirm it. My plan to get one is to get some energy reading AND expand the Zigbee.

I’ll hit up Wink tomorrow. I’d like to use it as a SmartThings repeater - where it needs to go, I need something with high WAF and she wouldn’t notice an outlet. :smile:

my hub v2 was working and i was able to add the outlink to it, i dont know how or what i did it just worked.
so my hub needed to be replaced, faulty on the cord side, no power.
the new hub arrived today, removed everything like i was told and readded it all, i cannot get the outlink to show up again, dont know if i got lucky or if the new firmware is the culprit.

@mattjfrank I cannot find the description you posted “switch device type”?

Edit to add. So it seems after the update the quirky outlink does get added but as a “thing” and really it’s just a thing cannot do anything with it

Hey @Trevlan

I never released any device type for the outlink because using the GE Zigbee Switch device type or a few others works. You just need to log into the ide at https://graph.api.smartthings.com/ and change the device type to a zigbee switch.

I had hopes of getting the energy reporting working but I’ve tried about 10 different ways and can’t seem to figure it out. I haven’t worked on it in a couple weeks.

1 Like

Thanks man I think it worked
I can now see on/off but I am not home to test it. But looks good in the app now.

Thank you very much for your help and direction.
Love this community

ETA:: works thanks again at least on off better then nothing thanks @mattjfrank

Has anyone made progress on the Energy Meter for this? just picked one up as it was on sale at Home Depot.

@mattjfrank, are you still working on this product?

I have made no progress. I’d hoped someone else would. But now that these have been liquidated I have doubts any progress will be made. I’ll likely take another stab at it in the future.

i’d buy up the remaining stock at this price if the power meter worked…

These work nicely, but man are they chunky. As in, I needed to put a deep box in my bathroom wall to fit it. Make sure you measure your electrical box before buying up all the stock!

I have this reporting energy usage. However, there may be some configuration bits that I need to figure out yet. It’s reporting a cumulative value (does not seem to report on-demand usage at all, just a [maybe?] daily energy usage value in kWh), but it doesn’t seem to match what I was expecting to get. I have more testing to do on this before I’m comfortable releasing any code.


Thanks for your work @mitchp keep us posted. If I haven’t said it before the community appreciates the effort you make and the code you release.

On a side note, the TAPT is actually natively supported by ST now once it’s firmware is updated. I was going to try to get my TAPTs updated and my OUTLINKS as well. Hoping that would improve some functionality. If you have a Wink Hub you may want to see if OUTLINK has a firmware update available.

I’m on the current firmware for both. I’ve had both working as generic devices for some time now. I think some of the ZigBee generic device types have had their fingerprints updated to catch more “standard” devices recently. Not sure if there was anything special in the Wink update that allowed this.

Hey All,

I picked up three of these from my local HD on clearance as well, but I’ve had no luck in getting even switch functionality working in ST. I have a Gen1 hub, and these are my only Zigbee devices if that makes a difference. Here’s what I did:

  1. Used portable router to plug in ST hub next to Outlink.

  2. Initiated device search on ST

  3. Press and held button on Outlink until blink/steady/off (as described in “manual”)

  4. Eventually (~30 seconds) ST switched to “Identifying a device” but stayed there indefinitely (5+ min)

  5. On backing out of menu, I saw the “Thing” entry

  6. Changed device type in IDE to everything I could think of: all GE device types, Zigbee switches, Quirky Powerstrip…

  7. Device status is not reported correctly in ST app or IDE, and ST app commands are not received or acknowledged by Outlink regardless of device type

I tried with two separate outlets, so I don’t think it’s the Outlinks.

One thing I did notice is that my boxes are labeled WH02 versus the WH01 referenced in your posts. Is this a newer version? Anything else I can try? I’d hate to think I wasted $100 on these things :rage:

Try ZigBee Switch device type.

Yep, tried that as well. Are you on v1 hub or v2?