Qubino Flush 1D relay ST and Alexa

Qubino support has been great. The only thing they could not help with was Alexa integration. Relay is operating perfectly with ST (I have the ST v3 hub). I have full access to adjust the advanced settings thanks to help found here, the Custom DH and Qubino support.
Here is the challenge:
Relay fully functional in ST, state of device displays instantly and accurately but with Alexa, it seems the state is not being found (my amateur diagnosis).
When I speak the On command for the relay, Alexa says “the device is not responding” and yet instantly turns on. Same thing happens when speaking the Off command.
The Alexa app shows a red dot next to the devices saying it is unresponsive. Operating the relay from the Alexa app (Edit)- will turn the relay on but switch icon stays in the Off position, and the Alexa app will not turn it back off (-End edit).
Here is what I have tried:
Changed the device type in the IDE, saved and then reset to correct type.
Removed from Alexa and then re-added it.
Rebooted the ST hub.

Removed Qubino Flush 1D relay.
Installed RIBU1C (12$ on Amazon).
Installed GE In-Wall Smart Switch zw4005 ($39.99 on Amazon).
Works perfectly with Smartthings and with Alexa.

The RIBU1C shows no voltage from the contacts.

I hope this helps someone else :hugs::sunglasses:

This happens a lot with many other devices, including GE devices (old, new, zwave plus), Aeon, and Zooz. The issue really isn’t with the device per se, but with how ST polls the device, and then sets it’s status, which then somehow gets communicated to Alexa.

I’m actually having the exact same problem with a GE device right now. SmartApps, including Alexa, work great, but I just can’t use the Classic mobile app or see the device’s on/off state in the mobile app correctly, and the IDE says it’s offline.

My gut feel says the Qubino was working just fine.

Thanks for the reply.
You are correct. The Qubino worked perfectly; save for the Alexa verbal notification of non responsiveness.
This project needed Alexa compatibility so I had to find a plan B using a Z-Wave device with known Smartthings/Alexa compatibility.
Saving the Qubino for another project.

1 Like

I’m looking at exactly the same device to replace my Leviton switch. It’s an older device that has 2 zwave devices in 1, which worked perfectly to replace a double switch in a single gang box. I want to put the original switch back in and use either 2 Qubino’s, or their dual relay version inside the box. I’m glad to hear about your positive experiences with these.