Problems with V2

I migrated to V2 last Friday and I have had nothing but problems since then. I will start off and say that migrating wasn’t that bad… I have 72 connected devices the entire swap only took about 2hrs. Setting up my smart apps took a little longer though… still working out some kinks.

These are the issues I am having (keep in mind my router hasn’t changed & hub placement is the same).

  • After about 24hrs most devices don’t respond to automated smart apps. For example I arrived home today, smartthings showed me arriving, sent the command to turn on my lights, set the temp, play my Sonos and unlock my door, but nothing happened.

  • The set brightness levels on various lamps don’t work during their set times. For example I have our ensuite set at 20% after we go to bed. When I walk in the brightness is still 100%. Activity feed shows the command being sent, but it doesn’t take (yes the light does turn on).

  • The Sonos weather app no longer works. I have tried everything I can think of, but nothing works. All my other Sonos prompts seem to work though (but cut out half way through saying it).

These are just a few so far. Also I have to say that the new app is extremely slow to respond. I don’t know if its the app itself, V2 hub or my aging iPhone 5, but it is painful to wait for the pages to respond if I simply want to change a mode or turn on a light.

The problem I am having with the top issue seems to go away if I reboot my router (I have a latest gen Airport Extreme), but I have had to do this each day (sometimes twice). HUB is not close to the router… about 25ft away. HUB is also located in the middle of my house.

All of these issues I am having rarely happened with V1. Sure I would have the odd light not turn on, or it wouldn’t see that I arrived home, but they were few and far between. With V2 I have had this happen multiple times Friday, Saturday, Sunday and now Monday (day 4!). So far my V2 experience hasn’t been a good one.

Can you make any recommendations as to what I can try or can you look into my system and see where there could be an issue?

1 Like

I think it’s the whole platform. I’m on V1 and seeing slowdowns and misfires all weekend. Earlier today my routines wouldn’t run. They are better now but it was weird. I usually run smoothly.

1 Like

I would agree these are platform issues, I’d recommend an email to

1 Like

Good to know I’m not alone. I just rebooted my router again, left the house, came home and everything worked this time. Fingers crossed it works tomorrow :wink: I’ll email support regardless.

I had the same problem with #1, ST kept sending a push notification that it knew I had arrived home, but nothing happened when it was supposed to. Deleting my location seemed to fix the problem, which I wasn’t too bummed about because the re-pairing dance moves were still fresh in my head. Support is your friend, they’re a little bogged down but they’ll help.

Unless you have a bad router, you should never have to reboot it.

I just did the migration to V2… really don’t want to do that again! Lets hope it doesn’t come to that. Maybe Alex can come over and give me a hand :wink:

1 Like

I agree, but it’s the only thing that seems to work right now. PIA let me tell you. I even thought about attaching a switch to my router and creating a reboot rule in ST :wink:


My V1 is horribly slow tonight and missing timings. I suspect platform on this.

My poor V2 is staring at me promising it wouldn’t happen to me if only I would put him in the game, coach.

1 Like

How many devices do you have? It doesn’t take that long. The key is knowing what SmartAppd you have installed on V1. Or in my case rules in SimpleRuleBuilder. You will loose dashboard solution modules though, which is a pretty low blow in my mind.

All kinds of problems over the past few days and I am still on V1. i.e.

  • Light coming on when they shouldn’t
  • Only two out of three lights come on when a particular rule fires.
  • Very very slow response to… well… anything.
  • Minimote did not appear to be working at all last night. Couldnt turn off anything so I reverted to the app. I proceeded to turn of the lights and seconds later they came back on :frowning:

Same experience last night.

Rebooting the router is either the critical symptom here, or a red herring. Why would rebooting a router in any way fix a cloud issue? Unless it’s reestablishing a network connection of some kind (in which case I think there would be easier ways, like a soft reboot of hub). ??

1 Like

It only makes sense to me if a local engine queue gets backed up and can’t unf*&*& itself because of the latency and dropped calls with the cloud. It in effect gives it a fresh start to start sending and receiving commands.

That was the cartoon bubble in my head without really digging in on it.

Sonos Weather has been down for over a month. I e-mailed support and the reply I got was “I have experienced this on the Sonos at my office here, and let engineers know about it. I will let them know it is also an issue on your end. I have not found a work around, but I know they are working to fix the Weather app, and the Sonos integration in general.
I don’t have a timeline for this fix to roll out, but it should improve several aspects of Sonos, and other LAN integrations once it is released.”

This was over a month ago.

I found that removing the evening forecast and just leaving the Current and Today’s Forecast worked for a while. Then it stopped gain. Removing Today’s Forecast and just leaving the Current Conditions works…but that solution really sucks. The entire point is to know what the day is going to be like when we wake up.

I really wish that they would get Sonos working again especially the TTS. It seems like ST has pushed this to the back burner with the v2 app and hub rollout. I hope it is on their radar soon.

I spoke to support this morning and they told me the same thing. Looks as though it’s not a priority at the moment.

I have my router set to “Auto” for channel selection. I will assign a channel tonight and see if it makes a difference. I had another problem last night when selecting “Good Night!”. Nothing turned off, had to reboot the router and the HUB to get it to work again. I was happy that “Good Morning!” worked fine though : )

At times when any routine fails, rather than going the reboot router and the long way, just open that routine as if you are re-configuring something and click “Done”. This has helped me at times.

1 Like

Now I am thinking that my problem was not as isolated last night as I thought. Several lights in the house flashed on for about 3 seconds then off. After that nothing would work. I had been playing with my router and wifi frequencies ( damn new neighbors with WiFi on same channel ) . Even though V2 is not on wifi I thought it might have been related to my playing with router .
I wound up pulling a battery and powercycling the V2 before I could get a green light.