Problems with Automation Routines hoping someone can help


(David Wright) #1

I hope I am posting in the correct Place, i am having a problem with some of my setup Routines, and i have tried lots to fix the problem to no avail.

Using Smarthings app normal Routine setup, I have some routines setup, one “GoodNight” turns off some lights and sets the heat to 62 at 9 PM, as well as changing the mode to Night

I also have" someone came home" That program is to turn the furnace to 70 degrees, when someone arrives, my wife or me. I have that set to NOT occur if in Night Mode.

Problem seems no matter what I do the Someone came home still happens when I come home after 9 am, I want the furnace after 9 to stay at its low tempature as if im getting home later then that, im just going to bed. so no need to heat house to 70,

I have tried removing the routine and redoing, removing the app reinstalling it, nothing seems to be working, any help you all could give would be great.

Thanks.


(Mike) #2

I have a very similar setup except I don’t have my thermostat tied to it. I only use it to open my garage door. If in night mode it will not open it automatically. That seems to work fine. I found that the phone presence is not always reliable and sometimes my phone or my wife’s will never connect when we get home. Then sometime in the middle of the night it will connect and the garage door would open and switch me to home mode. This then allows some other routines I don’t want running at night to start up.


(Jimmy) #3

Can you verify in the more menu that the mode is actually getting changed by your goodnight routine?


(Mike) #4

Be careful using that. On my phone I have to shutdown and restart the app to get that to indicate the current mode. If I already have the app open and the mode changes most times the display does not indicate the change.


(Jimmy) #5

That’s odd. Have you told support?


(David Wright) #6

Yes I have verified that it goes to Night mode, I have not contacted support on the issue.


(Jimmy) #7

Can you post a screen shot of your someone came home routine?


(David Wright) #8


(Mike) #9

Looks identical to my setup. Except mine opens the garage door instead of setting thermostat. I also have the push notification turned on.


#10

I would go through and make sure that you do not have any Routines or other Automations setup that is setting the Mode to let’s say Home or something that is not running that is keeping/setting it in/toNight Mode.

Typically and in my case, at Sunrise, I have a Routine that sets the Mode to Home because it’s no longer nighttime and I have rules for lights that only work at night and once the sun comes up (Sunrise), being in Home Mode those are now ignored. I only say this because you mentioned coming home at 9am which technically is no longer Nighttime, so go through the Automations and make sure you that you are setting all of your Modes for appropriate times and qualifications (scenarios).

There was an issue in the past where certain things weren’t being set when a Routine ran. I had a scenario when I would come home, my garage door would open a and the SHM and Mode were set appropriately, but the Garage Lock wouldn’t unlock as part of the Routine. It’s possible that the Mode in one of your Routines isn’t being set if this bug is still there, and then that results in other Routines firing/not firing because Mode is out of whack. To get around all of their, you could goto webCoRE and instead create Pistons to replace your Routines and also give yourself more flexibility and additional qualifications to check against. :slight_smile:


(Jimmy) #11

Yeah, that routine looks correct. Look at the device history in the app or ide to see if there is something else triggering it.


#12

What about the routine changing to Night mode? Can you post that as well?


(www.rboyapps.com - Make your home your butler!) #13

One other thing you can do is open your IDE, click on your device under My Devices, click on List Events and you can track down which “app” or “routine” is sending the command to your device.

This way you can confirm the “source” of the command.