Google is missing from Smartthings Classic

I am having a lot of problems with Smartthings/Google Home.
I can connect the service and in the new app I can see ‘Google’ in ‘Connected Services’ -> ‘All Locations’. If I tab that one, the only option I have is to delete the account.
In the Classic App I used to be able to choose which devices Smartthings should expose to Google Home, but when I look in the Classic App now, I don’t see Google at all :-(.

This is a big problem, as I don’t want all my rooms and devices from ST in Google Home. Can anyone help me?

Thanks in advance.


But how can I ‘hide’ devices from Google Home? I used to be able to do that.

You can’t from the integration. In the thread I posted, some users are creating a second home in the google app and moving the devices they don’t want to see into it.

OK - I will try that.

Wil it be possible in the future to hide devices or is that option gone for good?


OK - thank you for your answers :).

This is a lot of work when having 50+ Hue bulbs that I want to move :(. One at a time.

Try messing around with 270+ devices in Google or Alexa… Not having the option to select which devices from ST to be exposed to these connected services stinks.


No thanks :hot_face:

BLUF- there are no “easy” ways to do this especially if you have a large Smart Home set up. This may not work for everyone but I hope it helps some of you. FYI- I have mostly WiFi devices and only a few Zigbee/ Z-Wave items. Some of what is below I have cut/pasted from searching how to fix this. So my issue was duplicates showing up in GH under the “Linked to you” heading. We know there is no way to just delete a device and putting things in another “Home” is not fixing anything. Here is what I did. BTW I am using a Andriod phone to do this so IOS may be a tad different- No Clue

  1. Using the “new” ST app, From the home screen tap the 3 lines on the L/S of the screen, then tap the gear icon, tap Linked services, tap Google then tap delete account.

  2. Go into the GH app, click on the + button and then on the option that says Set up device . At the bottom you’ll see a link labeled Have something already set up? - go there and you’ll see all of your linked services - unlink them all. Next you want to delete your home . Go back to the home screen in the Google Home app, click the settings button and then scroll all of the way down and you’ll see a link labeled Delete this home - click this. Note that you’ll need to un-associate any household members before you can delete the home. I wanted a clean break so I factory reset all my Google devices, you can do so if you want.

  3. Create a new “Home” in GH

  4. Re link ST with GH. This will pull everything from ST back into Google under the “linked to You” heading. Put the items back into the rooms you want. STOP!! do not set anything back up from the GH app that was pushed in there from ST or you will have the same issue you started with.

  5. If you factory re set your Google, speakers, displays, Chromecast, etc. set them back up.

  6. If you have some real off brand stuff i.e cheap stuff like me, you may need to re set these to get them back into GH, I have 4 Dogain bulbs I had to do this with. Only re-link services back into GH that are not being pulled in from ST.

Here is the PIA part- most if not all of your routines in GH will be broke, you will need to go into each of them and re associate the bulbs, switches, etc to get them to work again, you could just delete them all if you only have a few and start over, up to you.

At this point it is trial and error depending on your set up, I went back and tested everything and if I found a bulb or routine not working I figured out why i.e. need to re set the device or re-link a service. Do this one item at a time to ensure you have no issues and make sure every time you make an adjustment or change to tell “Google to Sync my Devices”

Hopes this helps some of you !