Problems Adding SmartApps

I just upgraded to latest Smartthings app from classic recently. Today I tried to add a few Smartapps, unfortunately none of them was success. It always shows “Process…” on screen and seems stuck there forever. I had to close Smartthings app to end the process.

My cell phone is Google Pixel 2 XL and all apps are upgraded to latest. Anyone has any clues? Thank you.

Any malware blocking on your home network or using a pihole? Strict firewall rules? Vpn?

I am using the new V3 hub (FW 000.030.00005) and new S.T. app (V1.7.47-22).

My SmartApps are showing as installed in the IDE with OAuth enabled for all.

They all show up in my SmartApps on the app.

All good so far, right… Or so I thought!

Then when I try and go to actually install/load any of them I get the same error message.

I am very new to S.T. and quite a noob with anything like this but would anyone know what maybe causing this error?

It seems it happens on all of the’My SmartApps’ regardless of which one I try.

This problem is driving me nuts as I have been wrestling with it for days now. Any help would be well appreciated.

Thanks.

Do you have malware blocking on your home network such as adguard or a pihole?

2 Likes

Nothing like that installed on my devices or network.

I just tried this and I am actually able to add SmartApps from the SmartThingsPublic (master) in the IDE but not custom GitHub Repository Integrations in the settings.

I followed your advise from this topic. It worked by loading the Classic app and going to marketplace. Does adding SmartApps through the IDE not work anymore except from SmartThingsPublic?

Now the SmartApps seem to appear in Connected Services (that’s for that tip, I didn’t know that and why they should be hidden over there)

But, I have no idea how to use them.

When I try and create an automation there is no option for any of these connected services or am I being really stupid again and missing something very obvious?

Life360 is confusing because you would think you can use it from the Member location option but unfortunately it is only available to use with Device status. August locks and your ecobee devices should also be available to use under device status.

@jkp You are correct! I have pi-hole. After disable pi-hole, smartapps are working now! Thanks a lot for the help! :slight_smile: