New SmartThings app - Can't add new, or open existing Smartapps

I’ve been running the classic and new SmartThings app on my phone, but only really using the classic app.

Discovered today when I tried to add/use Smartapps on the new SmartThings app that I can’t add new Smartapps, or open existing Smartapps. I get the same result if I try to add a Smartapp, or open an existing one:

  1. A “processing” message appears
  2. A second message almost always appears for a moment, saying “We’re having trouble connecting. Check your network connection and try again”

Sometimes the second message clears and the process just stops and goes back to the Smartapps screen, nothing opened or added.

Other times the 2nd clears, and the “Processing” spinner returns and it sits that way endlessly until I finally force-stop the app.

I only have one location and one hub in the IDE, so things look normal.

I have no problem installing and opening Smartapps in the classic app, so clearly there is no connection issue w/my network. If I install the new Smartapp in the classic app, it shows up as installed in the new app, but still cannot be opened in the new app.

I tried clearing data in the new app, didn’t help.

How can I resolve this?

Any ad/malware blocking apps on your mobile device or home network such as adguard?

2 Likes

Thanks for the help, @jkp!

I am running an adblocking package on my EdgeRouter, custom package developed by EdgeRouter community.

If that’s it, are there addresses I need to whitelist?

Interestingly, I found 8 or so instances of the Smartapp that I was trying to install on the new app, in the classic app when I opened it. So the Smartapp install from the new app is completing, but the app can’t the process nor allow the app to launch.

There are two addresses I believe… SmartThings.com and http://usage.trackjs.com/

4 Likes

Great, thanks! Would not have thought of this myself…off to go whitelist and try again! Really appreciate the tip.

Yup - that worked perfectly as far as I can tell. Smartapp opened in new SmartThings app.

Much gracias to you (again), @jkp.

Helped me too, pi hole was sending this to gravity.

1 Like

I’m running pfBlockerNG, I added “.trackjs.com” to the whitelist and that fixed the problem.

1 Like