AEON SmartStrip NOT a multichannel device?

I was pleased to see an “official” device time was added for the AEON SmartStrip a while back. In the past I’ve controlled this by creating Virtual on/off tiles and “binding” them to the power strip via a smart app I wrote.

Then I just use normal SmartApps to control the virtual tiles.

However, in the upgrade to Hub 2.0 process I saw that there is an official “Multi-Channel Control” smart app to control individual endpoints of a multi-channel device… which seems like that’s what I have with my SmartStrip. However, when I try to install this app, my SmartStrip does not show up as a multi-channel device.

I also don’t see the code for it in the IDE so I can’t pick through that and see what’s going on or what the app is looking for.

Anyone use this app and/or a power strip?

I use the Aeon Power Strip which is a great item!!!

Tyler mentioned in another thread on this device that they are working on Multi Channel Devices and they hoped to support them before years end.

My Enerwave Multi Channels don’t show up either. My guess is they are testing supporting multi channel. I too wish they’d share their smart app code.

Gotcha… thanks for the reply. I’ll just go back to my “Duct Tape” method then using my AEON/Virtual Tile binder app.

Your duct tape method has been working for me for over a year…and it’s awesome.

I should also note the enerwave device type I made using the aeon code over a year ago is so much better in V2 hub. The only reason I need the smartapp now is to control those individual switches from other apps.

@chrisb Is the SmartStrip now officially supported? I don’t need to use the virtual devices for it anymore??

There’s an official device type, but as far as I can tell the device itself isn’t really support, so no… you do need to use the virtual devices.

When I first got my strip there wasn’t even a device type so I kinda cobbled together one based on someone else’s multi-channel device type. It mostly worked but the problem was still that you couldn’t control the individual switches with the standard SmartApps… that is still the case with the official device type.

My little AEON binder app works with the the official device type though, so still need the virtual devices and the binder app and then you can use the virtual devices with any standard SmartApp, including the Smart Lighting app.

However, while I have tested it yet with the Smart Lighting app, I’m pretty certain that this instance of the Smart Lighting app will NOT run locally as it’ll use virtual tiles which I imagine are only cloud entities.

So, these outlets can’t be controlled independently? Has anything changed on this?
This would seem like a waste without it no? Unfortunately I made the assumption and just had one arrive, I came on here looking how to get the thing to work! :frowning:

No, they definitely can be controlled independently, but it’s not quite as simple as a standard outlet.

This is a bit of an over simplification, but here’s what’s going on.

See, a standard outlet has a capability called “switch.” But the AEON has four different outlets, so instead of just “switch” is has “switch1”, “switch2”, “switch3”, and “switch4”. The problem, however is that most smart apps only look for “switch” capability. The switch1, 2, 3, and 4 are… well, not what SmartApps are looking for.

So, insert my ‘binder’ app… What you do is create four virtual switches in the ide. Then you install my binder app by selecting the AEON strip you want to bind, and then selecting the four virtual devices you created. The binder app just makes the switch1, 2, 3, and 4 follow whatever the virtual switches do.

Now, because virtual switches just have the “switch” capability they can be seen by standard SmartApps. So, for instance if you want switch3 on the strip to turn on when you open a door, you would create an automation in SmartLighting or Rule Machine and tell virtual switch #3 to turn on when the door opens.

The binder SmartApp sees the virtual switch turn on and it turns on the correct outlet in the strip to match.

5 Likes

is there a workaround for the energy monitoring too?

I’d love to use Rule(or any of the laundry apps- they seem great too!) to notify if my washer is done (plugged in one outlet) or the dryer is done (plugged in another outlet). For now looks like all the apps only see the total strips wattage?

Um… no. I don’t think so. That would probably involved doing on editing of the SmartApps involved.

thanks- i guess i have to try and figure out how to fiddle with the code…

I installed the original device then installed the Smart App and nothing. I then tried the Device Type and other smart app in the main thread on this matter and that didn’t work either (Configure doesn’t work).

This is the most frustrating experience I have ever had with Smart Things! :frowning:

Stepped away from the cliff and figured it out.

1 Like

I am new this month to doing smarthome stuff. I bought a SmartStrip which is now the single best purchase that I have made – precisely because it was so useless out of the box that I was forced to learn about more advanced topics like Virtual switches, Creating from Code, Binding, and such. (cf. Rainer Maria Rilke’s “Winning does not tempt that man. This is how he grows: by being defeated, decisively, by constantly greater beings.”)

So, it appears that one MUST use chrisb’s binder app – which is now working great for me. Can someone (perhaps especially chrisb) comment on whether it makes more sense to use all of chrisb’s now year-old approach, or is there something beneficial about leveraging the new official device type as part of the binding?

To be honest – even though everything is now working fine, the icons [from chrisb] are about the ugliest that I have in my mix, which seems to represent the device well since the SmartStrip still is the most klugey device that I have (wrt icons not always showing off/on correctly, delayed response coming on, etc.). Still, chrisb has made this device a very good investment for me, so I thank and tip my hat to him.

1 Like

You can definitely use the updated official device type for the power strip. I’m running the official driver myself.

You don’t technically need to use my binder app… but if you don’t you need to do a lot of re-writing of any smart app you want to use with the individual outlets. The problem with the official device type (as well as mine) is that the commands to turn on the individual outlets are on1/off1, on2/off2, on3/off3, on4/off4.

Nearly all SmartApps send on/off as commands which obviously don’t touch the individual outlets. The binder app is just a way to not have to recreate any smart app that you want to use with individual switches.

To put it another way for anyone who’s still not getting what’s going on, think of each switch speaking a different language. Switch 1 speaks German, Switch 2 speaks Spanish, Switch 3 speaks Japanese, and Switch 4 speaks Russian.

All smart apps speak only English. So you need to re-write smart apps so they speak the language of the outlet or… install my app and the 4 virtual switches. My app speaks English, German, Spanish, Japanese and Russian. You can just speak English to the virtual device, then my app hears you speaking and translates to the appropriate language for the outlet.

4 Likes

@chrisb, do you have a link for the binder app? I’ve been searching around but have not been able to find it.

Yeah… I’m still using it myself. I’ve honestly been away from the community here a LONG time, so I’m not sure how to share apps anymore. If someone can educate me on that I’ll be happy to share.

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.