Problem With Leviton DZMX1 Dimmer - Recommend A Replacement


(John Westlund) #1

I have a Leviton R02-DZMX1-1LZ from Home Depot that is not very reliable at reporting its status back to the hub. Sometimes it will be over an hour from the time I turn the light on or off with physical switch until that status is updated in the SmartThings app. Control from the app works fine and if I refresh the switch in the app it will get the correct status. Support has had me do a Z-Wave repair, and then remove and re-include the switch with my hub and it is still the same. I Want to add some standard Z-Wave switches and was going to use the Leviton but not if I can’t get them to accurately report status. I know they don’t support instant status but I am ok with them having a few second delay but not hours! Can someone recommend me another switch that works. I know about the Leviton and Cooper products that support instant status but I would like to avoid having to pay a premium for those if there is a better alternative out there.

BTW - This is the only Z-Wave device on my hub and the only other device I have connected is a SmartThings motion sensor.


(Bruce) #2

There are two types of Leviton dimmers relevant to your situation – I know because I have many of each. You are right that the DZMX1 does not report status to ST. In my experience, they usually show up within 30 seconds. So if yours is not doing that, I’d agree about all of the steps Support suggested. And, it could be that you have a bad dimmer. I have 40 of these and they all work very well, when controlled by ST.

There is a more expensive Leviton dimmer, the VRMX1. It is a rare z-wave dimmer that has instant reporting. I use these for places where I want to turn on a bunch of lights from physically pressing one switch. To have this feature available, the dimmer must be included directly to the ST hub.


(Calvin Robertson) #3

What is the pairing procedure for the leviton dimmers. The manual says to call their tech support which is only open until 5:00 eastern time. I’ve paired two leviton switches and was able to pair another dimmer by accident, but I’ve tried all sorts of gyrations and have been unsuccessful on this other dimmer.


(Bruce) #4

Which model dimmer are you referring to?


(Calvin Robertson) #5

The dzmx1. I’ve tried everything I can think of.


(Bruce) #6

Have you reset the dimmer?


(Bruce) #7

And if you have reset it, try moving either the hub or the dimmer closer to each other for inclusion, or use a Minimote to include it. After you get it included, you will need to do a z-wave network repair.

There are times when it takes multiple attempts to include one of these dimmers. You just have to be patient and keep trying. Reset the dimmer each time you fail to get it included. Double check ST to be sure it didn’t get included behind your back. Start the inclusion process on your mobile app, and press the dimmer. Watch for the bottom LED on the dimmer to blink during inclusion – it will turn solid when it is included. If you don’t see it blinking, it failed to include, try again.

If you remain stuck after all of that, reboot your hub and try again.


(Calvin Robertson) #8

That did the trick. The instructions left out the fact that in order to reset dimmer you had to hold the switch until the red led stopped flashing. I also used the minimote and got it in the first shot. Many thanks for the help.


(Realy Living Dream) #9

Okay @bravenel , since you have 40 of these maybe you can answer my question. When I paired it ( after I finally figured out how to remove it from my old hub and get it into pairing mode) It is showing as a GE z-wave outlet not a Leviton dimmer. so obviously dimming is not working. I have unpaired and repaired it a couple times with the same result of ST showing it as a GE outlet .


(Bruce) #10

Wow, that’s new behavior! When you included it did you do it generically, or did you go into the Leviton section of the Switches & Lights in the Market Place? I always did the latter, which is maybe why it showed up as a Dimmer Switch. I always included using a Leviton 600A Dimmer.

You can probably just edit the device’s Type in the IDE to make it be a Dimmer Switch.


(Realy Living Dream) #11

I was just doing the generic add device and letting it get discovered. I didn’t know you could specify what device you were looking for. Found that removed and repaired it again as the 600w dimmer and now it is working fine.

Thanks for the help.


(Bruce) #12

There used to be a tip in the old mobile app that said if you were having trouble with a generic include recognizing your device, to try including it from the device specific list instead. So I’ve always done it that way for all of my devices.