Problem adding ST multipurpose sensor

I have been trying to add a new ST multipurpose sensor to my V3 hub with no luck and am at my wit’s end.

I have tried resetting and re-enrolling, turning hub off and on etc.

I only see the device on the list of connected devices to the hub per picture. That is the only place it shows up, so I can’t assign the device or create any rules etc - it also says no room assigned’ even though I assigned a room each time I try enrolling.

I’ve had no issues in the past with the St motion sensors.

Would be grateful for any further suggestions?

I just set up over 20 of these with no issue within the last two weeks. I have one more still in the box, I’ll try to add it today and see how it works and I’ll report back.

1 Like

Login to IDE, go to the devices section and see if that device shows there. Check the device type - it should be SmartSense Multi Sensor. If not, change it to that device type and check if group is set to the appropriate room and Update.

Then check the app to see if it shows.

1 Like

Thanks - it does, and it looks to be correctly set up in terms of device type ie multi sensor and room! But no dice, can’t see the app. So bizarre.

What is even stranger is I downloaded the classic app overnight to use simultaneously and I can actually see the device in the classic app. So I can set it up with the smartapp automation but wondering what will happen when the app is finally decommissioned.

I just tried with the ring camera I have and the same happens - I can see in classic up and ide but not the new app.

Thanks - would be keen to see how you go, whether it’s just me with this weird problem

check to see if you have multiple locations in IDE? also is your hub assigned to a room in the new app?


I just set up a new sensor with no problems at all

Hi, no - only one location. But the hub is assigned to a room, always has been and never had any issues with previous sensors or devices though

Alrighty, thanks. So looks like just me then!

It could be caused by one of several issues:

  • devices not be synced properly
  • a custom device or smartapp that may have a space
  • or something else that normal users can not see :slight_smile:

Do contact ST support …

Tagging @Brad_ST

1 Like

I will, thank you for your suggestions! I appreciate it

are you in the us or one other the other 3rd party counties

I’m in Australia. Haven’t had any issues with other devices in the past eg the smartthings motion sensor, kasa tp link devices etc

Ah, could be just a hickup in the backend system. Since you are in Australia you might want to give a minimum of 1-3 days for it to clear itself up else email/call in.

Yeh, doesn’t seem like there is much I can do for now in any case. Thanks!

Did you change the region of your Samsung account? It is registered in a region other than Australia.

If you sign in at, which URL are you redirected to? It should be but is likely due to the region issue.


You’re right, it defaults to the latter. But I remember changing my country on my account from the UK to Australia, it even says that on my account now.

So are you saying this is causing this slight chaos in my devices showing up/ not showing up in the app?

Unfortunately yes. That change doesn’t change the region your Samsung account is registered with for SmartThings.

You would be best off creating a new Samsung account registered for Australia and resetting/re-adding your devices with the new account.

You won’t believe it. I went to register a new account but went back to the app to check something - lo and behold, I see the sensor now listed there!

If I have more problems in the future I might consider migrating to the new account. Thanks for your input