HUB Will Not Pair Smartthings Motion or Door Sensors

I have been using smartthings for about 3 years now, and I really found it to be great. I converted over from Homeseer and actually didn’t have any issue moving all of the Homeseer switches as well as Schlage locks, GE Switches and several other misc devices. With that said, I have run into a problem this week. I was trying to add some Samsung Door/Window sensors and a Samsung Motion sensor, but no matter what I do, I can not get them to pair. I have tried three different W/D sensors so I know it is not the sensors. I tried the general exclusion and initially two of the W/D were excluded, but I cannot get them to join. I have rebooted the Hub from Website interface, nothing. I have removed the batteries and unpluged the Hubv2 to reboot but that hasn’t worked. Repaired the Zwave network, nothing. I have been working on this for over a week now! I did see another user had an issue with some GE switches, but these are SAMSUNG!! Aren’t they suppose to be seemless?

Any advice would be greatly appreciated.

two things to check…

  1. if you have any custom device handlers installed in IDE, you may need to open them and choose Publish for Me. There is a known issue where device handlers can become stale preventing you from adding the devices.
  2. if moving any zigbee devices from another hub, you should try resetting them

Samsung SmartThings brand devices don’t use zwave. Most of them use zigbee, a few of the newer ones use WiFi. So general exclusion (a zwave utility) and repairing the Z wave network won’t make any difference at all as far as smartthings brand devices.

Most likely you have to individually reset the devices and then you can add them.

We need to know the model numbers of each sensor. They should be on the back of the sensor or possibly inside the battery compartment.

The multipurpose sensor is Samsung SmartThings Multipurpose Sensor [GP-U999SJVLAAA] and the motion detector is Samsung SmartThings Motion Sensor GP-U999SJVLBAA

Hi @ggrw1011, welcome to the ST community, but what took you 3 years to come by? LOL :wink:

Those are definitely zigbee, as @JDRoberts mentioned, so all the zwave stuff you’ve done (general exclusion and repair) will not help.

If you bought those sensors new, they should have joined ok, but sometimes that’s not the case. If you got them used, then you need to reset them. Regardless, I highly recommend you reset them and try again.

1 Like

Hello @johnconstantelo - I did purchase them new. I tried to reset them several times, but it did not work. I actually took one multipurpose sensor and one motion sensor to another location where I have a different hub, and they were able to connect to that hub without any issue so I know it is not the devices. (On a separate note - I have been part of the community for some time, but there is so much great material here that I have never had to post any issues I have had because there is always a string that I can find to fix the issue or get a custom handler!)

I am going to try what @jkp suggested, but I don’t have any custom IDEs for the SmartThings products. If this does not work and anyone has any other suggestions, I would greatly appreciate the suggestions! Thanks for the help so far!

Hi @jkp - I didn’t have any custom device handlers installed in IDE for these type of sensors, but I do have several custom device handlers generally. Are you saying I should publish all the custom device handlers I have even though they are not being used by this type of device?

It is worth mentioning that I do have several Samsung SmartThings Multipurpose Sensors that I am using that I paired several months ago without any issue. I am not sure if it is my Hub being quirky or the type of sensors. Tomorrow I am installing two GE switches so it should be interesting if they will pair properly.

How close is your hub to your hub to your wifi router? Which app are you using… the ST Classic app or new app?

Within 2 feet.

It is possible there is interference from the 2.4 ghz band of the wifi on the router and zigbee on the ST hub. As a test, you may want to move the hub at least 10 feet from the router and see what happens.

My hub is in a network closet on the first floor of the house and the Access Point for the WiFi is on the second floor so there is plenty of distance. I really appreciate the suggestion though…can you think of anything else? I am really bummed because i just purchased sensors for all the windows in the house so we can start to use ST for our security.

Last thought, if you are using the Classic app, try installing the new app, login and try to pair the devices. Or if using the new app, try the Classic. Other than that, I am at a loss. Contact ST support again and see if they can investigate for you.

Do they still show up in the IDE after exclusion? If so, remove them from there also.

So @jkp that sort of worked. I was able to get the device loaded with the new app, but it didn’t work. I found a new device handler that works. And actually, I noticed that the multi-purpose sensors I installed a few weeks ago were not working, but they are working now with the new device handler. So thanks for the suggestion. Now I have to try to set up a Routine in Alexa using this new device with the new device handler!

1 Like