Preview | SmartThings-managed Edge Device Drivers

Hey guys! Long time no speak. I am having a small problem with smartthings and home assistant as i cant get my hands on an aeotec zwave stick 7.
Since the new edge drivers, i have seen that they finally added the fibaro double switch 2 which i had lying around so i bit the bullet and installed one using edge drivers. The only thing is when the device gets added to HA i only see one switch. No secondary switch no nothing. Anyone have any thoughts on this?

1 Like

I suggest you start a new topic on this and then hopefully others who are using home assistant will be able to comment. You can put it in the following section of the forum:

I do know that at the present time many third-party integrations, including the voice assistants, do not see multiple endpoints on a device that is communicating through an edge Driver. So it’s the same symptom, I just don’t know if it’s the same cause. :thinking:

Hi. I’m having issues with the device tile display.

On March 8, I added a Leviton z-wave 4-speed fan switch (ZW4SF-1BW) using the stock edge driver z-wave fan controller. It works prefectly, app tile shows fan rotating and changes color when active.
Yesterday, March 12, I added 2 more of the same switches. They both function normally but the app device tile doesn’t show the fan rotating or change color when active like the first. I’ve removed and readded both several times with the same reults. The first switch continues to display properly.
Any suggestions?

I received a Third Reality Contact Sensor the other day.
Unlike most contact sensors, this one uses a pair of AAA batteries for power.

The battery level being reported by the ST Edge driver is showing as 45%.
When I connected the same device to Hubitat, it was reporting the battery level as 100%.
Edit: Seeing the same result with the Third Reality motion sensor, although it is using the Zigbee Motion Sensor Mc by @Mariano_Colmenarejo
I’m assuming all Edge drivers inherit from a base standard driver and add features, etc.

This device is using the default edge libraries for the calculation of battery %.
The sensor directly sends the remaining battery % and the driver with those libraries divides it by 2 and displays it.

I don’t know if Hubitat will use the battery voltage attribute instead of the remaining %.

1 Like

A post was split to a new topic: [SmartThings Edge] Issue with channel invitation

can someone from smartthings tech help. Opening the link just gives me a spining circle and the smartthings logo after i tap accept. Can you check it out.
cant download drivers.
Thanks
Refael

Welcome to the SmartThings Community, @dollar65!
Did you accept the invitation a while ago?

no. it’s anew invitation.

When I try to follow the link provided in the initial post, I only get the following error message:

“no healthy upstream”

Hi! I sent you a DM to get more info, please, check your inbox. As I need more personal information, we’ll continue our conversation there.

Is there any way to confirm you have successfully loaded a particular edge driver?

Yesterday, I enrolled in the beta for the first time and “installed” my first driver. Today I tried to install the corresponding new device, but it was not found by the scan. So I don’t know if there was a problem or it just hasn’t downloaded to my hub yet (I read somewhere it could take up to 24hrs to complete).

In the ST app, follow these steps:

  1. Go to your hub and select the menu (three-dot symbol in the upper-right corner)
  2. Tap on “Driver”. You’ll see the drivers installed.

If your device wasn’t recognized, make sure it is included in the fingerprints of the driver, you can verify that in the official Github repository:

  1. Enter the driver folder and open the fingerprints.yaml file.
  2. The list of supported devices and the profile assigned to them will appear there.

Which device (brand and model) are you trying to connect?

2 Likes

Found it (the driver) installed in the app - thanks for the pointer.

The device is an Aqara (unsupported) leak sensor, using a pre-beta non-official driver from
https://github.com/veonua/SmartThingsEdge-Xiaomi

The driver came with appropriate disclaimers, and others seem to have gotten this particular sensor to work with that driver, so I will keep trying the pairing now that I know the driver is installed and follow-up in that driver’s thread if necessary. This sensor is included in the driver’s fingerprints.yaml.

(update: after a few retires, I was able to get the device paired and all seems working fine)

2 Likes

I know this goes against everything this thread is about but is there a way to change a device added with an edge driver back to a groovy handler?

You have to remove the device then remove the edge driver and add the device back. It should pickup the old device handler

How is it that you actually remove edge drivers? Is there a way that you can see a list of every driver that has been added to your hub from all sorts of different developers?

open the hub in the ST app, click on the 3 dots in the upper right of the screen and select Driver. You will see all the installed drivers and all the channels you have registered.

Hi, @GRClark. Developers cannot install drivers in your Hub directly.
They can only expose their drivers in a channel where you can enroll your Hub, after that, you can install them.
Also, there are some devices that are already connected to Drivers by default, take a look at this post:

So is it no longer possible to add devices which use a groovy handler? I’m trying to access a capability that doesn’t seem possible with hedge drivers - indicator lights on GE switches.

Also curious if you can give any insight whether devices will automatically be switched over from groovy handlers to edge drivers as this process proceeds…? I can’t imagine forcing everyone to remove and re-add devices to the hubs in order to use this new driver.

1 Like