Presence on iPhone

(Morgan) #1

My wife’s iphone presence has been horrible the last week. It has been working flawlessly, and now it just always reports that she is either home or away, and doesn’t change unless she opens the app when she is gone or away.

It has been working VERY well for the past 7 months, but acting up now.

Anyone else having this issue?

(Ron S) #2

For me has been working flawlessly for months even after switching from iPhone 5 to IPhone 6 but today I left, arrived and left within a few seconds… :wink:

Hope she is set up with her own account. I had made that mistake once of using my credentials on her app and it was not supposed to work but somehow worked for months but one fine day, it failed as it was supposed to. Once she has own credentials, registered her phone, (@tyler was kind enough to help), her iPhone 5 presence works much better where by it always triggers at the same spot. For me on iPhone 6, it is never consistent where in the geofence it is going to trigger but it does.

Update: Although I always ask her to keep her app open which she does.

(Morgan) #3

@smart She has her own account, and registered her phone. She is running an iPhone 6, and it isn’t super consistent with the geofence, but close enough. Now, it just isn’t working and she has the app open so i’m not sure what is going on.

(Ron S) #4

@thrash99er Please do open a support ticket for sure. And please do share what they have to say.

(Ron S) #5

Also, I am sure you have already checked:

Enable Location Services and Background Refresh for SmartThings app.
(Settings -> Privacy -> Location Services -> SmartThings -> Always)
General -> Background App Refresh (On) -> SmartThings(On)

Some others have reported too if the phone is locked, it somehow acts erratic. Cannot confirm it. My wife has the app running always on a 5 but the phone is definitely always locked when she is arriving/departing. Will check on my iPhone 6 today.

One issue that I face here in NJ is the stupid Optimum auto hotspots all over the state (even though saves me a lot on data plan). I have my phone registered to auto sign in to Optimum hotspots being an Optimum customer. These hotspots have very weak signal near my home. As a result the ST app will crash at times or will still be updating the status while I am already in my geofence and reach my house. Doesn’t happen everyday (may be depending on the load) but this is one of the reason for me when it does not work for me. On my way back home, I disable Optimum wifi on my phone to get around.

(Dawn Fairbro) #6


I have a support ticket open for this same issue for the past week. I have the Iphone 4 with the latest software upgrades.

(Ron S) #7

K. I tested it with iPhone 6. Kept the phone locked 25 miles from work to home. No issues at all with the presence at all. It triggered the push and text as I entered the geofence. The only thing is I had maps running in the background.

One thing you guys should check is when you launch maps, it should always default to your home location. If you ask Siri, it should also confirm where your home is and please make sure your Siri is linked to you as contact with the correct home address and phone number. This is on top of what I asked to check earlier. See if it helps.

(Dawn Fairbro) #8

added my home address to my contacts. Siri now has my home address… We will see if that helps. thanks

(Ron S) #9

Also make sure eh. You launch “maps” on your iPhone. It defaults to your home address.

(Dawn Fairbro) #10


not sure what you mean… I am at work and it defaults to my current location (20 miles away from home)… always has. do I need to change a setting

(Ron S) #11

For some reason when I launch maps from work, it defaults to my home in the textbox where you type in location and my current location flashing in the blue circle. Will explore some more. Will post a pic from work tmrw morning what I mean.

(Dawn Fairbro) #12

interesting… thanks

(Ron S) #13

This issue may have been related to having a location based reminder on m iPhone with a much shorter radius as the geofence. Not sure. Deleted that. Will know tmrw morning while departing. Today arriving was flawless.

(Morgan) #14

@smart Yeah, i’ve checked the privacy settings, I’m not connected to other networks, the location based reminder isn’t a bad idea though, I’ll check that out.

It has worked very well in the past, just not sure why it isn’t working now.


(Ron S) #15

@dfairbro1 I am at work and opened map. The home address comes up automatically in the text field where you type in location and shows the current location on the map (flashing blue circle) and if you make the map smaller you should see your home location (red pin).

(Nagui Anis) #16

iPhone presence always gives me errors when Wifi is off, if I turn it on I have no problems at all, this could be related to GPS accuracy which is increased by Wifi

(Ron S) #17

One of the basic prerequisite is to have your wifi enabled.

(Dawn Fairbro) #18


looks like i just have mine cleared as the default. If I put my address in I get the same look- flashing blue circle and red pin (home). I am on the edge of getting an Iphone 6 ( which might solve some issues) but the thought of switching presence sensors( from Iphone 4 to iphone 6) is holding me back… may just get worse…

(Ron S) #19

I switched from 5 to 6 with no issues…

(Dawn Fairbro) #20

@smart So i phone 6 arrives Tues. Did you install 6 first as a presence sensor and then uninstall your other phone, or the other way around. Just trying to make this easy…