SmartThings Community

Pre-Release of Quirky (Connect) Service Manager and 7 Devices


#69

Does its IFTTT channel work?


Quirky Aros AC Unit Help Please
(Chandy) #70

My husband and I were looking for a small supplemental AC unit because of major uneven heating in our home and found the Aros AC unit for $150 at Walmart. We did a quick search and found that someone had written an app for it to be integrated into Smartthings mobile app utilizing the SmartApps.
We followed these directions above and are getting this error:

No signature of method: script144001403656644345072.metadata() is applicable for argument types: (script144001403656644345072$_run_closure1) values: [script144001403656644345072$_run_closure1@294da323] Possible solutions: getMetadata(), getState(), setState(java.lang.Object), metaClass(groovy.lang.Closure)

I am a complete novice at coding, so I do not really know exactly what I am looking for. I searched for “script”, “run_closure” and parts of that random number to maybe see if I could locate something but all to no avail.

I have searched and see a few threads talking about this but did find anything that was helpful. One person mentioned not enabling “OAuth” but I don’t see anything about that in the coding. Is there anyone who could help me figure this out? It’s not bad switching between apps but we are more Smartthings fans than Wink so would like to have it all integrated in one if possible.
Thank you in advance!!


(Ray) #71

Possible you are installing a device type code into a smartapps or the other way around?


(Chandy) #72

I just copied the code directly from Github like the directions said.


(Ray) #73

I don’t have this device but just looking at the list of files on his gibhub you create a smartapps with a file https://github.com/twack/Quirky-Connect/blob/master/Quirky-Connect-Service-Manager.groovy
And all the other files are for a device type. So pick one that’s applicable to your AC and create a smart device type per instruction above. Hope that will help.


#74

Code for the smart app goes one place, code for the device type goes another:


(Chandy) #75

Thanks Navat604 and JDRoberts for that snippet of knowledge they both kind of helped me understand a little better what to do. I really appreciate the help!!
I have successfully published the Quirky-Connect-Service-Manager to the SmartApps, and added the Quirky-Aros-Device to the SmartApps.
But, I went to add the device by following the direction in that overview JDRoberts. Just to show what I am doing I logged in and clicked “My Devices” tab on the top of the page, then clicking the green “+ New Device” button on the right. I’m not exactly sure where the “Device Network ID” can be found but in the dropdown menu “Type” the Aros is not listed…although every other Quirky device is listed there :-/.
Am I doing something wrong to not get it listed in the devices? From that overview it sounded like it should be listed there, unless I’m reading that wrong.
Also, I contacted Quirky and they gave me my OAuth codes but when I tried to enter them there is a grey circle with a line through it and I am unable to. Could this be part of the reason the app isn’t working?


(Todd Wackford) #76

Quirky, aka Wink has changed their authorization methods which has broken the integration to SmartThings for the 7 wink (phone flashing) apps. It’s not known when this will be fixed.

Sorry, I will try and get the apps/devices pulled from my github soon.

Todd


(Chandy) #77

Oh. Well that sucks :frowning: thanks for responding and letting me know. :smile:


(MT) #78

It’s really amateur hour when I start coding, but I managed to connect my Aros to smartthings by getting my bearer token with that neat chrome plugin and hard-coding it into the JSON call. I’m not sure how long my token will last, but the http response had the max value of the spec so I suspect it will last quite a while??? Maybe I mis-read that.

I didn’t create a device type for it because I’m not smart enough, but instead created a smart app that takes mode, temp & fan speed as inputs and shoots the command over when a virtual switch is turned on. I created instances of the app with a few preset modes that I like to use, threw in a master parent switch to keep a consistent on/off state and it seems to be working.

Of course this is all because IFTTT doesn’t let me pick fan speed / mode and always defaults to medium / cool (annoying) and I just wanted to yell at alexa to crank that baby up when it was getting hot.

Hopefully this will hold me over until some real developers get the fancy pants/proper integration working again. Or maybe competitive integration isn’t a priority. Either way as long as I can cool myself down without exerting the 2 calories of energy it takes to open the wink app, I’m a happy man. Though I wonder how many calories it takes to yell at my new girlfriend. “Alexa, call me Joaquin from now on”…she didn’t get it.


(esung) #79

I don’t know when it happened, but last night I noticed quirky power outlets started working again with smarthings. I haven’t paid much attention to the stuff and didn’t change anything on my apps for long, so it must’ve been something on quirky or smarthings end that fixed it. In any case I’m glad that it works again. Thanks.


(Colin) #80

@twack Noticed that these are still in your github, and with @esung’s post, are these working again? I am starting to be addicted to ST, and I have lots of change around the house to count… a porkfolio would be useful… and Quirky. (see what I did there?) :smiley:


(esung) #81

As far as I can tell my quirky power outlet still works. Status report is still off, and sometimes ST wouldn’t send the proper command because of the wrong status. (Wouldn’t turn off because it thinks they are already off). Also some weird behavior, like my motion triggered smartapp would turn off and back on some quirky outlets whenever there’s a motion. I haven’t tried refreshing the whole set up to see if that fixes it. I’m just glad that they started working again after 3months outage.

Having said that, I am never going to buy other quirky product to use with ST. Anything that is not an official support from ST could face problem like this anytime.


#82

I still get a “you are not authorized to perform the requested operation” when I try to run Quirky (Connect).

I’ve set up the IFTTT channel for the NImbus, but it appears that any text sent via IFTTT will not scroll (although those items set up through the Wink app will when you press down on the device).


#83

Hey @TheStressMachine, can you reference the name of the plugin that you used. Willing to get a little crazy in order to get these things up and running!


(MT) #84

I used Advanced REST Client from the chrome store to manually get my token.

Used the documentation at http://docs.wink.apiary.io to form the message.


(Colin) #85

can you post an example message?


(MT) #86

I don’t have one handy but if you go to the documentation and click “post” under oAuth it pretty much gives it to you.


(Jason Hamilton) #87

So is the quirky connect manager working again? I have an api token from wink. I’d like to have my spotter (since this is the last thing I have left with wink) added into smartthings. When I click to setup in ST it Wink just tells me that redirect is not authorized.


(Roman Iakoubtchik) #88

Since Wink does not currently support/allow ST to authorize using their API, we can remove the authorization and manually hard-code the access & refresh tokens.

Using Advanced REST client (Chrome, Firefox) we set the following:

URL: https://winkapi.quirky.com/oauth2/token
Request: POST
Payload: {"client_id":"c22d82a7fc3d6faf06dcff1bcf0feb52","client_secret":"bd44c524a1df9dce134235d174350603","username":"YOUR-wink-app@email.com","password":"YOUR-wink-app-pass","grant_type":"password"}
Content-Type: application/json

I’ve also posted an updated version of the Quirky-Connect-Service-Manager.groovy smartapp, which worked for me.


Quirky Egg Minder