Power Allowance not working for one device

This is a weird one. I got a new GE 12722 light switch, so that we can turn off a light after so many minutes if it’s left on.

Hooked everything up, and tested that the switch is controllable through the ST app. Light turns on, light turns off. However, if I set a Power Allowance action to turn it off… the light simply stays on forever.

We have one other Power Allowance action that runs an identical GE 12722 switch, and it works fine.

I logged into graph.api.smartthings.com/ and checked things out, but when I compare it to the other switch’s Power Allowance action that is working, I see absolutely no difference. The same things are logged, right up to the point where one shuts off and one doesn’t. Also, I rebooted the hub. No difference.

In case it matters, this is simply a Smart Lighting action turning off a light via Power Allowance after 20 minutes. No time, date, mode, or illuminance options set.

I’m at a loss. Any ideas?

Just exclude the device and add it back again. I did have this same problem before and that’s the only way for my fix.

I’ve actually done that twice, already. Is there a trick to it, or a step I may be missing?

Can you post screenshots of the power allowance setup for the problem switch?

Also, go to that switch’s listing under rooms, click on the switch’s name (not the icons on either side of the name) and that will open the switch’s detail screen.

Then tap on smart apps at the top of the screen and it will show you all the smartapps that are using that switch. Just review that to make sure it’s what you expect it to be

You can also use the “recently” tab at the top of the devices detail screen to see exactly which commands it receives at the point when it is supposed to shut off

Sometimes it’s a matter of having accidentally set up two schedulers that conflict with each other.

Only one smart app for this (new) switch. Here are the two screens.

As for the recently tab. That’s the thing… The smart app should be logging that it’s activating after the 20 minutes, but it just doesn’t show up. In recents, I’ll see the light turn on, and that’s it. It will stay that way, until I manually (through the ST app, or physically at the switch) turn it off. Then, I’ll see the “turn off” entry.

I have the same problem with a Leviton outlet, dropped the Power Allowance and made a rule using Rule Machine and it works well now.

Yeah, I had a Levitron switch first, and found out there’s actually a bug with those that causes this, so I traded it out for a GE that I know works (or… that was the thought, anyway).

In looking for solutions for this, I keep seeing “Rule Machine” as a solution. There’s only one problem with that… Rule Machine doesn’t exist anymore. I guess it’s still there for you if you were lucky enough to have installed it prior to March, 2016… but that won’t really help me.

It isn’t a problem with your device it is a problem known by ST and being worked on. Here is a part of an email I received regarding this.
Thanks very much for letting me know, and sorry about the delay in response (I was OOO for a few days).

What’s happening is a polling request from the Hub to your switch that’s resetting the power allowance time allotment. I can assure you we are taking this issue very seriously. I’ve tagged your account and you’ll be notified as soon as the fix is issued.

1 Like

Anyone know if there’s been any movement on this bug?

Tagging @slagle


Has there been any improvement regarding thus bug. I am having the same problem with my unit too. Time settings in excess of 5 minutes or so cause the switch to remain on due to polling events. This is costing me quite a bit and yo be honest, this power saving function was one of my main reasons for replacing my x10 system with this new hub. Very disappointing :smiley:

Will a fix for this issue be part of the 16.7 Hub firmware upgrade? The release notes are very general.

Looks like this isn’t fixed. Pretty disappointing. No response from ST as well.

Any fixes here? I have the same problem. Leviton dimmer in same room as ST hub works fine with Power Allowance timer, but doesn’t work on 2 Leviton switches on other side of the house.

I’m not sure of the status of the bug discussed in this thread since the thread is two years old and a lot has changed since then.

That said, there is a workaround which should fix the problem for you. Instead of applying power allowance to the switch itself, apply it to a virtual timer. Since virtual timers are not usually polled, you shouldn’t run into the problem described in this thread.

See the how to article in the community – created wiki: