Post Requests for Zwave Edge Drivers Here (community-created)

Additional information

I have five BeSense/Kaipule IM20 with a different fingerprint. Mfg Code: 0214-0003-0001.

When I use the stock Edge driver it lists a bunch of capabilities the sensor doesn’t have. (motionSensor, illuminanceMeasurement, temperatureMeasurement, and relativeHumidityMeasurement are all null.)

Please create an Edge driver for the version 0003 sensor that only displays Battery, Contact, and Tamper states. Many version 3 owners will be grateful!

Wanted to also thank @Mariano_Colmenarejo - my WA00z-1’s were migrated to the edge yesterday and this driver worked like a charm!


I searched the forums but couldnt find anything. Im looking for a driver for Water Leak and Freeze Detector – ZLink Products

Thats the same device as a HomeSeer FS100, but with a different manufacturer ID in the fingerprint.

You may be able to install the HomeSeer driver set and ST may allow you to change to that driver. It may also say the device isn’t supported by that driver and fail to allow it to be set. I’d at least try that first. If that doesn’t work, a driver shouldn’t be too hard to make for it.

1 Like

Thanks. I tried that driver but got an error “Error changing device driver to “HomeSeer Edge Driver”. Ensure that the driver you are trying to change to has a valid fingerprint match with this device.”

Have you found any edge driver for GoControl Z-wave Siren? Can you please share the link?

A post was merged into an existing topic: Post Requests for LAN Edge Drivers Here (community-created)

I wasn’t sure if you were offering to make a driver? Or if I should be looking elsewhere. Anyone else using these zlink devices?

I don’t have either the Zlink nor the FS100W to work with. Both are unavailable for purchase. Unless I can use one for testing, its not feasible (time wise) to build a driver. HomeSeer devices can be, uh, fun to try and create drivers for. :slight_smile:

1 Like

5 posts were split to a new topic: Issue with zwave child switch mc

Is there a driver already for retrofit GoControl recessed lighting z-wave, dimmable?
Model LB65R6Z-1?

I believe it just used the z-wave dimmer switch driver befor. But since 6/26 all of them apprar offline in the app and as driver it shows z-wave switch.
Tried deleting and adding back, but they don’t even get found…

Just uograded to them slowly kight group by light group over the last 3 years and now I’m dead in the water and no clue how to get them ti work again…

Thanks in advance!

Two things.

  1. Before you can add a z-wave device back to the hub you must first Exclude it. In the mobile app open the hub tile, click on 3 dots, settings, z-wave utilities, z-wave exclusion. Then do what ever the manufacturer says you need to do to start exclusion.

  2. Post the fingerprints (manufactures code) of your devices from the Advanced Web App or the API Browser+. And some kind sole might direct you to an existing driver or add the fingerprints to an existing driver.


Thank you, Paul!

To 1: unfortunately, my device does not come up when I go into exclusion mode. It doesn’t tell me how to completely remove my device… for pairing I need to toggle the lightswitch 4 times in 4 seconds. Could that be the same?

To 2: Is this the correct info?
Manufacturer Code
Presentation Id:

Thanks again!

Usually pairing and exclusion are similar so I would try that. If that doesn’t work just keep quickly toggling while hub is in exclusion mode.

Hi @GlowInTheDark

I wiil try to add to my driver in august


Thank you, that would be amazing!

Any help also with what is the best method to re-add these switches to the Smartthings hub, looks like some of the fingerprints are not found, or at times a few of the switches are not being added by the Smaartthings Android app. These switches used to work good on the old platform :frowning:

I have an Qubino Flush 1d relay switch that I use to control my garage door motor.
It is currently using a the default “Z wave switch” edge driver and I can trigger the switch and open/close the door, however I cannot access the door sensor which is also connected to the Qubino device.
Is there an edge driver that allows me to access the sensor?


1 Like