Poor reliability with Ecolink Motion Sensors


(Andrew) #1

My Ecolink Motion Sensors have gotten progressively worse over time. I use them as a trigger to turn on lights in certain rooms. Half the time they don’t detect any motion and I have to walk within about 5 feet of the device and wave my hands to get it to sense motion. They used to pick up from at least 15 to 20 feet away. Are there any external factors that could be causing these to work poorly? Like dust or humidity? I ordered one of the new generation of Samsung’s motion sensors so we will see how that one works out. I just wondered if anybody else has had problems with the Ecolink ones like I have.


(Bob D.) #2

I’ve 4 Ecolink Motion Sensors, 2 for about 3 years and 2 for about 1-1/2 years, using them for the same purpose; turn on lights and sirens. Other than routine battery replacements, I’ve had no issues. Detection ranges appear to be the same, 15’ to 20’ with no loss of detection.


(MarkTr) #3

Any confirmation that it’s distance and not just laggy response? Can you approach them from a blind spot (or temporarily reposition them to make that possible) and see if they’re still slow to respond when the first contact is at the shorter distance?


(Ron Talley) #4

When was the last time you changed the batteries? What type of batteries? I have 4 and they work flawlessly…


(Jimmy) #5

have you added any other z-wave devices in this time?


(Eric) #6

I have the same problems with slow or never triggering of my Ecolink motion sensors. That said, their contact sensors work perfect. Batteries seem to last forever.

For those of you who don’t have issues with them:

1 - What trigger setting do you have them set at?
2 - Are they high up or low?
3 - On an angle?


(Andrew) #7

Thanks for the responses and suggestions. Smartthings app is reporting 100% battery, but I’ve had them for about a year, so maybe I should double check battery. Also, I’m going to try and open them up and clear any possible dust out to see if that helps. I’m also going to make sure I have them set to maximum sensitivity.