Platform Issues? - UndeclaredThrowableException Everywhere

Anybody else seeing a large number of errors (java.lang.reflect.UndeclaredThrowableException) on what appears to be random lines of code across multiple smart apps that have worked for months (even over a year)?

No changes to the apps on my end. Any thoughts?

Same here nothing is working

Cron jobs are failing too.

Things seemed to have gone back to “normal”. Some weird platform issues for 1-2 hours.

I haven’t checked logs, but I had a lot of issues with various apps/device control since mid-morning through the early evening today. It felt like gremlins were in the machine…

I’m still seeing issues. Scheduled jobs keep failing, even after restarting the SmartApps associated with them…

Yep, same here. Several issues/Errors on SmartApps that I never had before, including SmartTiles, since 5pm PST.

I had similar problems today. Solved by rebooting my Harmony hub I think.

I noticed Harmony spamming long debug info in the logs every second seemed to trigger network or QPS throttling by the smartthings servers which clogged commands and timers from the platform, lights not turning off and other weirdness. Tons of Android mobile app “network connection problems” error and IDE failed to load errors all stopped when I reboot the Harmony hub. I could also see my Harmony actions in the “Not yet configured” section of Marketplace. Saving Harmony Connect didn’t fix the problem but as soon as I reboot the Harmony hub the errors stopped. Possibly another access token issue.

The Harmony 1 error per second spam that ended with a Harmony Hub reboot was:
debug addSubscription, params: [appId:<myappID>, param1:subscriptions, action:[GET:executeSmartAppGet, POST:executeSmartAppPost, PUT:executeSmartAppPut, DELETE:executeSmartAppDelete, OPTIONS:executeSmartAppOptions], controller:smartAppApi], request: [attributeName:level, callbackUrl:http://<mylocalLANHarmonyIP>:8222/api/harmony.automation?smartthingscb, deviceId:<mydeviceid>

Also noticed in logs that Cree bulbs are now spitting up warning somewhat frequently. Never noticed this before:
warn DID NOT PARSE MESSAGE for description : catchall: 0104 0008 0A 01 0140 00 142A 00 00 0000 0B 01 0400

im sitting here in the dark, all locally ZWAVE and Zigbee devices are not reporting in or working, but the Cloud to cloud stuff is working ok, so my Hue’s, Netatmo & Tado devices are the only things working.

Ive tried a hub reboot, but i am also getting errors in the log. yet again shows nothing is wrong

Edit… and also my Sonos is working…in the IDE all my devices are showing as INACTIVE

You might be getting rate limited from the log spamming and that’s why the platform is not able to control/respond to your non-C2C ST devices. See if you can cut down the log errors by powering down a spamming device. No idea what changed on the ST side. No info.

there is definitely no log spamming occuring, if anything my log is devoid of a hell of lot of entries but looking at my logs i seem to see a lot of info relating to hub offline/online messages.

I personally think someone at ST has pushed the firmware update that is scheduled for Thursday early by accident (purely speculation on my part, the firmware section of the IDE is not showing an update, but who knows if its because the hub isn’t reporting back correctly)

Logs are missing some events.

Some jobs still a unstable.

Harmony spams the logs anytime something Harmony-related is activated…

I was working again about 10am ish GMT, didn’t last long about 12am GMT the hub started doing it active/Inactive dance again, but this time it must have been happening slower as i was getting notifications from the ST app this time, i believe the countdown is 10 minutes offline before the notification is sent.

My internet has been rock solid all morning as i am working at home and VPN’ed into work with no disruption at all.

one change i made yesterday was to use pollster to get the status of my Sonos devices every minute so i could use playtext and resume correctly. in the logs i could see that the hub became active, then pollster would kick in and get the next updates from my 4 sonos devices… then after maybe a minute it would go offline the Zwave or Zigbee radios did not start.

I removed this change (it was working for hours last night with it with no problems) and i have rebooted the hub and it all seems to be ok for the moment, its not gone offline, but i have no confidence this will continue to work. as i have been working 2 hours with the sonos pollster job in place.

While I’m not getting that exact error, I believe recent instability is due to cloud changes in preparation for a hub firmware update on Thursday (per ST email). Not sure if V2 or V1 hub or both, and this is complete conjecture…

Either way, my setup survived this storm mostly, except I had to reset a few SmartApps. There is no automated way of doing that, and no self healing despite advertisements to the contrary. It’s the one thing that would make my setup 100% (I consider it 99% reliable, I use mostly events to drive things, not times)

Could be preparation. If so, it worries me a bit with respect to Thursday.

Currently some jobs are still a little weird. Harmony-related events fail and flood the logs.

I agree Nothing is working for me right now and I’ve just about had it. Very close to tearing everything out and go back to the old fashion way. I’m exhausted troubleshooting my house 1-2 hours a day.

Most of my automations are event driven. However, the turn off after X minutes are now failing too. Those jobs never fire.

EDIT - Scheduled jobs have always been a little dicey. No longer true, now they fail religiously.

@slagle @jody.albritton Anything on the back end happening that is causing apps and jobs to fail everywhere?

Just for the record I’m in the same boat here. The top of my list is the “your network appears to be having trouble…please check your network connection”.

So I did and for the record my network connection is fine for everything except ST.

I was getting that error all night. I wasn’t able to do anything within my app and I sent support an email with the screen shot of the error.

Same thing here. Cron jobs were reliable. Now every job fails within an hour (at most). I wonder what was changed.