Platform Issues - Today

devicetype
ide

(Anthony S.) #1

@slagle @jody.albritton
I’m trying to work on a app and device and I can’t change modes or execute routines that changes modes. I’ve even tried to manually change it under locations in the IDE.
I’m also seeing what is believe is a DB error Generic.JDBC.Exception when trying to save code changes to a device type in the IDE.
I really have been noticing a steady increase in stability lately. I have had a schedule issue in the last 3 days so thanks for that. I just want you to know that I’m not trying to just dump on you guys. I just look forward to a time when there is less of these type of issues. :slightly_smiling:

Am I the only one having issues?


(Jason) #2

I would submit a ticket

They’ve pushed a few hot fixes that have helped. I Can’t wait until the new scheduler rolls out though!


(Anthony S.) #3

Sorry I forgot to add I opened up requests for both issues earlier today

Never mind it’s seems to be working nowish.


(Anthony S.) #4

cancel that it’s still not working org.springframework.dao.CannotAcquireLockException: Hibernate operation: could not update: [physicalgraph.device.DeviceTypeHandler#]; SQL [update device_type_handler set version=?, code=?, date_created=?, device_type_id=?, handler_version=?, last_updated=?, state=? where id=? and version=?]; Lock wait timeout exceeded; try restarting transaction; nested exception is java.sql.SQLException: Lock wait timeout exceeded; try restarting transaction


(Anthony S.) #5

I’m really starting to get ticked off… My damn house is stuck in Morning mode meaning that the only way to stop my lights and morning automations from triggering is to remove all of the automations and then have to re-add them after it’s fixed.
I emailed support for both incidences separately and it’s been 6+ hours

@slagle @jody.albritton Can you tell me the need to actually send a report request in if they just go unanswered?


(Tim Slagle) #6

Because they are the people who can help. :slightly_smiling:

Have you tried changing your mode in the IDE?


(Anthony S.) #7

I try very hard to remember that Tim I really do… My problem is it feels like changes get made to the platform and then support is non-existent to the consumer. To me support feels like its sole purpose is to collect issue metrics\trends so the company can direct the appropriate resources to address that fire.
Its not what it should be.
Instead of a black hole with the mentality that well we did our part and reported the issue and now wait and just hope it gets addressed over the next 2 months.

It should be a place for someone to go to get actual help from a knowledgeable employee that might have an answer.

That was the first thing tried… It just sits for a couple minutes than times out with a 500 error message.
It honestly feels like parts of my account are corrupted


(Jason) #8

Some members of the community have been using rule machine in place of routines. Have you tried this?


(Michael Hess) #9

LOL, you should try dealing with Insteon support, SmartThings make them look like a third world country that’s recently been nuked.

Just thought I’d throw some perspective out. :slight_smile:


(Jonathan Bond) #10

I have simple routines that turn on certain lights at sunset, turn light on with motion, and turn some off at bedtime. I have tried rule machine as well as smartrules and they are both failing. I also have rules that aren’t functioning properly as well.

Am I missing something that would actually tell me that smartthings is having issues and I shouldn’t expect them to function properly?

Is this something on my end or this completely a sever issue?


(Michael Hess) #11

The scheduler is FUBAR so sunset will definitely not work reliably. I have lights (motion) delaying by up to around 20 seconds before turning on as well, been going on for weeks now. Rules are a crap shot as well if they rely on timing in minute and second level.

Basically my family has made a game out of it, “hey guys, place bets on how long it’ll take for my office lights to turn off, if at all today!”


(Anthony S.) #12

definitely… i only have 2 automated routines and the rest are in RM


(Bobby) #13

Are you using any LAN devices with any of your routines? I used to have similar mode problems on regular basis but that stopped when I started using only local devices. Anything that’s not local gets automated with Rule. I haven’t had modes sticking on me since I followed this rule