PlantLink Connection problem


#1

When I use PlantLink Connection in ST, each plant sensor shows up twice in the PlantLink Dashboard. Anyone else have this problem???


(Darryl) #2

I did. And when I reached out to PlantLink support, they said they were aware of the issue, didn’t have root cause, and that it wasn’t consistently occurring. They were going to keep looking at it though.

The technician suggested I delete one of them, and that it should be fine. I have yet to do that out of laziness.


#3

I just got the same “advice” from PlantLink - but when I deleted, it then made the other not seem to work!


(Darryl) #4

Please let me know how it works out. They should fix it, in my opinion. :smile:


(Mark B) #5

Mine doesn’t show up twice in my PL dashboard but it does show up there as “Link missing” - likely due to the fact that ZigBee devices can only be paired to a single hub? I followed the PL integration note within the ST app to get ST to find/connect a PlantLink previously connected to my PL hub. It found it, I ran the PL Connector, logged in w/my myPlantLink creds. and was done. What I can’t figure out is why the PL constantly displays the value of 0% in the ST app. tile & doesn’t ever change. All other values display in their appropriate tiles in ST.

Hmmm … doesn’t seem like the PL/ST integration has been fully baked yet.


(Brian) #6

I have the same as @darrylb and @logar - double entries in my PlantLink Dashboard. I’ll also contact PL support. I’m not encouraged but maybe three incidents for them is a trend and they’ll take action to resolve the issue.


(Brian) #7

Support request sent. One additional thing I found. In my SmartThings tile for the sensors, the bottom section says: Please Install SmartApp “Required PlantLink Connector”. I’ve already done that and it appears in the SmartApps section of the Thing, as well as the sensor (although doubled) appears in My Dashboard on PlantLink. I suppose @mrmedia is correct: [quote=“mrmedia, post:5, topic:34738”]
Hmmm … doesn’t seem like the PL/ST integration has been fully baked yet.
[/quote]


(Brian) #9

And here is the answer:
Thank you for your interest in PlantLink. Having two plants show up for one sensor/Link is still a known bug. We suggest leaving both plants for now; if you delete one it will remove your sensor and you’ll have to re-pair. It should still give you correct readings in the mean time.
We’ve traced a likely culprit down to a really low level inconsistency with the timing between SmartThings and PlantLink… but we haven’t worked out a patch yet… but we’re working on it! We’re sorry that we don’t have a really good answer to share yet.

It would appear they are close to a resolution, but not quite there yet…


(Chick Webb) #10

Here’s a note for anyone having trouble installing the Smart App.

I paired a couple of sensors with my ST hub, and they were reporting data, so I knew they’re working. I also created a PlantLink account, but did not add a hub as I have no intention of using it. But, when I tried to install the Smart App, at the point where you select the sensors I did that, but tapping on Done generated the red bar of death and “An unexpected error occurred.” I was unable to complete the install of the Smart App.

The problem turned out to be the device type. For some reason they paired using the “PlantLink Direct Sensor” type and not the official “PlantLink” type. Once I changed that in the IDE I was able to get the Smart App to install.


Plant Link Intergration
(Mark B) #11

I haven’t checked yet but are you saying there are 2 device types available to choose from in the IDE & the correct one to choose is labeled “PlantLink”


(Chick Webb) #12

Because I had previously installed a custom DTH that @Kristopher had written, yes. If you don’t install that you should only have the one.


(Alex K ) #13

Have same problem with duplicate. also with “you need to install plantlink connector error” message. Also not sure how to set plant type in ST itself. I tried to set it in plantlink dashboard but after next sync ST created new devices and my renamed one is not reporting anything.

Something is broken in the integration


(Chick Webb) #14

My email dialogue with their support folks indicated that is still true, yeah.


(Alex K ) #15

I just tried to edit the link i had deployed and change the plant type from default to what it actually is. I edited both of them in myplantlink. They both started intial calibration again and new 3rd one got created with default setting. And there is no way to set plant type from ST itself. So this is totally broken


(sidjohn1) #16

I was able to fix this by powering off the ST hub and then deleting all the plants and senors in the plantlink app, then I powered back on the ST hub. I waited about an hr before opening the plantlink app and now I have no dups. I didn’t delete or change anything inside ST.


(Carlos Isturiz) #17

I have the same problem. Four real sensors and four “Initial Calibration” dupes. I have deleted them and restarted several times. Anyone has a permanent fix?


(Carlos Isturiz) #18

IS this still working fine for you? I tried it but after a few hours, the dupes showed up again