Plant Link Intergration

Mine still works

My plantlink has been calibrating for 2.5 days. Is there something wrong ? The app says connected to my plantlink but don’t see anything other than Calibrating. The plantlink website doesn’t show I have any link active.

sounds like something went wrong. Logs? I would rerun through the app set up

I reinstalled the device and app and it seems connected. I installed the plantlink direct monitor. Where do I see the nice info layout like above ? Each time I click on the smartapp on my phone, it just goes to settings for the direct monitor and no real soil info. Thanks.

I am sorry but I don’t follow your question.

If you are using the default DTH and the Default ST Plantlink app, you should have a plantlink account that you created. You put that in the Plantlink app, so ST know to ship the data over to them. Withing 60 min, the plant should show up, and you can do additional, settings in the plantlink app or website.

If you are using the custom DTH, I am sorry, I can’t help with that.

Thanks for your reply. I am using the Plantlink Connector that is supported by Smartthings. I see my sensor in the Myplantlink dashboard (showing up twice, I know that is a bug from reading other posts). But I can’t see any data! I don’t see any moisture info or anything. I click on the calendar and from there can’t click to anything else. I see settings and soil but basically no data is showing anywhere about the soil or anything else. My battery level is shown as Low and I am waiting from AAAA batteries to arrive. Is that why nothing is on the website for me to see?

what is the recent activity showing in ST? What do the Logs in ST show?

Here is what it repeats in the Logs every 15 mins. Another question is… Do i need to have a device handler installed on the IDE? I don’t have on installed there. Thanks.

2017-06-19 12:43:38.330 PM EDT
moments ago DEVICE plantStatus Low Battery Plant Link plant status is Low Battery

2017-06-19 12:43:38.317 PM EDT
moments ago APP_COMMAND setStatusIcon PlantLink Connector sent setStatusIcon command to Plant Link

2017-06-19 12:43:37.528 PM EDT
moments ago DEVICE moisture_status
moisture_status
{“type”:“link”,“signal”:"0x00… Plant Link moisturestatus is {“type”:“link”,“signal”:“0x00”,“zigbeedeviceid”:“0022A300000A36C0”,“created”:1497890617,"moisture…

2017-06-19 12:43:36.924 PM EDT
moments ago DEVICE battery_status
battery_status
{“type”:“link”,“signal”:"0x00… Plant Link batterystatus is {“type”:“link”,“signal”:“0x00”,"zigb

is that that log for the probe or the app? Looks like the probe to me. What does the app log look like?

The battery might be the issue. Keep them on hand. if moisture gets inside, it will drain the batteries in a day or less.

Thanks again for your help. Here it is for the App (I think) … Not much info here:

Date Source Type Name Value User Displayed Text Changed
2017-06-19 12:43:38.317 PM EDT
12 minutes ago APP_COMMAND setStatusIcon PlantLink Connector sent setStatusIcon command to Plant Link true
2017-06-19 12:29:17.523 PM EDT
27 minutes ago APP_COMMAND setStatusIcon PlantLink Connector sent setStatusIcon command to Plant Link true
2017-06-19 12:29:09.588 PM EDT
27 minutes ago APP_COMMAND setStatusIcon PlantLink Connector sent setStatusIcon command to Plant Link true
2017-06-19 12:14:39.659 PM EDT
41 minutes ago APP_COMMAND setStatusIcon PlantLink Connector sent setStatusIcon command to Plant Link true

ok, everything looks ok as far as i can tell i would say give it 24-48 hours then open a support case with plantlink

OK thanks for all of your prompt replies, I really appreciate it.
Last question… Where on the plantlink website do you see the soil info? I go to Dashboarrd and I see my sensors… do I click on the calendar… or what?
Thanks!

Click on the sensor then click edit.

I cannot seem to get the plantlink to pair using the plantlink direct. I have created the device handler from code, but if I try to add device from my mobile it does not find and if I add a device from the computer it does not show any data in smart things. Not even the battery level. Do I need to add the mac address in my devices?

I’ve had the plantlink working for 6 months. Today it stopped reading moisture, so I pulled the batteries and reset it.

I then added it back to smartthings. I then started going through the Plantlink connector setup:

  1. Login - my info
  2. Choose device - plntlink
  3. Click done

It is at step 3 where I get “an unexpected error has occurred”

From the log:

java.lang.IllegalArgumentException: Command ‘setStatusIcon’ is not supported by device 3b9d62a3-7979-433a-a848-08892f0193fc of type ‘Plant Link’. Supported commands: [ping] @ line 114

Can’t seem to get past this, having cycled through a few times. Always the same error.

Thoughts?

Yesterday I literally switched over my PlantLink from using their hub to going through ST and had the same issue. I found a post on here (not sure where it was) pointing out that there are two Device Handlers in SmartThings for the PlantLink.

There is “Plant Link” which is what my ST hub used automatically. And there is “PlantLink”. The latter works for me and did not give me the Unexpected Error toast. I wasn’t watching my log so I can’t confirm if something else changed.

Try going into your devices, editing the PlantLink to use this other handler.

Thanks for the insights.

I’m not fully sure on how to force the “PlantLink” device handler vs the “Plant Link” device handler. I’m clearly missing a fundamental understanding here.

When I choose to add a new device, it automatically finds “Plant Link” and that brings me to the error during registration.

I did a search and found another handler and I’ve added KristopherKubicki/device-plantlink-direct as a device handler in the IDE. There doesn’t seem to be a way to choose this device handler. Smartthings just discovers the device when I add it and picks the device handler it wants to use. I still get the same error so I assume it is still using the other device handler.

If I attempt to add the Plantlink manually, there is only one choice under irrigation - PlantLink Soil Moisture Sensor (Oso Technologies Inc.) This also leads to that same error.

So how do I actually choose what handler I want to use from the app?

Thanks.

I’m unsure of a way through the app.

If you have access to a computer (or I suppose through your phone’s browser) you can navigate to:

https://graph.api.smartthings.com/device/list

Logging in with your ST account, you can view the devices on your hub. If you click a device and view its page, you’ll see an “Edit” button at the bottom left. This lets you update some properties. In this case it’s the "Type* " that needs to change. In the drop down there should be two plant link related handlers, “Plant Link” and “PlantLink”. For me, this was set to “Plant Link” by default, and changing to the “PlantLink” allowed the connector to work without the ‘unexpected error’

I tried to grab some screenshots, hopefully it helps:

Screenshots

Edit: Here’s the post that lead me to this change that fixed this issue for me

3 Likes

Success.

And now I actually understand how to alter device handlers which I am sure will come in handy in the future.

Thanks for the detailed explanation!

No problem! There’s a ton of powerful and cool stuff just tucked slightly out of the way. Currently I’m exploring webCoRE. My plant can control things now based on moisture reading from the link. Cyborg plant.