Phone as presence sensor not triggering automations in new app

On my new Note 20 Ultra I can’t even enable “get location from this phone”. It tells me ‘try again later’ :man_shrugging:t3:

Had Same Issue 2 days ago. I uninstalled the app, reinstalled without any success . then after 1 day i was able to turn location on but now i have 2 phones with same name . and still does not detect location, in IDE i see 2 phones with same name, one as presence sensor but showing last activity from 6 days ago, the 2nd device has same name but it’s type is “placeholder” . i really hope someone can explain to me how to resolve this. no location based automations running anymore

2 Likes

With help from Support, I finally figured out why my Automations weren’t triggering.

My “I’m back” Automation has 2 conditions: a phone-as-presence sensor returns and Location is Away. Well, it seems that the Location Mode changes I had in my Routines didn’t migrate properly. When I put the Location Mode changes into my Scenes, ensuring the mode is Away when I expect “I’m Back” to trigger, it did!

All is fixed here. Hopefully this ends up being the case for some of you guys.

1 Like

That should work if one one house member but what about 4 members

Works the same with multiple. When you configure your automation, be sure to choose all of the members as triggering sensors.

I’m still having the issue - i.e. phone as presence sensor not triggering automations.

Sometimes, it’s because mobile presence (using the four iPhones in our family) will not work.

Sometimes, mobile presence works – but the related automation doesn’t fire for some reason.

My automations - at least the ones using mobile presence - are all super simple. The only "If’ statement that I have is a mobile device arriving or departing, with no other conditions. And still, they’re not 100% reliable.

The bigger issue for me, though, is the inconsistency and lack of reliability with mobile presence. It doesn’t work well. (When my phones were set up the ‘old’ way through the Classic app, it worked. Now that I’ve set them up again in the new app, presence only works occasionally. While ST Support has been very responsive, they’ve been unable to resolve it for me.)

Sorry to hear, Suth. Have you submitted a ticket with Support?

Yes. Multiple.

The last update:

We have reviewed your account and see that the both mobile presence devices are updating, so any issue with mobile presence accuracy will be caused by outside factors in the phone itself.

I replied back to that to reinforce that mobile presence did work perfectly when the phones were set up through the Classic app, and that the problems all started when I migrated to the new app (which required me to set up the phones from scratch, and then delete the old ‘devices’ that I’d used in Classic). It used to work. It doesn’t now. Nothing else has changed.

i am having the same problem - it only started with the last app update.

I am beyond frustrated at mobile phone presence not working.

It’s gone from being 100% reliable to being (to put it as nicely as I can) buggy and inconsistent.

What makes it even more frustrating … now that mobile phones no longer appear in the app as “Things” (like they did in the Classic app) there’s absolutely no way to know if presence is actually working — without logging in to the IDE, which is also going away. Mobile phone presence is now essentially invisible. Which is ridiculous.

I checked the IDE this morning. Of our family’s four iPhones, only two currently show a correct presence status. What’s the point.

(And yet magically, Uber and my local taxi company can find me within 30 feet of my exact location — consistently. Some of the fast food and restaurant apps that I use can tell exactly when arrive at their location, without fail. But SmartThings? Nope.)

1 Like

Mine seems to be working as expected now. About 2 weeks ago, I set up a WebCoRE piston to text me when I get home (as a test). It consistently triggers as I pull into our cul-de-sac.

I thought that presence-based automations were failing, but I found that I needed to log back into my Bond linked service. I checked my history, and

Mind you, I joined this party late, so I never used Classic (and thus never integrated Life360). I tested WebCoRE presence detection, but was getting delays from minutes to days. Not certain how to explain what might be different, nor am I smart enough to troubleshoot this. Happy to try to answer any questions if someone wants to know details about my setup.

This worked. Thank you very much. Wish I read this sooner.

Broken for me too.

IDE will always show the presence correctly, but the automations will NOT fire.

Same issues here since switching over to the new app. I used the Life360 integration as I found mobile presence through ST to perform pretty poorly even in the Classic app. This morning, in response to my ticket, the tech informed me that the ability to trigger automations through the Life360 presence integration is going away and incompatible with the new app.

I have found that L360 isn’t completely compatible within the new app. It isn’t L360, it’s the app. I’ve arrived home and had ST indicate that L360 is showing away, when in fact L360 indicates I’m home.

So I’ve done what I’ve done with so many other things, keep the automation out of ST as much as possible. I use IFTTT w/L360 to throw virtual switches to turn STHM on and off.