Philips Hue Problem


#1

I am having trouble with a Philips Hue. When I first set it up, it worked fine. ST was able to see it and it added all the bulbs.

Silly me was playing around and I uninstalled the Philips Bridge. Now I can not pair with it any more.

I have tried resetting the Philips Hub (using the little button on the back of it).
I uninstalled the Hue (Connect) multiple times
The Philips Hue App has no problem seeing it.
But when I try to add it back into ST, it cannot find it.

When I am trying to discover it, I am seeing errors repeat over and over in the event log for the ST HUB. Can anyone help me get past this?

Thanks!
Steve

1b452c5a-23e9-4646-a3b4-14c8c6b8f0a2 ‎3‎:‎58‎:‎48‎ ‎PM: debug Executing GET /description.xml HTTP/1.1
Accept: /
User-Agent: Linux UPnP/1.0 SmartThings
HOST: 192.168.1.200:80

on Homestead Hub via sendHubCommand

1b452c5a-23e9-4646-a3b4-14c8c6b8f0a2 ‎3‎:‎58‎:‎48‎ ‎PM: trace verifyHueBridge(C0A801C8:0050)

d94974cb-b7ca-480c-9eb6-1780fa521851 ‎3‎:‎58‎:‎45‎ ‎PM: error groovy.json.JsonException: Lexing failed on line: 1, column: 1, while reading ‘<’, no possible valid JSON value or punctuation could be recognized. @ line 518

d94974cb-b7ca-480c-9eb6-1780fa521851 ‎3‎:‎58‎:‎45‎ ‎PM: debug Parsing ‘index:01, mac:00178817CC59, ip:C0A801C8, port:0050, headers:SFRUUC8xLjEgMjAwIE9LDQpDb250ZW50LXR5cGU6IHRleHQveG1sDQpDb25uZWN0aW9uOiBLZWVwLUFsaXZl, body:PD94bWwgdmVyc2lvbj0iMS4wIiBlbmNvZGluZz0iVVRGLTgiID8+Cjxyb290IHhtbG5zPSJ1cm46c2NoZW1hcy11cG5wLW9yZzpkZXZpY2UtMS0wIj4KPHNwZWNWZXJzaW9uPgo8bWFqb3I+MTwvbWFqb3I+CjxtaW5vcj4wPC9taW5vcj4KPC9zcGVjVmVyc2lvbj4KPFVSTEJhc2U+aHR0cDovLzE5Mi4xNjguMS4yMDA6ODAvPC9VUkxCYXNlPgo8ZGV2aWNlPgo8ZGV2aWNlVHlwZT51cm46c2NoZW1hcy11cG5wLW9yZzpkZXZpY2U6QmFzaWM6MTwvZGV2aWNlVHlwZT4KPGZyaWVuZGx5TmFtZT5QaGlsaXBzIGh1ZSAoMTkyLjE2OC4xLjIwMCk8L2ZyaWVuZGx5TmFtZT4KPG1hbnVmYWN0dXJlcj5Sb3lhbCBQaGlsaXBzIEVsZWN0cm9uaWNzPC9tYW51ZmFjdHVyZXI+CjxtYW51ZmFjdHVyZXJVUkw+aHR0cDovL3d3dy5waGlsaXBzLmNvbTwvbWFudWZhY3R1cmVyVVJMPgo8bW9kZWxEZXNjcmlwdGlvbj5QaGlsaXBzIGh1ZSBQZXJzb25hbCBXaXJlbGVzcyBMaWdodGluZzwvbW9kZWxEZXNjcmlwdGlvbj4KPG1vZGVsTmFtZT5QaGlsaXBzIGh1ZSBicmlkZ2UgMjAxMjwvbW9kZWxOYW1lPgo8bW9kZWxOdW1iZXI+OTI5MDAwMjI2NTAzPC9tb2RlbE51bWJlcj4KPG1vZGVsVVJMPmh0dHA6Ly93d3cubWVldGh1ZS5jb208L21vZGVsVVJMPgo8c2VyaWFsTnVtYmVyPjAwMTc4ODE3Y2M1OTwvc2VyaWFsTnVtYmVyPgo8VUROPnV1aWQ6MmY0MDJmODAtZGE1MC0xMWUxLTliMjMtMDAxNzg4MTdjYzU5PC9VRE4+CjxwcmVzZW50YXRpb25VUkw+aW5kZXguaHRtbDwvcHJlc2VudGF0aW9uVVJMPgo8aWNvbkxpc3Q+CjxpY29uPgo8bWltZXR5cGU+aW1hZ2UvcG5nPC9taW1ldHlwZT4KPGhlaWdodD40ODwvaGVpZ2h0Pgo8d2lkdGg+NDg8L3dpZHRoPgo8ZGVwdGg+MjQ8L2RlcHRoPgo8dXJsPmh1ZV9sb2dvXzAucG5nPC91cmw+CjwvaWNvbj4KPGljb24+CjxtaW1ldHlwZT5pbWFnZS9wbmc8L21pbWV0eXBlPgo8aGVpZ2h0PjEyMDwvaGVpZ2h0Pgo8d2lkdGg+MTIwPC93aWR0aD4KPGRlcHRoPjI0PC9kZXB0aD4KPHVybD5odWVfbG9nb18zLnBuZzwvdXJsPgo8L2ljb24+CjwvaWNvbkxpc3Q+CjwvZGV2aWNlPgo8L3Jvb3Q+Cg==’


Hue(Connect) won't connect
(Tony - SmartThings Unpublished Contributor ) #2

I had this problem about 10 days ago. I had to notify ST Support. They finally got me sorted, but it took two complete wipes / resets of the ST hub (which means I’m now reentering all of my apps, devices, settings. Ugh.

ST Support was very responsive, and the person I was speaking with said that our issue is one for which they are actively working on a fix. No word on when it will be released.


#3

Ack!

Is it only discovery of the Philips Hue that is busted? If so, I guess I’ll live without the Philips Hue then until they fix it.

Or all discovery?

I’m afraid to remove something just to test it if I wont be able to add it back. I still seem to be able to control the other things I have.

Thank you very much for your reply. I can at least stop messing with it… was pulling my hair out. :smile:


(Tony - SmartThings Unpublished Contributor ) #4

Have you tried updating your hub? ST released an update 5 hours ago - the update description has language that appears to relate.


#5

I’ll try that. Thanks!


#6

Did the update and I still have the issue. I appreciate the suggestion though for sure!

Guess I’ll watch for a future update and live without the Hue for a while. I do not want to redo everything unless I have to.

Thanks again!


(Tony - SmartThings Unpublished Contributor ) #7

Steve - you should send ST support an email. They might be able to help you individually before they release the fix.


#8

ST reached out to me before I had a chance to submit an email. :slight_smile: Wow the community support from you all and ST support is so amazing.


(Mike) #9

I’m running into this exact same issue. I emailed ST support last week and have not heard back from them. At this point in time my Hue lights are unusable.


(Tony - SmartThings Unpublished Contributor ) #10

Argh. It happened AGAIN! Unbelievable.


(Mike) #11

From what I can tell, you remove the SmartApp (Hue Connect) however it doesn’t really uninstall. It continues to run totally invisible to either the iPhone app or the ST web interface. When you try to install the Hue Connect app again, check out Live Logging in the ide. The “phantom” app and device spring forth with logging. Even though the UI doesn’t display the device (Hue Bridge) or the app (Hue Connec). Also, if you log into the ide and try to delete the SmartApp/DeviceType it tells you it’s in use but you won’t be able to find any trace of it in use except via the live logging during a new app installation attempt. It’s frustrating since there’s little we can do as users, I think the phantom device/app is running on the platform somewhere.


(Doug Dale) #12

Were you able to solve this problem? I’ve just started having the same problem after upgrading my Hue bridge to the new firmware that came out yesterday (01023599). I can’t control the Hue lights, the bridge does not even show up in Hue (Connect), and when it scans for bridges, I get the same JSON error that is shown above.

I’ve contacted SmartThings support. I’m hoping that you or they will have some tips before I go through all the pain you guys have experienced removing and trying to re-add everything.


(Tony - SmartThings Unpublished Contributor ) #13

In my experience, ST support are the only people who can solve this type of problem. Do not bother with the hassle and pain of removing everything.

Its been a continuing / evolving issue for me (lasting about 6 weeks). I had a ghost hue bridge for a long time (~4 weeks). ST support managed to remove it. However, now I have ghost hue lights. Its incredibly frustrating.


(Doug Dale) #14

After a couple e-mails back and forth with SmartThings support, I’m back up and running. They had me try resetting the ST hub and changing the IP address of the Hue bridge, but that didn’t work, so they asked me to remove all my bulbs and the Hue bridge. I tried to do the sequence they suggested, but I could not remove the bridge without first removing the Hue (Connect) app.

When I did that, I ended up with what (I think) you describe of a ‘ghost’ bridge. It would show up in the app, but not in the web IDE. I stumbled on a Flush Local Devices option on the hub page of the web IDE and that caused by ‘ghost’ bridge to disappear from the phone app.

I then added back my Hue lights. I was able to successfully rediscover and reconnect with the Hue bridge. I selected all my bulbs and had an error message, but I think that was a glitch because when I went back in, all the bulbs were there.

Now I have to go back in and reinstall all my apps that used my Hue bulbs.

I don’t know if there is anything there that helps anyone else. I hope so, though.


(Tony - SmartThings Unpublished Contributor ) #15

Where is the “flush local devices” option? I don’t see it on my hub page on web IDE.


(Doug Dale) #16

I can no longer find it on my hub page, either. As I remember it was right below the ‘Utilities’ section. Either something changed or the option only appears in certain circumstances.