Hue(Connect) won't connect

My Hue(Connect) app stopped seeing my Hue Bridge a couple days ago and it can’t find it anymore. It has been working fine for months. I think it happened after I did a Z-Wave Repair but it could just be a coincidence.

The IP address of the Hue Bridge has not changed and it does have the latest firmware. I can control my 35+ Hue devices just fine through any other mean but ST.

I’ve tried uninstalling the Hue(Connect) app but I can’t and only get an error message both through the App (“NSURLErrorDomain error - 1005”) and the IDE (“No such property: id for class: org.codehaus.groovy.grails.web.taglib.NamespacedTagDispatcher”).

Have you seen this before? How did you solved it?

I had this happen to me a couple of days ago when I updated the Hue bridge to the latest firmware. I’m working with SmartThings support right now (back and forth by e-mail), but don’t have a solution yet.

Others have seen this problem to, as indicated by this thread:

Wow… The WAF took a nose dive yesterday… Now half of our wall switches are useless…

I was able to restore Hue connectivity today with the help of ST support. Unfortunately, it required removing all my apps that use Hue bulbs, removing the bulbs, and then the bridge and Hue (Connect) app, then re-adding them all. See the link to the thread that I posted earlier to get all the details. Hope it helps…

Ouch. I’ll wait to hear from them (I have an open ticket) as I have over 35 Hue devices…

Ouch, indeed. I only have 7.

I’ve been able to make it work again, but not without pain… I’ve remove all my Hue devices, one by one with all their apps- and then I’ve be able to uninstall the Hue(Connect) app.

From there I have been able to re-install the Hue(Connect) app and it was able to see my Hue bridge again. That’s quite inconvenient, but it now all works as before…

Can’t wait for v2…

My Hue Bridge went south 2 days ago but I know its because the IP address changed after a router reset… won’t let me remove it or Hue Connect from the App… have reached out to support but oh I hope I don’t need to remove all my Hue stuff again!

Using the hue app, you could set your ip address back to the old address. This would fix the issue and prevent it from happening in the future.

or update your device network id for the hub in the ide? Wouldn’t this work? just convert to hex.

Hi @jody.albritton and @pstuart

Tried changing the IP back in the Hue App (didn’t know you could do that!) and nothing at all. Hue connect just says no hubs and doesn’t find one.

If you go into the IDE devices, what hue related devices do you see and what is the DNI (Device Network ID)?

Here you go

Ok, so the Hue thinks its ip is on port 80 and that matches the hex DNI C0A80014:0050

Is that the current IP of the Hue hub?

Also, a screen shot of the list events might be helpful as well.

Yup thats the current IP of the hub.

Event’s list may well not be as helpful as you would think…

Hmmm, seems strange. What happens if you go through the app and do a config (gear thing) and click your way through the smartapp setup? Any events or logs in the IDE?

After setting the IP address back, you might need to to reboot your hub. I would also log out and back in to the mobile app and then check the hue connect app. @jonallsebrook

Hi All,

So after advice from support I took the plunge and deleted all Hue stuff including the numerous smart apps from the system. Re added the hub and all is well.

It’s actually not a bad thing as it’s got me to Spring clean my ST setup and tweak things!

Thanks for all the input much appreciated!

Looks like it’s the only way to go for now… I did a full cleanup yesterday and so far so good…

I had exactly the same problem of my SmartThings Hub v2 not able to find my Hue Bridge anymore after I changed my router setup. I tried all solutions mentioned on the SmartThings support site but the Hue Bridge remained undiscoverable.

In my case, the steps below worked and allowed me to solve the problem without having to go through the dreaded procedure of deleting all my Hue devices and start over again. Hope it works for you as well.

  • Go to
  • Select “My Devices”
  • From the list of devices, select “Hue Bridge”
  • Press the red “Delete” button
    (to my surprise, I was able to delete it without warnings of it being connected to existing SmartApps etc)
  • Start your SmartThings app
  • Click “My Home” and select “SmartApps”
  • Click on "Hue (Connect) to start discovery of Hue devices (don’t forget to press the button on the Hue Bridge)

In my case, it found the Hue bridge instantly and I was able to easily restore my Hue setup.