New Philips Hue Hub Issues

I noticed that after upgrading to the Hue Hub V2 that some of my commands from apps don’t work. I am talking about the new Hue hub that is square and supports HomeKit, not the V2 SmartThings hub, which I also have.

Here’s a few errors from the logs of the Hue Bridge. Is there an update of some sort, I don’t seem to be able to edit the code for the Hue Bridge under “My Devices”

error groovy.json.JsonException: Expected a value on line: 1, column: 2.
error groovy.json.JsonException: Expected a closing curly brace '}' or a comma ',' on line: 1, column: 90.
error groovy.json.JsonException: Expected a closing curly brace '}' or a comma ',' on line: 1, column: 145.

The code is in the SmartThings-Public GitHub repository.

Hi Patrick,
Thanks for the heads up!
I requested a bridge V2 to run some tests but if find something in the code that can be improved please post it and mention me and I will get it published.
Thanks a lot!


Any success in making Hue v2 work?

I also just updated to the v2 Hue hub and can no longer control my lamps… :unamused:

As a followup, the reason my hue bulbs weren’t working is because SmartThings was still linked to the old hub (obviously, I guess).

Here are the steps I took to fix this…

  1. Go to My Home
  2. Tap the SmartApps tab
  3. Tap the Hue (Connect) SmartApp
  4. You should see a field to select your bulbs and another one describing your bridge. Tap on the Hue Bridge
  5. A bit redundant… but you should now see Select Hue Bridge field. Tap that.
  • If there are 2 bridges shown (as was the case for me), simply select the one that isn’t selected and then tap Done
  • If there is only 1 bridge, try unchecking the existing bridge and tapping Done, then tap Select Hue Bridge field again and click Done … again.
  1. Select Next and/or Done to finish pairing the device
  2. You should now be back on the Hue (Connect) SmartApp screen. Make sure all of your bulbs are selected and then click Done one more time.
  3. Gain control of your bulbs again!

I had an even worse issue. I got the new hue hub and got the migration done it worked fine with smart things. Then I got the new smart things up and redid everything and hue worked fine. I added a bulb and it worked well. I tried adding a bulb and I got the error it could not save plumb list (can’t remember exactly) but I had a bunch more to add the next day so I did not worry about it. I uninstalled all hue bulbs and hub as I was redoing almost every light then when done smartthings found the hub as usual found the bulbs but when I hit done got the same message that the list could not be saved. well a little research told me tp reboot the hue hub did not help reboot smartthigns did not help but now I can’t open the hue smart app. nothing happens I can’t choose add new phillips light nothing happens. three different phones one a android and nope rebooted everything nope. reset the router nope. though hue had a update yesterday and great smartthings found it but again would not save the bulb list. I rebooted again and now back to no able to open the smart app. Pdf course when I emailed smartthings I listed all I did I even included the weblink and they asked me to do all the things. sorry I can’t do them because I can’t open the smart app.