SmartThings Community

Pentair ScreenLogic

Has anyone gotten their IntelliQuick Screen Logic into ST? All I really need is notifications when programs run and the ability to turn in lights. Valves would be great but not needed within ST.

This is too funny! I went to search IntelliQuick Screen Logic on Google and this post is already in the google search results.

1 Like

I did try that first and I searched here but haven’t seen anything other than custom wired work.

I don’t have ScreenLogic and instead went with the cheaper Autelis controller option. I have been able to get that and ST working together along with Amazon Echo. See the details here: http://www.autelis.com/forum/viewtopic.php?f=13&t=561

I already have the pentair as that was what was offered with my pool

I have the screenlogic system also. I like it as far as setting schedules and controlling the variable speed pump and in floor cleaning system, but have not seen an easy way to integrate with smart things. There is an alexa skill but it doesn’t seem that useful, other than maybe asking what the temperature in the pool is. You could probably wire into the panel some relays where their spa side control buttons can be hooked up, but I have not tried. Just having smart things be able to turn on and off the pool light and features would be nice.

The Alexa integration is broken for me but it allows you to turn in the lights, turn on a feature (variable) and get the temp.

I have been really trying to integrate my Pentair into Smartthings. I have a spa side remote that I would like to control my Smartthings integrated devices.

After a lot of research I have come across this link. It looks promising and I am going to play around with it this weekend. It is definitely not plug and play, but it’s worth a shot!

Very curious to hear how this works out with you. I think that I am more interested in the opposite tho, I.E. controlling pool lights, spa circuit, air blower, etc from smart things scenes/routines instead of separately from the ScreenLogic app. I do not have the spa side remote, we basically use Iphone/Tablet as our only pool control. The main Pentair pannel is on the opposite side of the house and not easily accessable. I’ve toyed with the idea of z-wave relays wired into the pannel to emulate the spa side remote, but haven’t really dug into it that much.

If this works the way it says it does, there is an integration (device handler) fro Smartthings which would allow you to include pentair equipment in scenes, etc.

I installed the node.js component. However when I try to run it it tells me there is already another controller installed. I assume this is the pentair software running on my PC.

I think there was something released for the non intellitouch pentair systems at one point, this might be it? Not sure what they are called but lower line of pentair stuff than the intellitouch/screenlogic systems.

So that means my intellitouch is not supported?

I’m really not sure, I have not tried it.

Hi,
I’m the author of tagyoureit/nodejs-poolController. I have been working with @bsileo on the integration. It is still a work in progress, but much of the functionality already works (native web UI for the pool app as well as SmartThings integration from bsileo/SmartThings_Pentair). We’ve been working together on it.

First, you need to get my app up and running. Then you can work on installing the ST integration. If you need to chat about it your can find us in the Gitter Forums or open up an issue on my Github page.

cheers,
Tag

1 Like

We are talking on github. I had move my issue over there earlier. Thanks!

This integration is working pretty well, though there is always more things to do! The interface gives you full control of pumps, lights, and all auxiliary circuits. It also reports back all temperatures from the system. It is built on a model using child devices so that you can access and use all this functionality from any other SmartApps on your ST environment. Thus you can finally control the pool lights alongside all the rest of your outdoor lights!

That looks great!

Wow looks great. I can’t get it to run yet.

What issues are you having? Working to get the PoolController running or troubles on the SmartThings side of the integration?