Outage? Glitch? (11 December 2018)

I was working on some of my devices in the IDE, and then, after being in there for about 15-20 minutes, doing this and that, (note that point; i.e. it’s not like I just went in there and it wasn’t working from the beginning) all of a sudden, it kicked me out somehow, and now I can’t get back in.

Well…I can get logged in, and I can get to my devices, but it won’t let me save any changes to them.

When I click ‘Update’, I get the following on an otherwise blank white page…

Access to graph.api.smartthings.com was denied

You don’t have authorization to view this page.


EDIT: That ^^^ is in Chrome web browser, but when I tried it just now in Internet Explorer, it worked just fine.

In Chrome, I also completely logged out…i.e. all the way out, including making sure I was no longer logged in with Samsung SSO anywhere. Then, logged back in, and got the same thing.

So, is this being caused by an outage or a glitch of some sort, or what?

Chrome should work fine if you open the IDE in an incognito window. You can view without the incognito window but not write.


OK, but…wait…
What about the fact that I was indeed in there in Chrome, and was indeed successfully making changes, renaming things, creating and deleting devices, etc for a while, and then it suddenly stopped…i.e. during the same session during which I was able to do all of that stuff?

You’re not alone, I got the same result trying to update a device handler.

Edit Update: Looks like it’s a Chrome issue, I just tried it in Firefox and it worked fine.


I don’t know why you noticed a change in how Chrome works with the IDE during a session, but I can tell you that putting Chrome into incognito mode will allow you to make changes to IDE DTH’s and devices. Edge (if I recall correctly) also has this same issue - i.e., private window is needed.