"Access to graph.api.smartthings.com was denied"


(phil) #1

SO I went to edit one of my devices and got this. Even if I go to edit it and change nothing and hit update I get this error. Is something going on?


[RELEASE] NST Manager v5.0
(jkp) #2

working fine for me


(phil) #3

Hmmmm. Just tried to create a device and I get access denied

Access Denied
We’re sorry, but you are not authorized to perform the requested operation.


Unable to update DTH
(jkp) #4

I always login to IDE using https://account.smartthings.com


(phil) #5

logged out and logged back in and everything seems fine


(phil) #6

Take that back. Still cant create a new simulated deviceSome how my account is hosed


#7

I just had the same problem. Contact ST support. They had me log into the IDE in an incognito window in Chrome and that worked!!! There must be a cookies/browser data issue in Chrome so I’m going to clear data (when I have a chance) and that should clear it up. So, if you can log in and create a device in the incognito window, you know it’s a browser issue.


(Hendre) #8

I had the same issue yesterday (US Account)


(Phil) #9

I’ve had these issues as well. Specifically, not being able to update a SmartApp’s settings, editing an existing device, and adding a new device. And they’re intermittent - every once in a while it works, but usually I get the error. Per @Ryan780’s comments, I tried using a Chrome Incognito tab, and that worked for me, too!

I did contact SmartThings Support, but so far they’ve only suggested logging out and back in, which I’ve tried a zillion times but doesn’t help. Seems like so far they don’t know what the root cause is.


Access Denied?
(Olivier Cuny) #10

If using Chrome browser, use another. Chrome can have some session issues.


(jkp) #11

use an Incognito tab in Chrome to login to IDE and that should resolve the issue.