One of my Zwave light switches stopped responding

The switch works manually but won’t turn on or off via ST’s and it always shows as being on whether it is or not. All other switches are working fine. Is there a fix for this? Do I need to remove the switch and then add it back in?

@tonyfalcone, before doing that try turning off power to the switch at the breaker box and/or the air gap switch (if it has one).

Also, run a zwave repair via the IDE (more hub detail). If it comes back with “failed to update route…”, then you’ll need to force exclude and then add it back to ST. Support may have other recommendations as well.

Thanks John I tried all that but it still wasn’t responding so I just replaced it with a new switch that I had.

I am also having this issue. Ironically I also have two switches and one stopped working.

I just did a zwave repair and then clicked on “click here to see progress” this takes me to a hub events window with a filter “zwNwkRepair”. But nothing ever displays.

I am not sure how to debug this issue given the flakiness of the system these days.

@Ron whenever I initiate zwave repair and if you have Sonos connect or hue connect, I simply watch them in the IDE for failures or successful repairs. I have yet to see any intermediate status happening or may be I don’t know. Of course you are watching “all” in live logging you may see that zwave repair started or finished or some Issue. But that’s tedious to look and find thru so many messages. hue connect or Sonos connect listing never fails.

zwave repair did not work. But removal of all smart apps related to the switch, exclusion of the switch, include switch new (working again), add smart apps back in. Not too painful since I only had two smart apps but I lost the switch from my dashboard now since they don’t do that anymore :frowning:

But at least it works again !!!

I had three switches/plugs fall off last week. I think the second and 3rd happened when I ran the zwave repair. Never do that again!