Official DTH BUG


Hello, i have found a very annoying bug in an official dth that is breaking an important part of my automation, please samsung read this carefully and don’t ignore it.
The problem comes from multi metering switch dth that aeotec dual switch uses it by default.
What i’m trying to do is set parameter 123 to 2 and associate an external device to group 4.
I use zwave tweaker to do this,if i leave the tweaker as dth everything works fine, meaning the s2 physical switch won’t control its own load but will control an external one.
As soon as i change back from tweaker to multi metering switch, parameter 123( and 122) gets back on default value, group changes are fine
So it will basically end up controlling my external device BUT its own load turns on/off too.
What samsung needs to check is why the parameter is not remembered and reverted back to its original value.
I have tested the single nano switch from aeotec and i can confirm that same bug is not present and the paramaters values are preserved after changing back to its official dth too.
Here are the exact steps samsung needs to fallow to identify the bug.
I am using smartthings hub v3 UK and the problem is on aoetec nano dual switch last firmware.

-Change multi metering switch to zwave tweaker.

-Change parameter 123 to 2 (bug exists in parameter 122 too) and link your external device to group 4.

-Leave the zwave tweaker as dth and test the s2 physical switch.

-Boom, it works s2 changes the external device while NOT controlling his own load.

-Change back from zwave tweaker to multi metering switch dth.

-Bug appears, s2 will control his own load too even if parameter 123 is set to 2.

I believe there are isn.t any other compatible dth for this device that i can try

Not something I am familiar with, but a quick look at the DTH code suggests that it sends a command to reset the configuration of the Aeotec Nano Switch before sending it other configuration commands.

wow so i am right,could someone patch me up with a quick fixed dth?
ill try to look at it myself to see if understand it enough to edit it properly.
if i just remove this line
command “reset”
could it pottentially fix it?

This is a community forum. If you really want Samsung to see it and hopefully act, you need to submit a support ticket.

i sent an email to samsung as well, but i have a feeling they’ll just find some excuse and close their eyes or take months to fix it
i have more trust and hope that this comunnity would give me a quick fix, i think i something easy to fix if you are familiar with the language.

1 Like

Hi @Ady_Lupu, the reply from @orangebucket is spot on. ST does this with many of their DTH’s.

Don’t remove anything yet. Give me a sec to look through that code.

EDIT: Make a copy of the code and create your own DTH. All you need to do is make this change:

Basically comment out line 122 that sends the configuration reset command to the device. You’ll have to force a config again, but that should be automatic when you switch from ST’s DTH to yours.

1 Like

im at the location right now,i dont live there yet and is pretty far.been trying myself to play with the dth but no luck.ill wait here some more if you think you can patch me up

Look at my edits above. Just create your own copy of the DTH, comment out that line, edit the device to use Tweaker to change those parameters you want, and then switch to your DTH.

thank you , you are a life saver, this was bugging me for days
funny thing i already edited some lines myself including that along others since i know that device’s documentation like my house but didint worked since i probably broke something else, but after seeing your replay ive copied again the original dth and just commented that line and it works now, samsung should probably comment that line too
big thanks once again


Glad I was able to help!

1 Like