Aeotec Nano Dual Switch - secondary endpoint shows 'Offline'

Hi all.

I have an Aeotec Dual Nano Switch that controls a bathroom electric towel rail. I only use one of the 2 outputs on the switch, however for some reason the second endpoint always shows as ‘Offline’ in IDE. It’s more a cosmetic issue rather than anything major, but I wanted to sound out my issue with anyone on the forum to see if there is a fix for this please?

Below is a screenshot showing the Dual Switch, the first output is ‘En-suite Towel Rail’ and the second output is ‘z_Spare Switch’:

Be interesting to hear anyone from anyone else that has this type of device.

Many thanks,
Guy

I do not have any Aeotec devices but looking at your screenshot, I notice you are using a different device handler for each. Have you tried changing the device handler on that second device to match the first one?

1 Like

Sorted looks like matching the DTH has fixed it (I seem to recall trying to do this a few weeks ago, but for some reason it kept defaulting back to the ‘ZWave Binary Endpoint’ DTH after hitting save - looks like it has stuck now, thank you!

Spoke too soon, looks like it’s still showing as ‘Offline’ :frowning_face:

Removing and re-adding the device seems to have fixed it.

Looks like the DTH has also been reset to default (which might have been the issue).

Main switch DTH: Z-Wave Dual Switch
Secondary switch DTH: Z-Wave Binary Switch Endpoint