Aeotec Micro Switch Issues With Manual Operation

Hey all…I have an aeotec micro in wall switch which works fine for the most part, the app can turn it on and off, however, my issue is, when I use the actual wall switch, the device doesn’t update its status in smart things for a good while, sometimes as long as 30 minutes.

Doing some searching on here, there’s a post from a couple years ago that the device requires a specific device handler, however, the DH that was posted is no longer available on github. On another forum I see that I need to change parameter 80 to “basic.” I found z-wave tweaker on this forum and tried that, but it only allows me to change parameters to number values. I even tried to trick tweaker by copying the word basic and then pasting it in, but it deletes it before I can save the parameter.

Does anyone have a good DH for the aeotec micro, or another solution?


I haven’t had the micro in a while, but used to. If you look at page 7 in the gen 2 manual it looks like Parameter 80 needs a value of 2 to use Basic Reporting.

Hope that helps!

Yep, that did it! I should have checked the manual! Thanks! Used Z-Wave Tweaker to set parameter 80 to 2 and now I’m in business!


Which micro do you have? It should be using the ST device handler “Z-Wave Metering Switch”, which already sets parameter 80 to basic during configuration:

response(encap(zwave.configurationV1.configurationSet(parameterNumber: 80, size: 1, scaledConfigurationValue: 2)))

If for some reason the config didn’t run right, I don’t see an easy way to do that with the stock DTH unless you exclude and reinclude the device.

There’s hope though! I used ST’s stock DTH and created my own version. I set new parameter values to significantly increase reporting times (like all the time), and you can kick off a configuration cycle whenever you want by tapping on the power tile in the Classic app (or device settings), or in the new app go to the device’s settings (three dots in the upper right hand corner) and toggle the button and tap back (<). That’s a workaround for the new app until I can figure out a better way…

Anyway, If you want to give this a try, here you go:

Please NOTE, reporting times are set very high, so if you have a busy, congested, large, or unhealthy zwave mesh, you’ll want to set reporting values back to defaults, or something slower. I have less than 10 zwave devices, so this doesn’t impact me.

EDIT: this DTH assumes you have the metering version of the device, sorry about that.

Well, there is Zwave Tweaker - always my first tool for parameter changes (as the OP did).

True, but when going back to the original DTH, parameters get set back to what that specifies when configuration initiates. I like Tweaker for when developing my own DTH’s to take full advantage of the device’s capabilities that ST doesn’t. When the OP reverted back to stock, parameter 80 was already being configured to 2 in the stock handler, but for some reason that didn’t happen when first included.

Didn’t know know that changing the DTH would change Parametrrd on z-wave (doesn’t work that way on zigbrr

The device was using the Z-Wave Generic Switch DH by default. I used tweaker to change parameter 80 to 2, and it seemed to be working fine, however, the next day, after reading the responses to this thread, I tried it again and it smart things didn’t recognize the switch turning on and off (I only gave it a minute) so i figured based on John’s response that it didn’t stick.

I then switched to Z-Wave Metering Switch and that seems to have done the trick, as now, for a couple days, things have been working as they should.

Thanks for the help guys!

1 Like

Yup, and actually it will happen on any device using a stock handler. It all depends on the stock ST DTH and what parameters ST is changing. Some parameters that you can change with Tweaker will stick if ST’s handler doesn’t configure the same ones, OR if ST’s handler doesn’t use any factory resets parameters during a configuration cycle. They do that with the Aeon HEM device, some thermostats (zwave or zigbee - I have both), and a few others. Best way to know is to look at the stock DTH code.

1 Like

Cool - I learned something new! Don’t have as many z-wave devices as zigbees -so this hasn’t come up for me. I’m sure it will save me some frustration in the future if I have to work with z-wave DTHs! Thanks!

(Also, had no idea that could happen with Zigbee at all - as in your Aeon HEM device).

1 Like