[OBSOLETE] Updated Open Source Ecobee Device Type and SmartApps

I have an iPhone7+ , mini-iPad, no crashes here.

1 Like

Andrea - please let us know how it goes.

You might want to follow the even more detailed instructions linked at the top of my (updated just this morning) INSTALL document. Follow the Install Manually from Code directions, copying all FIVE of the SmartApps in my repository (previously there were only 3).

And don’t forget to enable OAuth forthe Ecobee (Connect) SmartApp.

Thank you for the spoon feeding :slight_smile:

I will try to get it done today / this evening.

Any ideas on why I can’t seem to UNINSTALL what I started Saturday night?

Some of the SA’s did uninstall, but there is 1 child all (circulation), the parent App (ecobee connect) that are still in the IDE. In the mobile app ONLY Ecobee connect is showing up in Automation/ SA

Things I have tried:
Delete circulation -

Delete Ecobee connect (which to my understanding ALL child apps have to be deleted first)


open and remove this is the error (I have also tried deselecting the ECOBEE & Living room entry THEN REMOVE = same result.

thanks for any suggestions!

You will have to remove the Ecobee Smart Circulation app from within the Ecobee (Connect) app - open it, select Helper Apps, and open any apps that show up there…then remove them. (These are “children” of the parent app, and as such are not visible at the top level of the Mobile App.

OR, you can delete them within the IDE - Open you Location, Select SmartApps, thing find Ecobee (Connect), open each (indented) child and delete them.

OR, don’t remove them at all - you don’t really have to. Just install the latest code for each SmartApp on top of the existing apps and then the two device handlers. Turn on OAuth for Ecobee (Connect), and then you should be able to open Ecobee (Connect) on your mobile device, sign in to your Ecobee account, and proceed with the configuration.

Yes this was a fresh install - 3 times actually.

The ST mobile app crashes unless I comment out :slight_smile:/**
multiAttributeTile(name:“tempSummary”, type:“thermostat”, width:6, height:4) {
tileAttribute(“device.temperatureDisplay”, key: “PRIMARY_CONTROL”) {
attributeState(“default”, label:’${currentValue}’, unit:“dF”)

		tileAttribute("device.temperature", key: "VALUE_CONTROL") {
            attributeState("default", action: "setTemperature")
        tileAttribute("device.humidity", key: "SECONDARY_CONTROL") {
			attributeState("default", label:'${currentValue}%', unit:"%")

		tileAttribute("device.thermostatOperatingState", key: "OPERATING_STATE") {
			attributeState("idle", backgroundColor:"#d28de0")			// ecobee purple/magenta
            attributeState("fan only", backgroundColor:"66cc00")		// ecobee green
			attributeState("heating", backgroundColor:"#ff9c14")		// ecobee snowflake blue
			attributeState("cooling", backgroundColor:"#2db9e7")		// ecobee flame orange
		tileAttribute("device.thermostatMode", key: "THERMOSTAT_MODE") {
			attributeState("off", label:'${name}')
			attributeState("heat", label:'${name}')
			attributeState("cool", label:'${name}')
            attributeState("auto", label:'${name}')
        tileAttribute("device.heatingSetpoint", key: "HEATING_SETPOINT") {
        	attributeState("default", label:'${currentValue}°', unit:"dF")
		tileAttribute("device.coolingSetpoint", key: "COOLING_SETPOINT") {
			attributeState("default", label:'${currentValue}°', unit:"dF")

	} // End multiAttributeTile


The ST app then no longer crashes but no data is displayed. If I hit refresh from the thermostat device I get the following from Live Logging



please believe me - I have tried everything I can think of !
Got on Support as I have spent hours to delete… they could not do it and elevated to engineering.

support message:
Thanks for waiting Andrea. We tried a few things from our end, but unfortunately did not have success. We are going to go ahead and iso this to get it resolved for you.

Our engineers will go ahead and go in and remove the smartapp smartthings : Delete(i renamed it)

I’m sorry to ask again, but did you enable OAuth for the Ecobee (Control) SmartApp?

I am getting on a cross-country flight, but if the wifi works, I will try to help you tonight (I’m in EST time zone, heading to PST).


I suggest re-installing everything again from my latest - that error is on a line that doesn’t add two nulls, in the middle of authorization, so something is screwey.

Yes I enabled OAuth. Enjoy your flight - we can catch up whenever - this isn’t your “day job” after all.
I am not THAT demanding haha.

Thanks Barry !

Update ! Engineering got it out of the IDE ! Checked the MOBILE APP - gone !

Clean slate - ready …set…go

David -

Have YOU enabled OAuth on Ecobee (Connect)?

The error message indiscate a problem with authentication, or a corrupted source file for Ecobee-thermostat.

Yes - and the sign in etc all seems to be fine

“Thumb typing is problematic for correct spelling”

So sorry, just trying to narrow down the issue.

Please reinstall the thermostat device…the error line referenced (1048) makes no sense…be sure to copy from the RAW tab on Github…


Thank you ! I have reinstalled all and I have used raw - all with the same outcome .
Interestingly the sensor has the same error @ line 1048

“Thumb typing is problematic for correct spelling”

After a number of refreshes:

Ok, I will look at again when I get my hotel.


David -

Grab the updated ecobee-connect.groovy (v0.10.6) - I can’t be positive it solves all of your problem, but I think it at least addresses why you weren’t seeing data after the initial configuration.

One suggestion - don’t hit the refresh button multiple times in rapid succession - it can take 5-10 seconds for a refresh to complete, because it has to request ALL the data from the Ecobee cloud again… I might need to put a throttle on that button - hitting it rapidly can cause a race condition…

Anyway, let me know if this works for you…if not, let me know.

Andrea -

You probably want to get the latest updated ecobee-connect.groovy as well (v0.10.6). Just copy/paste it over your current one, then Save and Publish it again…if you were still having startup problems, this probably fixes them (I hope :slight_smile: ).

When I try to run the app a box pops up that says “Sorry, but there was an unexpected error.” My only option is to go back or remove.