[OBSOLETE] Tibber

I have updated the official integration from Tibber to the new app and added some more parameters.

Original DH from Tibber and installation instructions can be found here:

My version is here:

Screenshot_20210325_113841

If you want to join Tibber, you can use my referral code and get 500NOK to buy smart devices. Du har blitt invitert til Tibber!

2 Likes

I get the following error message when try to create this SmartApp:

" No signature of method: script_app_metadata_9ca0c23f_e44b_43d7_8cb0_ec5111500704.metadata() is applicable for argument types: (script_app_metadata_9ca0c23f_e44b_43d7_8cb0_ec5111500704$_run_closure1) values: [script_app_metadata_9ca0c23f_e44b_43d7_8cb0_ec5111500704$_run_closure1@660eefb4] Possible solutions: getMetadata(), getState(), setState(java.lang.Object), metaClass(groovy.lang.Closure)"

@cscheiene ’s code is a DTH, not a smartapp. The message you got can happen if you add a DTH in as a smartapp. :thinking:

Did you put it into “My Device Handlers” in the IDE?

Or were you having problems with the original smartapp from the manufacturer?

In either case, be aware that since the groovy cloud will be turned off in a few months, both the smartapp and the DTH will stop working when that happens. So you might want to check with the device manufacturer to see if they are planning to provide an integration to the new SmartThings architecture. :thinking:

1 Like

with the original, I can see the currencies in the browser only, but not in my phone, it only says “connected”, and it is not possible to make any routines or anything.

with the updated version, I get no values what so ever… I suspect it might be due to missing home number, which it states should be 0 by default. but where can I find my actual home number id to use here?

not possible to make any routines with the updated version either, that was what I was looking for actually, so I was happy when I found this but then a bit disappointed again after all as it doesn’t work.

Make sure that your API key is correct. If you only have one home/location the home number is 0, the next would be 1, then 2 etc.

Routines should be working once you get data.


Hi, and thanks a lot for your reply, most appreciated :smiley:

The API key is correct and home is set to 0.
I know the key is correct because I’m using the same key for the original ST DH, where it works.
(but in the browser only though, and not in the phone app :confused: )

I’m actually able to use routines like you said,
even though the values are not displayed on the tile nor tile details.

However, I simplified it a bit by removing some of the tings I was not interested in, and now it works.
I’m basically only interested in the price, and the price level for making routines.

Here is the simplified version:
tibber-price-level-monitor.groovy

Also changed the tibber token url from type paragraph to link, as it was annoying having to copy the url :stuck_out_tongue:

@ cscheiene I noticed that the time interval is off by one hour. I’m in Norway, and when I write this it’s 08.37 in the morning. Price next Hour shows 07-08, and price in two hours 08-9.

I only use Price Level for my automations, but does it show correct current price level, when the time is off by one/two hours?

I see that here also. Price now and price level should be correct. Looks like there is something wrong with the summertime calculation for the price next hour

1 Like

@Geir_Skalvik1 New version uploaded, please test.

1 Like

Perfect, now it shows next hour 14-15 (time is 13:18), and in two hours 15-16

Thanks for all the work you do :slight_smile:

1 Like

Hi, is there any way to get Tibber information about my power consuption? (As I have the Tibber Pulse). It would be great to get how much energy have used so far this hour and what is the current peak power. This way, I can turn off devices to avoid to high peaks (for the Net tariff).

As I see that this is available in the Tibber API ( accumulatedConsumptionLastHour [Float] kWh consumed since since last hour shift)

accumulatedConsumptionLastHour is part of LiveMeasurement. It requiers the use of websockets, and the old groovy Device Handlers does not support that.

it doesn’t look like the price level is working. it never changes for me. it is always normal. in addition, I do not see names on the headings

I’m moving away from the ST plattform, so I’m not able to troubleshoot.

The missing titles is a known problem, not only for this device. Don’t know if ST has a fix for it yet.

Has anyone looked at an edge driver for this now that groovy disappears?